]> git.pld-linux.org Git - packages/Coin.git/blob - Coin.spec
- updated to 4.0.2
[packages/Coin.git] / Coin.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        High-level, retained-mode toolkit for effective 3D graphics development
6 Summary(pl.UTF-8):      Wysokopoziomowy toolkit do efektywnego rozwijania grafiki 3D
7 Name:           Coin
8 Version:        3.1.3
9 Release:        2
10 License:        GPL or Coin PEL or Coin EL
11 Group:          X11/Libraries
12 Source0:        https://bitbucket.org/Coin3D/coin/downloads/%{name}-%{version}.tar.gz
13 # Source0-md5:  1538682f8d92cdf03e845c786879fbea
14 Patch0:         %{name}-build.patch
15 Patch1:         %{name}-pc.patch
16 Patch2:         %{name}-format.patch
17 URL:            http://www.coin3d.org/
18 BuildRequires:  OpenGL-GLU-devel
19 BuildRequires:  OpenGL-devel
20 BuildRequires:  automake
21 BuildRequires:  bzip2-devel
22 BuildRequires:  doxygen
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  pkgconfig
25 BuildRequires:  xorg-lib-libX11-devel
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 High-level, retained-mode toolkit for effective 3D graphics
31 development. It's fully compatible with SGI Open Inventor 2.1.
32
33 %description -l pl.UTF-8
34 Wysokopoziomowy toolkit trybu przechowującego do efektywnego
35 rozwijania grafiki 3D. Jest w pełni kompatybilny z pakietem SGI Open
36 Inventor 2.1.
37
38 %package devel
39 Summary:        Header files for Coin3D library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Coin3D
41 Group:          X11/Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Obsoletes:      openinventor-devel
44 Obsoletes:      sgi-OpenInventor-devel
45
46 %description devel
47 Header files for Coin3D library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki Coin3D.
51
52 %package static
53 Summary:        Static Coin3D library
54 Summary(pl.UTF-8):      Statyczna biblioteka Coin3D
55 Group:          X11/Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static Coin3D library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka Coin3D.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67 %patch1 -p1
68 %patch2 -p1
69
70 %build
71 # must include COIN_INTERNAL and COIN_DEBUG in CFLAGS/CXXFLAGS, because
72 # internal CPPFLAGS are not propagated everywhere
73 CFLAGS="%{rpmcflags} -DCOIN_INTERNAL -DCOIN_DEBUG=0"
74 CXXFLAGS="%{rpmcxxflags} -DCOIN_INTERNAL -DCOIN_DEBUG=0"
75 %configure \
76         --enable-3ds-import \
77         --disable-debug \
78         --enable-java-wrapper \
79         --enable-man \
80         %{?with_static_libs:--enable-static} \
81         --enable-system-expat \
82         --enable-threadsafe
83
84 # FIXME: don't use global LIBS to fix libCoin.la linking
85 # (but cannot regenerate ac/am because of missing m4 files)
86 %{__make} \
87         LIBS="-ldl -lGL -lX11 -lpthread"
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 # sanitize file list
93 %{__sed} -i -ne '/^S/p' man/man3/filelist.txt
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 # obsoleted by pkg-config
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libCoin.la
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc AUTHORS COPYING ChangeLog FAQ FAQ.legal NEWS README README.UNIX RELNOTES THANKS
110 %attr(755,root,root) %{_libdir}/libCoin.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libCoin.so.60
112 %{_datadir}/%{name}
113 %exclude %{_datadir}/%{name}/conf/coin-default.cfg
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libCoin.so
118 %attr(755,root,root) %{_bindir}/coin-config
119 %{_datadir}/%{name}/conf/coin-default.cfg
120 %dir %{_includedir}/Inventor
121 %{_includedir}/Inventor/C
122 %{_includedir}/Inventor/VRMLnodes
123 %{_includedir}/Inventor/actions
124 %{_includedir}/Inventor/annex
125 %{_includedir}/Inventor/bundles
126 %{_includedir}/Inventor/caches
127 %{_includedir}/Inventor/collision
128 %{_includedir}/Inventor/details
129 %{_includedir}/Inventor/draggers
130 %{_includedir}/Inventor/elements
131 %{_includedir}/Inventor/engines
132 %{_includedir}/Inventor/errors
133 %{_includedir}/Inventor/events
134 %{_includedir}/Inventor/fields
135 %{_includedir}/Inventor/lists
136 %{_includedir}/Inventor/lock
137 %{_includedir}/Inventor/manips
138 %{_includedir}/Inventor/misc
139 %{_includedir}/Inventor/nodekits
140 %{_includedir}/Inventor/nodes
141 %{_includedir}/Inventor/projectors
142 %{_includedir}/Inventor/scxml
143 %{_includedir}/Inventor/sensors
144 %{_includedir}/Inventor/system
145 %{_includedir}/Inventor/threads
146 %{_includedir}/Inventor/tools
147 %{_includedir}/Inventor/Sb*.h
148 %{_includedir}/Inventor/So*.h
149 %{_includedir}/Inventor/non_winsys.h
150 %{_includedir}/Inventor/oivwin32.h
151 %{_includedir}/SoDebug.h
152 %{_includedir}/SoWinEnterScope.h
153 %{_includedir}/SoWinLeaveScope.h
154 %{_pkgconfigdir}/Coin.pc
155 %{_aclocaldir}/coin.m4
156 %{_mandir}/man1/coin-config.1*
157 %{_mandir}/man3/Sb*.3*
158 %{_mandir}/man3/Sc*.3*
159 %{_mandir}/man3/So*.3*
160
161 %if %{with static_libs}
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libCoin.a
165 %endif
This page took 0.074812 seconds and 3 git commands to generate.