]> git.pld-linux.org Git - packages/Coin.git/blame - Coin.spec
- added build patch (misc compile fixes)
[packages/Coin.git] / Coin.spec
CommitLineData
fe21aefb 1#
899bef05
JB
2# Conditional build:
3%bcond_without static_libs # static library
4#
fe21aefb 5Summary: High-level, retained-mode toolkit for effective 3D graphics development
899bef05 6Summary(pl.UTF-8): Wysokopoziomowy toolkit do efektywnego rozwijania grafiki 3D
fe21aefb
MK
7Name: Coin
8Version: 3.1.3
899bef05
JB
9Release: 1
10License: GPL or Coin PEL or Coin EL
466db9d4 11Group: X11/Libraries
899bef05 12Source0: https://bitbucket.org/Coin3D/coin/downloads/%{name}-%{version}.tar.gz
fe21aefb 13# Source0-md5: 1538682f8d92cdf03e845c786879fbea
899bef05
JB
14Patch0: %{name}-build.patch
15Patch1: %{name}-pc.patch
16Patch2: %{name}-format.patch
fe21aefb 17URL: http://www.coin3d.org/
899bef05 18BuildRequires: OpenAL-devel
466db9d4 19BuildRequires: OpenGL-GLU-devel
20BuildRequires: OpenGL-devel
899bef05
JB
21BuildRequires: bzip2-devel
22BuildRequires: fontconfig-devel
23BuildRequires: freetype-devel >= 2
24#BuildRequires: js-devel
466db9d4 25BuildRequires: libstdc++-devel
26BuildRequires: xorg-lib-libX11-devel
899bef05 27BuildRequires: zlib-devel
fe21aefb
MK
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
899bef05 30#define specflags -DCOIN_INTERNAL -DCOIN_DEBUG=0
fe21aefb 31
466db9d4 32%description
33High-level, retained-mode toolkit for effective 3D graphics
899bef05
JB
34development. It's fully compatible with SGI Open Inventor 2.1.
35
36%description -l pl.UTF-8
37Wysokopoziomowy toolkit trybu przechowującego do efektywnego
38rozwijania grafiki 3D. Jest w pełni kompatybilny z pakietem SGI Open
39Inventor 2.1.
fe21aefb
MK
40
41%package devel
899bef05
JB
42Summary: Header files for Coin3D library
43Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Coin3D
466db9d4 44Group: X11/Development/Libraries
14b3cc83 45Requires: %{name} = %{version}-%{release}
fe21aefb
MK
46
47%description devel
899bef05 48Header files for Coin3D library.
fe21aefb
MK
49
50%description devel -l pl.UTF-8
899bef05 51Pliki nagłówkowe biblioteki Coin3D.
fe21aefb 52
899bef05
JB
53%package static
54Summary: Static Coin3D library
55Summary(pl.UTF-8): Statyczna biblioteka Coin3D
56Group: X11/Development/Libraries
57Requires: %{name}-devel = %{version}-%{release}
fe21aefb 58
899bef05
JB
59%description static
60Static Coin3D library.
fe21aefb 61
899bef05
JB
62%description static -l pl.UTF-8
63Statyczna biblioteka Coin3D.
fe21aefb 64
899bef05
JB
65%prep
66%setup -q
67%patch0 -p1
68%patch1 -p1
69%patch2 -p1
fe21aefb
MK
70
71%build
899bef05
JB
72# must include COIN_INTERNAL and COIN_DEBUG in CFLAGS/CXXFLAGS, because
73# internal CPPFLAGS are not propagated everywhere
74CFLAGS="%{rpmcflags} -DCOIN_INTERNAL -DCOIN_DEBUG=0"
75CXXFLAGS="%{rpmcxxflags} -DCOIN_INTERNAL -DCOIN_DEBUG=0"
fe21aefb 76%configure \
899bef05
JB
77 --enable-3ds-import \
78 --disable-debug \
79 --enable-java-wrapper \
80 --enable-man \
81 %{?with_static_libs:--enable-static} \
82 --enable-system-expat \
83 --enable-threadsafe
84
85# FIXME: don't use global LIBS to fix libCoin.la linking
86# (but cannot regenerate ac/am because of missing m4 files)
14b3cc83 87%{__make} \
8fb758e7 88 LIBS="-ldl -lGL -lX11 -lpthread"
fe21aefb
MK
89
90%install
91rm -rf $RPM_BUILD_ROOT
899bef05
JB
92
93# sanitize file list
94%{__sed} -i -ne '/^S/p' man/man3/filelist.txt
fe21aefb
MK
95
96%{__make} install \
97 DESTDIR=$RPM_BUILD_ROOT
98
899bef05
JB
99# obsoleted by pkg-config
100%{__rm} $RPM_BUILD_ROOT%{_libdir}/libCoin.la
101
fe21aefb
MK
102%clean
103rm -rf $RPM_BUILD_ROOT
104
fe21aefb
MK
105%post -p /sbin/ldconfig
106%postun -p /sbin/ldconfig
fe21aefb 107
fe21aefb
MK
108%files
109%defattr(644,root,root,755)
899bef05 110%doc AUTHORS COPYING ChangeLog FAQ FAQ.legal NEWS README README.UNIX RELNOTES THANKS
14b3cc83 111%attr(755,root,root) %{_bindir}/coin-config
466db9d4 112%attr(755,root,root) %{_libdir}/libCoin.so.*.*.*
899bef05 113%attr(755,root,root) %ghost %{_libdir}/libCoin.so.60
fe21aefb 114%{_datadir}/%{name}
899bef05 115%{_mandir}/man1/coin-config.1*
fe21aefb 116
14b3cc83 117%files devel
fe21aefb 118%defattr(644,root,root,755)
899bef05
JB
119%attr(755,root,root) %{_libdir}/libCoin.so
120%dir %{_includedir}/Inventor
121%{_includedir}/Inventor/C
122%{_includedir}/Inventor/VRMLnodes
123%{_includedir}/Inventor/actions
124%{_includedir}/Inventor/annex
125%{_includedir}/Inventor/bundles
126%{_includedir}/Inventor/caches
127%{_includedir}/Inventor/collision
128%{_includedir}/Inventor/details
129%{_includedir}/Inventor/draggers
130%{_includedir}/Inventor/elements
131%{_includedir}/Inventor/engines
132%{_includedir}/Inventor/errors
133%{_includedir}/Inventor/events
134%{_includedir}/Inventor/fields
135%{_includedir}/Inventor/lists
136%{_includedir}/Inventor/lock
137%{_includedir}/Inventor/manips
138%{_includedir}/Inventor/misc
139%{_includedir}/Inventor/nodekits
140%{_includedir}/Inventor/nodes
141%{_includedir}/Inventor/projectors
142%{_includedir}/Inventor/scxml
143%{_includedir}/Inventor/sensors
144%{_includedir}/Inventor/system
145%{_includedir}/Inventor/threads
146%{_includedir}/Inventor/tools
147%{_includedir}/Inventor/Sb*.h
148%{_includedir}/Inventor/So*.h
149%{_includedir}/Inventor/non_winsys.h
150%{_includedir}/Inventor/oivwin32.h
14b3cc83
MK
151%{_includedir}/SoDebug.h
152%{_includedir}/SoWinEnterScope.h
153%{_includedir}/SoWinLeaveScope.h
899bef05
JB
154%{_pkgconfigdir}/Coin.pc
155%{_aclocaldir}/coin.m4
156%{_mandir}/man3/Sb*.3*
157%{_mandir}/man3/Sc*.3*
158%{_mandir}/man3/So*.3*
159
160%if %{with static_libs}
161%files static
162%defattr(644,root,root,755)
163%{_libdir}/libCoin.a
164%endif
This page took 0.114959 seconds and 4 git commands to generate.