]> git.pld-linux.org Git - packages/CodeIgniter.git/blob - CodeIgniter.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/CodeIgniter.git] / CodeIgniter.spec
1 %define         php_min_version 5.2.4
2 %include        /usr/lib/rpm/macros.php
3 Summary:        A powerful PHP framework with a very small footprint
4 Name:           CodeIgniter
5 Version:        2.2.2
6 Release:        0.1
7 License:        other
8 Group:          Development/Languages/PHP
9 Source0:        https://github.com/bcit-ci/CodeIgniter/archive/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  042f94f7c59b22111c7cf56673769c8b
11 Source1:        INSTALL-PLD.txt
12 Source2:        codeigniter-install
13 Patch0:         pld.patch
14 URL:            http://codeigniter.com/
15 BuildRequires:  rpm-php-pearprov >= 4.3
16 BuildRequires:  rpmbuild(macros) >= 1.461
17 BuildRequires:  sed >= 4.0
18 BuildRequires:  unzip
19 Requires:       php(core) >= %{php_min_version}
20 Requires:       php(ctype)
21 Requires:       php(date)
22 Requires:       php(hash)
23 Requires:       php(mbstring)
24 Requires:       php(mysql)
25 Requires:       php(pcre)
26 Requires:       php(session)
27 Requires:       php(simplexml)
28 Requires:       php(spl)
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _appdir         %{_datadir}/%{name}
33
34 %description
35 CodeIgniter is a powerful PHP framework with a very small footprint,
36 built for PHP coders who need a simple and elegant toolkit to create
37 full-featured web applications. If you're a developer who lives in the
38 real world of shared hosting accounts and clients with deadlines, and
39 if you're tired of ponderously large and thoroughly undocumented
40 frameworks.
41
42 %package doc
43 Summary:        CodeIgniter documentation
44 Group:          Development/Languages/PHP
45
46 %description doc
47 CodeIgniter documentation.
48
49 %prep
50 %setup -q
51 %patch0 -p1
52
53 cp -p %{SOURCE1} user_guide
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir}}
58 cp -r index.php application system $RPM_BUILD_ROOT%{_appdir}
59 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}
60
61 find $RPM_BUILD_ROOT%{_datadir}/%{name} -name index.html | xargs rm -v
62 rm -r $RPM_BUILD_ROOT%{_appdir}/application/{cache,core,helpers,hooks,libraries}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 %banner -e %{name} <<-EOF
69 Please read INSTALL-PLD.txt to know how can use the users the installed CodeIgniter!
70 EOF
71
72 %files
73 %defattr(644,root,root,755)
74 %attr(755,root,root) %{_bindir}/codeigniter-install
75
76 %dir %{_appdir}
77 %dir %{_appdir}/application
78 %dir %{_appdir}/application/config
79 %dir %{_appdir}/application/controllers
80 %dir %{_appdir}/application/errors
81 %dir %{_appdir}/application/language
82 %dir %{_appdir}/application/views
83 %dir %{_appdir}/system
84 %dir %{_appdir}/system/core
85 %dir %{_appdir}/system/database
86 %dir %{_appdir}/system/database/drivers
87 %dir %{_appdir}/system/fonts
88 %dir %{_appdir}/system/helpers
89 %dir %{_appdir}/system/language
90 %dir %{_appdir}/system/libraries
91
92 %{_appdir}/index.php
93 %{_appdir}/application/.htaccess
94 %{_appdir}/system/.htaccess
95
96 %{_appdir}/application/config/*
97 %{_appdir}/application/controllers/*
98 %{_appdir}/application/errors/*
99 %{_appdir}/application/language/*
100 %{_appdir}/application/views/*
101
102 %{_appdir}/system/core/*
103 %{_appdir}/system/database/DB*.php
104 %{_appdir}/system/database/drivers/*
105 %{_appdir}/system/fonts/*
106 %{_appdir}/system/helpers/*
107 %{_appdir}/system/language/*
108 %{_appdir}/system/libraries/*
109
110 %files doc
111 %defattr(644,root,root,755)
112 %doc user_guide/*
This page took 0.064707 seconds and 3 git commands to generate.