]> git.pld-linux.org Git - packages/CodeIgniter.git/blame - CodeIgniter.spec
inline sed, especially with line numbers, is not reliable. patch it
[packages/CodeIgniter.git] / CodeIgniter.spec
CommitLineData
db1f333d
ZU
1%define php_min_version 5.2.4
2%include /usr/lib/rpm/macros.php
3Summary: A powerful PHP framework with a very small footprint
4Name: CodeIgniter
dd4c63e3 5Version: 2.1.2
6acbfc9d 6Release: 0.9
db1f333d
ZU
7License: other
8Group: Development/Languages/PHP
9Source0: http://www.codeigniter.com/download_files/reactor/%{name}_%{version}.zip
dd4c63e3 10# Source0-md5: c7a2980dff2774c97bd38bfbf450d8d5
f4d15a2e 11Source1: INSTALL-PLD.txt
16ac96a4 12Source2: codeigniter-install
e854ff37 13Patch0: pld.patch
3d01a3e7 14URL: http://codeigniter.com/
db1f333d
ZU
15BuildRequires: rpm-php-pearprov >= 4.3
16BuildRequires: rpmbuild(macros) >= 1.461
17BuildRequires: sed >= 4.0
18BuildRequires: unzip
5682686a
ER
19Requires: php(core) >= %{php_min_version}
20Requires: php(ctype)
21Requires: php(date)
22Requires: php(hash)
23Requires: php(mbstring)
24Requires: php(mysql)
25Requires: php(pcre)
26Requires: php(session)
27Requires: php(simplexml)
28Requires: php(spl)
db1f333d
ZU
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%define _appdir %{_datadir}/%{name}
db1f333d
ZU
33
34%description
35CodeIgniter is a powerful PHP framework with a very small footprint,
36built for PHP coders who need a simple and elegant toolkit to create
37full-featured web applications. If you're a developer who lives in the
38real world of shared hosting accounts and clients with deadlines, and
39if you're tired of ponderously large and thoroughly undocumented
40frameworks.
41
6acbfc9d
ZU
42%package doc
43Summary: CodeIgniter documentation
44Group: Development/Languages/PHP
45
46%description doc
47CodeIgniter documentation.
48
db1f333d
ZU
49%prep
50%setup -q -n %{name}_%{version}
e854ff37 51%patch0 -p1
db1f333d
ZU
52
53%install
54rm -rf $RPM_BUILD_ROOT
db1f333d 55install -d $RPM_BUILD_ROOT%{_appdir}
db1f333d
ZU
56cp -r index.php application system $RPM_BUILD_ROOT%{_appdir}
57cp -r user_guide/* $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
5682686a
ER
58
59install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
60cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
db1f333d 61
16ac96a4 62install -d $RPM_BUILD_ROOT%{_bindir}
5682686a 63install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}
16ac96a4 64
6acbfc9d
ZU
65find $RPM_BUILD_ROOT%{_datadir}/%{name} -name index.html -delete
66
67rm -rf $RPM_BUILD_ROOT%{_appdir}/application/{cache,core,helpers,hooks,libraries}
68
db1f333d
ZU
69%clean
70rm -rf $RPM_BUILD_ROOT
71
f4d15a2e
ZU
72%post
73%banner -e %{name} <<-EOF
74Please read INSTALL-PLD.txt to know how can use the users the installed CodeIgniter!
75EOF
db1f333d
ZU
76
77%files
78%defattr(644,root,root,755)
16ac96a4 79%attr(755,root,root) %{_bindir}/codeigniter-install
6acbfc9d
ZU
80
81%dir %{_appdir}
82%dir %{_appdir}/application
83%dir %{_appdir}/application/config
84%dir %{_appdir}/application/controllers
85%dir %{_appdir}/application/errors
86%dir %{_appdir}/application/language
87%dir %{_appdir}/application/views
88%dir %{_appdir}/system
89%dir %{_appdir}/system/core
90%dir %{_appdir}/system/database
91%dir %{_appdir}/system/database/drivers
92%dir %{_appdir}/system/fonts
93%dir %{_appdir}/system/helpers
94%dir %{_appdir}/system/language
95%dir %{_appdir}/system/libraries
96
97%{_appdir}/index.php
98%{_appdir}/application/.htaccess
99%{_appdir}/system/.htaccess
100
101%{_appdir}/application/config/*
102%{_appdir}/application/controllers/*
103%{_appdir}/application/errors/*
104%{_appdir}/application/language/*
105%{_appdir}/application/views/*
106
107%{_appdir}/system/core/*
108%{_appdir}/system/database/DB*.php
109%{_appdir}/system/database/drivers/*
110%{_appdir}/system/fonts/*
111%{_appdir}/system/helpers/*
112%{_appdir}/system/language/*
113%{_appdir}/system/libraries/*
114
115%files doc
116%defattr(644,root,root,755)
117%doc %{_docdir}/%{name}-%{version}
This page took 0.084714 seconds and 4 git commands to generate.