]> git.pld-linux.org Git - packages/CodeEditor.git/blob - CodeEditor.spec
- tabs in preamle
[packages/CodeEditor.git] / CodeEditor.spec
1 Summary:        Code Editor for Objective C
2 Summary(pl.UTF-8):      Edytor kodu dla języka Objective C
3 Name:           CodeEditor
4 Version:        0.4.4
5 Release:        5
6 License:        GPL
7 Group:          X11/Applications
8 Source0:        http://savannah.nongnu.org/download/codeeditor/%{name}-%{version}.tar.gz
9 # Source0-md5:  396cc3b9a51a7f045fe53800c98723e0
10 Patch0:         %{name}-pass-arguments.patch
11 URL:            http://www.nongnu.org/codeeditor/
12 BuildRequires:  gnustep-gui-devel >= 0.8.7
13 Requires:       gnustep-gui >= 0.8.7
14 Requires:       %{name}-libs = %{version}-%{release}
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %define         _prefix         /usr/%{_lib}/GNUstep
18
19 %define         libcombo        gnu-gnu-gnu
20 %define         gsos            linux-gnu
21 %ifarch %{ix86}
22 %define         gscpu           ix86
23 %else
24 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
25 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
26 %endif
27 %define         appdir          %{_prefix}/System/Applications/CodeEditor.app
28 %define         supportdir      %{_prefix}/System/Library/ApplicationSupport/CodeEditorView
29
30 %description
31 CodeEditor is a programmer's editor and library for GNUstep.
32
33 %description -l pl.UTF-8
34 CodeEditor jest edytorem programisty i biblioteką dla GNUstepa.
35
36 %package libs
37 Summary:        CodeEditorView bundle
38 Summary(pl.UTF-8):      Paczka CodeEditorView
39 Group:          Development/Tools
40
41 %description libs
42 CodeEditorView bundle for embedding CodeEditor in other apps.
43
44 %description libs -l pl.UTF-8
45 Paczka CodeEditorView do osadzania CodeEditora w innych aplikacjach.
46
47 %package devel
48 Summary:        CodeEditorView bundle headers
49 Summary(pl.UTF-8):      Pliki nagłówkowe paczki CodeEditorView
50 Group:          Development/Tools
51 Requires:       %{name}-libs = %{version}-%{release}
52
53 %description devel
54 CodeEditorView bundle headers.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe paczki CodeEditorView.
58
59 %prep
60 %setup -q -n CodeEditor
61 %patch0 -p1
62
63 %build
64 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
65 %{__make} \
66         OPTFLAG="%{rpmcflags}" \
67         messages=yes
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
72
73 %{__make} install \
74         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc README TODO
82 %dir %{appdir}
83 %attr(755,root,root) %{appdir}/%{name}
84 %dir %{appdir}/Resources
85 %{appdir}/Resources/*.desktop
86 %{appdir}/Resources/*.plist
87 %{appdir}/Resources/*.tiff
88 %{appdir}/Resources/*.gorm
89 %{appdir}/Resources/Scripts
90 %dir %{appdir}/%{gscpu}
91 %dir %{appdir}/%{gscpu}/%{gsos}
92 %dir %{appdir}/%{gscpu}/%{gsos}/%{libcombo}
93 %attr(755,root,root) %{appdir}/%{gscpu}/%{gsos}/%{libcombo}/%{name}
94 %{appdir}/%{gscpu}/%{gsos}/%{libcombo}/*.openapp
95
96 %files libs
97 %defattr(644,root,root,755)
98 %dir %{_prefix}/System/Library/Bundles/CodeEditorView.bundle
99 %dir %{_prefix}/System/Library/Bundles/CodeEditorView.bundle/%{gscpu}
100 %dir %{_prefix}/System/Library/Bundles/CodeEditorView.bundle/%{gscpu}/%{gsos}
101 %dir %{_prefix}/System/Library/Bundles/CodeEditorView.bundle/%{gscpu}/%{gsos}/%{libcombo}
102 %{_prefix}/System/Library/Bundles/CodeEditorView.bundle/%{gscpu}/%{gsos}/%{libcombo}/CodeEditorView
103 %dir %{_prefix}/System/Library/Bundles/CodeEditorView.bundle/Resources
104 %{_prefix}/System/Library/Bundles/CodeEditorView.bundle/Resources/OpenInWorkspace.tiff
105 %{_prefix}/System/Library/Bundles/CodeEditorView.bundle/Resources/Info-gnustep.plist
106 %dir %{supportdir}
107 %dir %{supportdir}/ObjCHandler.bundle
108 %dir %{supportdir}/ObjCHandler.bundle/Resources
109 %{supportdir}/ObjCHandler.bundle/Resources/*.plist
110 %dir %{supportdir}/ObjCHandler.bundle/%{gscpu}
111 %dir %{supportdir}/ObjCHandler.bundle/%{gscpu}/%{gsos}
112 %dir %{supportdir}/ObjCHandler.bundle/%{gscpu}/%{gsos}/%{libcombo}
113 %{supportdir}/ObjCHandler.bundle/%{gscpu}/%{gsos}/%{libcombo}/ObjCHandler
114
115 #%files devel
116 #%defattr(644,root,root,755)
117 #%{_prefix}/System/Library/Headers/CodeEditorView
This page took 0.074587 seconds and 3 git commands to generate.