]> git.pld-linux.org Git - packages/Carla.git/commitdiff
Version: v1.9.9 auto/th/Carla-2.0-0.beta7.1
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Thu, 13 Sep 2018 11:27:10 +0000 (13:27 +0200)
committerJacek Konieczny <j.konieczny@eggsoft.pl>
Thu, 13 Sep 2018 11:27:10 +0000 (13:27 +0200)
some built-in plugins have been moved to a separate repository and they
won't build properly on Linux

Carla.spec
mmap_error.patch [deleted file]
param_update.patch [deleted file]

index b32083c5d95121833d2c73c30b9ee61e9e3cd753..26ee23abd453262563dd18ede2ad6875db5c7c53 100644 (file)
@@ -1,9 +1,12 @@
-# git tag is 1.9.8, but release name is 2.0-beta6
-# https://github.com/falkTX/Carla/releases/tag/1.9.8
-%define        tag     1.9.8
+# git tag is 1.9.9, but release name is 2.0-beta7
+# https://github.com/falkTX/Carla/releases/tag/1.9.9
+%define        tag     v1.9.9
 
-%define        beta    beta6
-%define        rel     5
+# current revision of source/native-plugins/external git submodule
+%define plugins_rev  98723d7
+
+%define        beta    beta7
+%define        rel     1
 Summary:       Audio plugin host
 Name:          Carla
 Version:       2.0
@@ -11,11 +14,11 @@ Release:    0.%{beta}.%{rel}
 License:       GPL v2+
 Group:         Applications
 Source0:       https://github.com/falkTX/Carla/archive/%{tag}/%{name}-%{tag}.tar.gz
-# Source0-md5: 279acb33716327c82516d6edb8ff6d13
+# Source0-md5: a583ccc17c12156c985b1b3154f42800
+#Source1:      https://github.com/falkTX/Carla-Plugins/archive/%{plugins_rev}/Carla-Plugins-%{plugins_rev}.tar.gz
+## Source1-md5:        b8bb65277e724d022b7ed54ead4bc286
 Patch0:                pypkgdir.patch
 Patch1:                soundfonts_path.patch
-Patch2:                param_update.patch
-Patch3:                mmap_error.patch
 URL:           http://kxstudio.linuxaudio.org/Applications:Carla
 BuildRequires: Mesa-libGL-devel
 BuildRequires: Qt5Core-devel
@@ -62,16 +65,33 @@ Header files for %{name} library.
 Pliki nagłówkowe biblioteki %{name}.
 
 %prep
-%setup -q -n %{name}-%{tag}
+%setup -q -n %{name}-1.9.9
+
+#rmdir source/native-plugins/external
+#mv Carla-Plugins-%{plugins_rev}* source/native-plugins/external
 
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
 
 %build
-%{__make} -j1 \
+# to make sure all needed features are available
+%{__make} -j1 features \
+       EXTERNAL_PLUGINS=false \
+       SKIP_STRIPPING=true \
+       CC="%{__cc}" \
+       CXX="%{__cxx}" \
+       CFLAGS="%{rpmcflags}" \
+       CXXFLAGS="%{rpmcxxflags}" \
+       LDFLAGS="%{rpmldflags}" \
+       PREFIX=%{_prefix} \
+       PYUIC4=%{_bindir}/pyuic4-3 \
+       PYUIC5=%{_bindir}/pyuic5-3 \
+       PYUIC=%{_bindir}/pyuic5-3 \
+       LIBDIR=%{_libdir}
+
+%{__make} -j1 all \
        --trace \
+       EXTERNAL_PLUGINS=false \
        SKIP_STRIPPING=true \
        CC="%{__cc}" \
        CXX="%{__cxx}" \
@@ -141,7 +161,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/carla-control.desktop
 %dir %{_datadir}/carla
 %dir %{_datadir}/carla/resources
-%{_datadir}/carla/resources/zynaddsubfx
+#%{_datadir}/carla/resources/zynaddsubfx
 %{_datadir}/carla/resources/*.py
 %{_datadir}/carla/resources/__pycache__
 %attr(755,root,root) %{_datadir}/carla/carla-control
@@ -152,7 +172,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_datadir}/carla/resources/carla-plugin-patchbay
 %attr(755,root,root) %{_datadir}/carla/resources/midipattern-ui
 %attr(755,root,root) %{_datadir}/carla/resources/notes-ui
-%attr(755,root,root) %{_datadir}/carla/resources/zynaddsubfx-ui
+#%attr(755,root,root) %{_datadir}/carla/resources/zynaddsubfx-ui
 %{_datadir}/carla/*.py
 %{_datadir}/carla/__pycache__
 %{_datadir}/carla/carla
diff --git a/mmap_error.patch b/mmap_error.patch
deleted file mode 100644 (file)
index 41a9d31..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/source/utils/CarlaShmUtils.hpp b/source/utils/CarlaShmUtils.hpp
-index 71ca6f0f..3ed53159 100644
---- a/source/utils/CarlaShmUtils.hpp
-+++ b/source/utils/CarlaShmUtils.hpp
-@@ -199,7 +199,11 @@ void* carla_shm_map(carla_shm_t& shm, const std::size_t size) noexcept
-         void* const ptr(::mmap(nullptr, size, PROT_READ|PROT_WRITE, MAP_SHARED|MAP_LOCKED, shm.fd, 0));
--        if (ptr == nullptr)
-+        if (ptr == MAP_FAILED) {
-+            carla_stderr("mmap failed: %s", std::strerror(errno));
-+            return nullptr;
-+        }
-+        else if (ptr == nullptr)
-         {
-             carla_safe_assert("ptr != nullptr", __FILE__, __LINE__);
-             return nullptr;
-
diff --git a/param_update.patch b/param_update.patch
deleted file mode 100644 (file)
index 8a30b87..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
-From afed293c3ea13ea68dc4bb3368021b43be8f3e32 Mon Sep 17 00:00:00 2001
-From: falkTX <falktx@gmail.com>
-Date: Sun, 25 Feb 2018 23:42:43 +0100
-Subject: [PATCH] Fix for built-in parameter widgets not always updating
-
----
- source/carla_skin.py           | 2 +-
- source/carla_widgets.py        | 2 +-
- source/widgets/paramspinbox.py | 8 ++++----
- 3 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/source/carla_skin.py b/source/carla_skin.py
-index 49eec8061..696690c92 100755
---- a/source/carla_skin.py
-+++ b/source/carla_skin.py
-@@ -1227,7 +1227,7 @@ def slot_knobCustomMenu(self):
-         else:
-             return
--        self.sender().setValue(value)
-+        sender.setValue(value, True)
-     #------------------------------------------------------------------
-diff --git a/source/carla_widgets.py b/source/carla_widgets.py
-index 4e43083c5..6013a1dcc 100755
---- a/source/carla_widgets.py
-+++ b/source/carla_widgets.py
-@@ -1409,7 +1409,7 @@ def slot_knobCustomMenu(self):
-         else:
-             return
--        self.sender().setValue(value)
-+        sender.setValue(value, True)
-     #------------------------------------------------------------------
-diff --git a/source/widgets/paramspinbox.py b/source/widgets/paramspinbox.py
-index ad89641c4..e7495923d 100644
---- a/source/widgets/paramspinbox.py
-+++ b/source/widgets/paramspinbox.py
-@@ -160,6 +160,9 @@ def setValue(self, value):
-         else:
-             vper = float(value - self.fMinimum) / div
-+        if self.fValueCall is not None:
-+            self.fValueCall(value)
-+
-         QProgressBar.setValue(self, int(vper * 10000))
-     def setLabel(self, label):
-@@ -192,10 +195,7 @@ def handleMouseEventPos(self, pos):
-         elif value > self.fMaximum:
-             value = self.fMaximum
--        if self.fValueCall is not None:
--            self.fValueCall(value)
--
--        self.valueChanged.emit(value)
-+        self.setValue(value)
-     def mousePressEvent(self, event):
-         if event.button() == Qt.LeftButton:
This page took 0.068605 seconds and 4 git commands to generate.