]> git.pld-linux.org Git - packages/CUnit.git/commitdiff
- compile fixes
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 29 Nov 2005 22:41:40 +0000 (22:41 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    CUnit-FHS.patch -> 1.1
    CUnit-curses.patch -> 1.1
    CUnit-libs.patch -> 1.1

CUnit-FHS.patch [new file with mode: 0644]
CUnit-curses.patch [new file with mode: 0644]
CUnit-libs.patch [new file with mode: 0644]

diff --git a/CUnit-FHS.patch b/CUnit-FHS.patch
new file mode 100644 (file)
index 0000000..0d193fc
--- /dev/null
@@ -0,0 +1,56 @@
+--- ./doc/Makefile.am~ 2004-10-01 00:38:27.000000000 +0300
++++ ./doc/Makefile.am  2005-11-30 00:06:17.000000000 +0200
+@@ -1,4 +1,4 @@
+-docdir = $(prefix)/doc/@PACKAGE@
++docdir = $(datadir)/doc/@PACKAGE@-@VERSION@/html
+ doc_DATA = \
+       CUnit_doc.css \
+--- ./doc/headers/Makefile.am~ 2005-04-28 00:56:16.000000000 +0300
++++ ./doc/headers/Makefile.am  2005-11-30 00:10:47.000000000 +0200
+@@ -1,4 +1,4 @@
+-dochdrdir = $(prefix)/doc/@PACKAGE@/headers
++dochdrdir = $(datadir)/doc/@PACKAGE@-@VERSION@/headers
+ INCLUDE_FILES = \
+       Automated.h \
+--- ./Examples/AutomatedTest/Makefile.am~      2005-11-30 00:15:58.000000000 +0200
++++ ./Examples/AutomatedTest/Makefile.am       2005-11-30 00:19:16.000000000 +0200
+@@ -1,4 +1,4 @@
+-exampledir=${datadir}/@PACKAGE@/Examples/Automated
++exampledir=$(libdir)/@PACKAGE@/Examples/Automated
+ example_PROGRAMS = AutomatedTest
+--- ./Examples/BasicTest/Makefile.am~  2005-11-30 00:15:58.000000000 +0200
++++ ./Examples/BasicTest/Makefile.am   2005-11-30 00:20:07.000000000 +0200
+@@ -1,4 +1,4 @@
+-exampledir=${datadir}/@PACKAGE@/Examples/Basic
++exampledir=$(libdir)/@PACKAGE@/Examples/Basic
+ example_PROGRAMS = BasicTest
+--- ./Examples/ConsoleTest/Makefile.am~        2005-11-30 00:15:58.000000000 +0200
++++ ./Examples/ConsoleTest/Makefile.am 2005-11-30 00:20:17.000000000 +0200
+@@ -1,4 +1,4 @@
+-exampledir=${datadir}/@PACKAGE@/Examples/Console
++exampledir=$(libdir)/@PACKAGE@/Examples/Console
+ example_PROGRAMS = ConsoleTest
+--- ./Examples/CursesTest/Makefile.am~ 2005-11-30 00:15:58.000000000 +0200
++++ ./Examples/CursesTest/Makefile.am  2005-11-30 00:20:27.000000000 +0200
+@@ -1,4 +1,4 @@
+-exampledir=${datadir}/@PACKAGE@/Examples/Curses
++exampledir=$(libdir)/@PACKAGE@/Examples/Curses
+ example_PROGRAMS = CursesTest
+--- ./CUnit/Sources/Test/Makefile.am~  2004-10-01 00:38:10.000000000 +0300
++++ ./CUnit/Sources/Test/Makefile.am   2005-11-30 00:25:09.000000000 +0200
+@@ -1,4 +1,4 @@
+-testdir=${datadir}/@PACKAGE@/Test
++testdir=$(libdir)/@PACKAGE@/Test
+ test_PROGRAMS = test_cunit
+ test_cunit_SOURCES = test_cunit.c
diff --git a/CUnit-curses.patch b/CUnit-curses.patch
new file mode 100644 (file)
index 0000000..d5d0057
--- /dev/null
@@ -0,0 +1,11 @@
+--- ./CUnit/Sources/Curses/Curses.c~   2005-04-26 02:27:32.000000000 +0300
++++ ./CUnit/Sources/Curses/Curses.c    2005-11-29 23:54:44.000000000 +0200
+@@ -53,7 +53,7 @@
+ #include <assert.h>
+ #include <string.h>
+ #include <math.h>
+-#include <curses.h>
++#include <ncurses/curses.h>
+ #include "CUnit.h"
+ #include "TestDB.h"
diff --git a/CUnit-libs.patch b/CUnit-libs.patch
new file mode 100644 (file)
index 0000000..ce05e1c
--- /dev/null
@@ -0,0 +1,44 @@
+--- ./Examples/AutomatedTest/Makefile.am~      2004-10-01 00:38:25.000000000 +0300
++++ ./Examples/AutomatedTest/Makefile.am       2005-11-29 23:56:29.000000000 +0200
+@@ -3,7 +3,7 @@
+ example_PROGRAMS = AutomatedTest
+ AutomatedTest_SOURCES = AutomatedTest.c AutomatedTest.h 
+-AutomatedTest_LDADD = -lcunit -lcunitexamples
++AutomatedTest_LDADD = -lcunit -lcunitexamples -lm
+ AutomatedTest_LDFLAGS = -L..
+ INCLUDES = -I..
+--- ./Examples/BasicTest/Makefile.am~  2004-10-01 00:38:25.000000000 +0300
++++ ./Examples/BasicTest/Makefile.am   2005-11-29 23:59:50.000000000 +0200
+@@ -3,7 +3,7 @@
+ example_PROGRAMS = BasicTest
+ BasicTest_SOURCES = BasicTest.c BasicTest.h
+-BasicTest_LDADD = -lcunit -lcunitexamples
++BasicTest_LDADD = -lcunit -lcunitexamples -lm
+ BasicTest_LDFLAGS = -L..
+ INCLUDES = -I..
+--- ./Examples/ConsoleTest/Makefile.am~        2004-10-01 00:38:25.000000000 +0300
++++ ./Examples/ConsoleTest/Makefile.am 2005-11-30 00:00:33.000000000 +0200
+@@ -3,7 +3,7 @@
+ example_PROGRAMS = ConsoleTest
+ ConsoleTest_SOURCES = ConsoleTest.c ConsoleTest.h
+-ConsoleTest_LDADD = -lcunit -lcunitexamples
++ConsoleTest_LDADD = -lcunit -lcunitexamples -lm
+ ConsoleTest_LDFLAGS = -L..
+ INCLUDES = -I..
+--- ./Examples/CursesTest/Makefile.am~ 2004-10-01 00:38:25.000000000 +0300
++++ ./Examples/CursesTest/Makefile.am  2005-11-30 00:01:27.000000000 +0200
+@@ -3,7 +3,7 @@
+ example_PROGRAMS = CursesTest
+ CursesTest_SOURCES = CursesTest.c CursesTest.h
+-CursesTest_LDADD = -lcunit -lcunitexamples -lncurses
++CursesTest_LDADD = -lcunit -lcunitexamples -lncurses -lm
+ CursesTest_LDFLAGS = -L..
+ INCLUDES = -I..
This page took 0.120652 seconds and 4 git commands to generate.