]> git.pld-linux.org Git - packages/COLAMD.git/blob - COLAMD.spec
- pl
[packages/COLAMD.git] / COLAMD.spec
1 Summary:        COLAMD: column approximate minimum degree
2 Summary(pl.UTF-8):      COLAMD - przybliżony algorytm minimalnego stopnia dla kolumn
3 Name:           colamd
4 Version:        2.6.0
5 Release:        0.2
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://www.cise.ufl.edu/research/sparse/colamd/COLAMD-%{version}.tar.gz
9 # Source0-md5:  49e185756896c1e918a535ec409c48b9
10 Patch0:         %{name}-ufconfig.patch
11 Patch1:         %{name}-shared.patch
12 URL:            http://www.cise.ufl.edu/research/sparse/colamd/
13 BuildRequires:  UFconfig
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 The COLAMD column approximate minimum degree ordering algorithm
18 computes a permutation vector P such that the LU factorization of A
19 (:,P) tends to be sparser than that of A. The Cholesky factorization
20 of (A (:,P))'*(A (:,P)) will also tend to be sparser than that of
21 A'*A. SYMAMD is a symmetric minimum degree ordering method based on
22 COLAMD, available as a MATLAB-callable function. It constructs a
23 matrix M such that M'*M has the same pattern as A, and then uses
24 COLAMD to compute a column ordering of M. Colamd and symamd tend to be
25 faster and generate better orderings than their MATLAB counterparts,
26 colmmd and symmmd.
27
28 %description -l pl.UTF-8
29 Przybliżony algorytm porządkowania minimalnego stopnia dla kolumn
30 (COLAMD) oblicza wektor permutacji P taki, że rozkład LU A (:,P) jest
31 bardziej rzadki niż A. Rozkład Cholesky'ego (A (:,P))'*(A (:,P)) także
32 jest rzadszy niż A'*A. SYMAND to przybliżony algorytm porządkowania
33 minimalnego stopnia dla macierzy symetrycznych oparty na COLAMD,
34 dostępny jako funkcja do wywołania z MATLAB-a. Tworzy macierz M taką,
35 że M'*M ma ten sam wzór co A, a następnie używa algorytmu COLAMD do
36 obliczenia porządku kolumn M. COLAMD i SYMAMD są szybsze i generują
37 lepsze uporządkowania niż ich odpowiedniki z MATLAB-a: colmmd i
38 symmmd.
39
40 %package devel
41 Summary:        Header files for colamd library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki colamd
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       UFconfig
46
47 %description devel
48 Header files for colamd library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki colamd.
52
53 %package static
54 Summary:        Static colamd library
55 Summary(pl.UTF-8):      Statyczna biblioteka colamd
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static colamd library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka colamd.
64
65 %prep
66 %setup -q -n COLAMD
67 %patch0 -p1
68 %patch1 -p1
69
70 %build
71 %{__make} \
72         CC="%{__cc}" \
73         CFLAGS="%{rpmcflags}"
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 install -D colamd.h $RPM_BUILD_ROOT%{_includedir}/colamd.h
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post   -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %doc README.txt
91 %attr(755,root,root) %{_libdir}/libcolamd.so.*.*.*
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/libcolamd.so
96 %{_libdir}/libcolamd.la
97 %{_includedir}/colamd.h
98
99 %files static
100 %defattr(644,root,root,755)
101 %{_libdir}/libcolamd.a
This page took 0.07975 seconds and 4 git commands to generate.