]> git.pld-linux.org Git - packages/COLAMD.git/blob - COLAMD.spec
- new
[packages/COLAMD.git] / COLAMD.spec
1 Summary:        COLAMD: column approximate minimum degree
2 Name:           colamd
3 Version:        2.6.0
4 Release:        0.1
5 License:        LGPL
6 Group:          Libraries
7 Source0:        http://www.cise.ufl.edu/research/sparse/colamd/COLAMD-%{version}.tar.gz
8 # Source0-md5:  49e185756896c1e918a535ec409c48b9
9 URL:            http://www.cise.ufl.edu/research/sparse/colamd/
10 Patch0:         %{name}-ufconfig.patch
11 BuildRequires:  UFconfig
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 The COLAMD column approximate minimum degree ordering algorithm
16 computes a permutation vector P such that the LU factorization of A
17 (:,P) tends to be sparser than that of A. The Cholesky factorization
18 of (A (:,P))'*(A (:,P)) will also tend to be sparser than that of
19 A'*A. SYMAMD is a symmetric minimum degree ordering method based on
20 COLAMD, available as a MATLAB-callable function. It constructs a
21 matrix M such that M'*M has the same pattern as A, and then uses
22 COLAMD to compute a column ordering of M. Colamd and symamd tend to be
23 faster and generate better orderings than their MATLAB counterparts,
24 colmmd and symmmd.
25
26 %package devel
27 Summary:        Header files for colamd library
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30 Requires:       UFconfig
31
32 %description devel
33 Header files for colamd library.
34
35 %package static
36 Summary:        Static colamd library
37 Group:          Development/Libraries
38 Requires:       %{name}-devel = %{version}-%{release}
39
40 %description static
41 Static colamd library.
42
43 %prep
44 %setup -q -n COLAMD
45 %patch0 -p1
46
47 %build
48 %{__make} \
49         CC="%{__cc}" \
50         CFLAGS="%{rpmcflags}"
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
55 cp -a colamd.h $RPM_BUILD_ROOT%{_includedir}
56 cp -a libcolamd.a $RPM_BUILD_ROOT%{_libdir}/libcolamd.a
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README.txt
64
65 %files devel
66 %defattr(644,root,root,755)
67 %{_includedir}/colamd.h
68
69 %files static
70 %defattr(644,root,root,755)
71 %{_libdir}/libcolamd.a
This page took 0.068227 seconds and 4 git commands to generate.