]> git.pld-linux.org Git - packages/COLAMD.git/blob - COLAMD.spec
- fix SuiteSparse_config BR
[packages/COLAMD.git] / COLAMD.spec
1 Summary:        COLAMD: column approximate minimum degree
2 Summary(pl.UTF-8):      COLAMD - przybliżony algorytm minimalnego stopnia dla kolumn
3 Name:           COLAMD
4 Version:        2.9.0
5 Release:        3
6 License:        LGPL v2.1+
7 Group:          Libraries
8 Source0:        http://www.cise.ufl.edu/research/sparse/colamd/%{name}-%{version}.tar.gz
9 # Source0-md5:  6a636d88f4ee6475a5ae2513a1a27544
10 Patch0:         colamd-ufconfig.patch
11 Patch1:         colamd-shared.patch
12 URL:            http://www.cise.ufl.edu/research/sparse/colamd/
13 BuildRequires:  SuiteSparse_config-devel >= 4.3.0
14 BuildRequires:  libtool >= 2:1.5
15 Requires:       SuiteSparse_config-libs >= 4.3.0
16 Obsoletes:      colamd
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The COLAMD column approximate minimum degree ordering algorithm
21 computes a permutation vector P such that the LU factorization of A
22 (:,P) tends to be sparser than that of A. The Cholesky factorization
23 of (A (:,P))'*(A (:,P)) will also tend to be sparser than that of
24 A'*A. SYMAMD is a symmetric minimum degree ordering method based on
25 COLAMD, available as a MATLAB-callable function. It constructs a
26 matrix M such that M'*M has the same pattern as A, and then uses
27 COLAMD to compute a column ordering of M. Colamd and symamd tend to be
28 faster and generate better orderings than their MATLAB counterparts,
29 colmmd and symmmd.
30
31 %description -l pl.UTF-8
32 Przybliżony algorytm porządkowania minimalnego stopnia dla kolumn
33 (COLAMD) oblicza wektor permutacji P taki, że rozkład LU A (:,P) jest
34 bardziej rzadki niż A. Rozkład Cholesky'ego (A (:,P))'*(A (:,P)) także
35 jest rzadszy niż A'*A. SYMAND to przybliżony algorytm porządkowania
36 minimalnego stopnia dla macierzy symetrycznych oparty na COLAMD,
37 dostępny jako funkcja do wywołania z MATLAB-a. Tworzy macierz M taką,
38 że M'*M ma ten sam wzór co A, a następnie używa algorytmu COLAMD do
39 obliczenia porządku kolumn M. COLAMD i SYMAMD są szybsze i generują
40 lepsze uporządkowania niż ich odpowiedniki z MATLAB-a: colmmd i
41 symmmd.
42
43 %package devel
44 Summary:        Header files for COLAMD library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki COLAMD
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       SuiteSparse_config >= 4.3.0
49 Obsoletes:      colamd-devel
50
51 %description devel
52 Header files for COLAMD library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki COLAMD.
56
57 %package static
58 Summary:        Static COLAMD library
59 Summary(pl.UTF-8):      Statyczna biblioteka COLAMD
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62 Obsoletes:      colamd-static
63
64 %description static
65 Static COLAMD library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka COLAMD.
69
70 %prep
71 %setup -q -n %{name}
72 %patch0 -p1
73 %patch1 -p1
74
75 %build
76 %{__make} \
77         CC="%{__cc}" \
78         CFLAGS="%{rpmcflags}" \
79         LDFLAGS="%{rpmldflags}" \
80         libdir=%{_libdir}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{_includedir}/colamd
85
86 %{__make} -C Lib install \
87         DESTDIR=$RPM_BUILD_ROOT \
88         libdir=%{_libdir}
89
90 install Include/*.h $RPM_BUILD_ROOT%{_includedir}/colamd
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc README.txt Doc/ChangeLog
101 %attr(755,root,root) %{_libdir}/libcolamd.so.*.*.*
102 %attr(755,root,root) %ghost %{_libdir}/libcolamd.so.0
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libcolamd.so
107 %{_libdir}/libcolamd.la
108 %{_includedir}/colamd
109
110 %files static
111 %defattr(644,root,root,755)
112 %{_libdir}/libcolamd.a
This page took 0.068772 seconds and 3 git commands to generate.