]> git.pld-linux.org Git - packages/COLAMD.git/blob - COLAMD.spec
- really updated
[packages/COLAMD.git] / COLAMD.spec
1 Summary:        COLAMD: column approximate minimum degree
2 Summary(pl.UTF-8):      COLAMD - przybliżony algorytm minimalnego stopnia dla kolumn
3 Name:           colamd
4 Version:        2.6.0
5 Release:        0.2
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://www.cise.ufl.edu/research/sparse/colamd/COLAMD-%{version}.tar.gz
9 # Source0-md5:  49e185756896c1e918a535ec409c48b9
10 Patch0:         %{name}-ufconfig.patch
11 Patch1:         %{name}-shared.patch
12 URL:            http://www.cise.ufl.edu/research/sparse/colamd/
13 BuildRequires:  UFconfig
14 BuildRequires:  libtool >= 2:1.5
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 The COLAMD column approximate minimum degree ordering algorithm
19 computes a permutation vector P such that the LU factorization of A
20 (:,P) tends to be sparser than that of A. The Cholesky factorization
21 of (A (:,P))'*(A (:,P)) will also tend to be sparser than that of
22 A'*A. SYMAMD is a symmetric minimum degree ordering method based on
23 COLAMD, available as a MATLAB-callable function. It constructs a
24 matrix M such that M'*M has the same pattern as A, and then uses
25 COLAMD to compute a column ordering of M. Colamd and symamd tend to be
26 faster and generate better orderings than their MATLAB counterparts,
27 colmmd and symmmd.
28
29 %description -l pl.UTF-8
30 Przybliżony algorytm porządkowania minimalnego stopnia dla kolumn
31 (COLAMD) oblicza wektor permutacji P taki, że rozkład LU A (:,P) jest
32 bardziej rzadki niż A. Rozkład Cholesky'ego (A (:,P))'*(A (:,P)) także
33 jest rzadszy niż A'*A. SYMAND to przybliżony algorytm porządkowania
34 minimalnego stopnia dla macierzy symetrycznych oparty na COLAMD,
35 dostępny jako funkcja do wywołania z MATLAB-a. Tworzy macierz M taką,
36 że M'*M ma ten sam wzór co A, a następnie używa algorytmu COLAMD do
37 obliczenia porządku kolumn M. COLAMD i SYMAMD są szybsze i generują
38 lepsze uporządkowania niż ich odpowiedniki z MATLAB-a: colmmd i
39 symmmd.
40
41 %package devel
42 Summary:        Header files for colamd library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki colamd
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       UFconfig
47
48 %description devel
49 Header files for colamd library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki colamd.
53
54 %package static
55 Summary:        Static colamd library
56 Summary(pl.UTF-8):      Statyczna biblioteka colamd
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static colamd library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka colamd.
65
66 %prep
67 %setup -q -n COLAMD
68 %patch0 -p1
69 %patch1 -p1
70
71 %build
72 %{__make} \
73         CC="%{__cc}" \
74         CFLAGS="%{rpmcflags}" \
75         libdir=%{_libdir}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT \
82         libdir=%{_libdir}
83
84 install -D colamd.h $RPM_BUILD_ROOT%{_includedir}/colamd.h
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %files
93 %defattr(644,root,root,755)
94 %doc README.txt
95 %attr(755,root,root) %{_libdir}/libcolamd.so.*.*.*
96
97 %files devel
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/libcolamd.so
100 %{_libdir}/libcolamd.la
101 %{_includedir}/colamd.h
102
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/libcolamd.a
This page took 0.088307 seconds and 3 git commands to generate.