]> git.pld-linux.org Git - packages/COLAMD.git/blame - COLAMD.spec
- create shared library using libtool
[packages/COLAMD.git] / COLAMD.spec
CommitLineData
2b824273
ER
1Summary: COLAMD: column approximate minimum degree
2Name: colamd
3Version: 2.6.0
4Release: 0.1
5License: LGPL
6Group: Libraries
7Source0: http://www.cise.ufl.edu/research/sparse/colamd/COLAMD-%{version}.tar.gz
8# Source0-md5: 49e185756896c1e918a535ec409c48b9
9URL: http://www.cise.ufl.edu/research/sparse/colamd/
10Patch0: %{name}-ufconfig.patch
11BuildRequires: UFconfig
12BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14%description
15The COLAMD column approximate minimum degree ordering algorithm
16computes a permutation vector P such that the LU factorization of A
17(:,P) tends to be sparser than that of A. The Cholesky factorization
18of (A (:,P))'*(A (:,P)) will also tend to be sparser than that of
19A'*A. SYMAMD is a symmetric minimum degree ordering method based on
20COLAMD, available as a MATLAB-callable function. It constructs a
21matrix M such that M'*M has the same pattern as A, and then uses
22COLAMD to compute a column ordering of M. Colamd and symamd tend to be
23faster and generate better orderings than their MATLAB counterparts,
24colmmd and symmmd.
25
26%package devel
27Summary: Header files for colamd library
28Group: Development/Libraries
29Requires: %{name} = %{version}-%{release}
30Requires: UFconfig
31
32%description devel
33Header files for colamd library.
34
35%package static
36Summary: Static colamd library
37Group: Development/Libraries
38Requires: %{name}-devel = %{version}-%{release}
39
40%description static
41Static colamd library.
42
43%prep
44%setup -q -n COLAMD
45%patch0 -p1
46
47%build
48%{__make} \
49 CC="%{__cc}" \
50 CFLAGS="%{rpmcflags}"
51
52%install
53rm -rf $RPM_BUILD_ROOT
54install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
55cp -a colamd.h $RPM_BUILD_ROOT%{_includedir}
56cp -a libcolamd.a $RPM_BUILD_ROOT%{_libdir}/libcolamd.a
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
63%doc README.txt
64
65%files devel
66%defattr(644,root,root,755)
67%{_includedir}/colamd.h
68
69%files static
70%defattr(644,root,root,755)
71%{_libdir}/libcolamd.a
This page took 0.038603 seconds and 4 git commands to generate.