]> git.pld-linux.org Git - packages/CHOLMOD.git/commitdiff
- updated to 2.1.1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 20 Apr 2013 06:41:02 +0000 (08:41 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 20 Apr 2013 06:41:02 +0000 (08:41 +0200)
- updated ufconfig,shared patches

CHOLMOD-shared.patch
CHOLMOD-ufconfig.patch
CHOLMOD.spec

index 4b64dbeb8f2eb5e35765fb54dcca7fda91aeecb9..8148d670c49048abfad46fbba546b73d9bf9ddbc 100644 (file)
@@ -1,28 +1,45 @@
---- CHOLMOD/Demo/Makefile.orig 2012-08-28 19:15:59.367085674 +0200
-+++ CHOLMOD/Demo/Makefile      2012-08-28 19:27:39.750404409 +0200
-@@ -16,24 +16,17 @@
- CONFIG = -DNPARTITION
- # check if METIS is requested and available
- ifeq (,$(findstring -DNPARTITION, $(CHOLMOD_CONFIG)))
--    # METIS is requested.  See if it is available
--    ifeq ($(METIS_PATH), $(wildcard $(METIS_PATH)))
--        ifeq (../../CAMD, $(wildcard ../../CAMD))
--            ifeq (../../CCOLAMD, $(wildcard ../../CCOLAMD))
--                # METIS, CAMD, and CCOLAMD are available
--                LIB_WITH_PARTITION = $(METIS) ../../CCOLAMD/Lib/libccolamd.a \
--                    ../../CAMD/Lib/libcamd.a
--                I_WITH_PARTITION = -I$(METIS_PATH)/Lib \
--                    -I../../CCOLAMD/Include -I../../CAMD/Include
-+    # METIS is requested.
-+    ifeq ($(WITH_METIS), 1)
-+                LIB_WITH_PARTITION = -lmetis -lccolamd -lcamd
-+                I_WITH_PARTITION = -I/usr/include/metis \
-+                    -I/usr/include/ccolamd -I/usr/include/camd
-                 CONFIG =
--            endif
+--- CHOLMOD/Demo/Makefile.orig 2013-04-20 07:49:10.121084286 +0200
++++ CHOLMOD/Demo/Makefile      2013-04-20 08:00:24.634389311 +0200
+@@ -14,38 +14,30 @@
+ # CAMD and CCOLAMD can be installed without METIS, but are optional.
+ I_WITH_PARTITION = 
+ LIB_WITH_PARTITION =
+-CONFIG = -DNPARTITION -DNCAMD
++CONFIG = -DNPARTITION
+ # check if CAMD/CCOLAMD and METIS are requested and available
+ ifeq (,$(findstring -DNCAMD, $(CHOLMOD_CONFIG)))
+-    # CAMD and CCOLAMD are requested.  See if they are available
+-    ifeq (../../CAMD, $(wildcard ../../CAMD))
+-        ifeq (../../CCOLAMD, $(wildcard ../../CCOLAMD))
++    # CAMD and CCOLAMD are requested. Assume they are available
+             # CAMD and CCOLAMD are requested and available
+             LIB_WITH_PARTITION = \
+-                        ../../CCOLAMD/Lib/libccolamd.a ../../CAMD/Lib/libcamd.a
++                        -lccolamd -lcamd
+             I_WITH_PARTITION = \
+-                        -I../../CCOLAMD/Include -I../../CAMD/Include
++                        -I/usr/include/ccolamd -I/usr/include/camd
+             CONFIG = -DNPARTITION
+             # check if METIS is requested and available
+             ifeq (,$(findstring -DNPARTITION, $(CHOLMOD_CONFIG)))
+-                # METIS is requested.  See if it is available
+-                ifeq ($(METIS_PATH), $(wildcard $(METIS_PATH)))
++                # METIS is requested.  Assume it is available
+                     # METIS is available
+-                    LIB_WITH_PARTITION = $(METIS) \
+-                        ../../CCOLAMD/Lib/libccolamd.a ../../CAMD/Lib/libcamd.a
+-                    I_WITH_PARTITION = -I$(METIS_PATH)/Lib \
+-                        -I../../CCOLAMD/Include -I../../CAMD/Include
++                    LIB_WITH_PARTITION = -lmetis -lccolamd -lcamd
++                    I_WITH_PARTITION = -I/usr/include/metis \
++                        -I/usr/include/ccolamd -I/usr/include/camd
+                     CONFIG =
+-                endif
+             endif
 -        endif
-     endif
+-    endif
  endif
  #-------------------------------------------------------------------------------
  
 -LIB2 = ../Lib/libcholmod.a ../../AMD/Lib/libamd.a ../../COLAMD/Lib/libcolamd.a \
@@ -31,7 +48,7 @@
        $(LIB_WITH_PARTITION) $(LAPACK) $(BLAS) $(XERBLA) $(LIB)
  
  #-------------------------------------------------------------------------------
-@@ -75,35 +68,25 @@
+@@ -88,39 +80,26 @@
  #-------------------------------------------------------------------------------
  # See below if you compile with -DNPARTITION
  library:
        ( cd ../Lib ; $(MAKE) )
 -      ( cd ../../AMD ; $(MAKE) library )
 -      ( cd ../../COLAMD ; $(MAKE) library )
--ifneq (,$(findstring -DNPARTITION, $(CONFIG)))
+-ifneq (,$(findstring -DCAMD, $(CONFIG)))
 -else
 -      ( cd ../../CCOLAMD ; $(MAKE) library )
 -      ( cd ../../CAMD ; $(MAKE) library )
+-endif
+-ifneq (,$(findstring -DNPARTITION, $(CONFIG)))
+-else
 -      ( cd $(METIS_PATH) && $(MAKE) )
 -endif
  #-------------------------------------------------------------------------------
  
  I = -I../Include
  
  readhb2: readhb2.f
 -      $(F77) $(FFLAGS) -O -o readhb2 readhb2.f
-+      $(F77) $(LDFLAGS) $(FFLAGS) -O -o readhb2 readhb2.f
++      $(F77) $(LDFLAGS) -O $(FFLAGS) -o readhb2 readhb2.f
  
  reade: reade.f
 -      $(F77) $(FFLAGS) -O -o reade reade.f
-+      $(F77) $(LDFLAGS) $(FFLAGS) -O -o reade reade.f
---- CHOLMOD/Lib/Makefile.orig  2012-08-28 19:15:59.367085674 +0200
-+++ CHOLMOD/Lib/Makefile       2012-08-28 19:15:59.397085673 +0200
-@@ -33,14 +33,14 @@
++      $(F77) $(LDFLAGS) -O $(FFLAGS) -o reade reade.f
+--- CHOLMOD/Lib/Makefile.orig  2013-04-20 07:45:02.304428018 +0200
++++ CHOLMOD/Lib/Makefile       2013-04-20 07:48:37.427752323 +0200
+@@ -43,14 +43,14 @@
  
  C = $(CC) $(CF) $(CHOLMOD_CONFIG) $(CONFIG)
  
  
  clean:
        - $(RM) $(CLEAN)
-@@ -132,9 +132,13 @@
+@@ -144,9 +144,13 @@
  # to compile just the double/int version, use OBJ = $(DI)
  OBJ = $(DI) $(DL)
  
  
  $(OBJ): $(INC)
  
-@@ -143,24 +147,24 @@
+@@ -155,24 +159,24 @@
  #-------------------------------------------------------------------------------
  
  cholmod_check.o: ../Check/cholmod_check.c
  
  
  #-------------------------------------------------------------------------------
-@@ -168,92 +172,92 @@
+@@ -180,98 +184,98 @@
  #-------------------------------------------------------------------------------
  
  cholmod_common.o: ../Core/cholmod_common.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  cholmod_dense.o: ../Core/cholmod_dense.c ../Core/t_cholmod_dense.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  cholmod_factor.o: ../Core/cholmod_factor.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  cholmod_change_factor.o: ../Core/cholmod_change_factor.c \
        ../Core/t_cholmod_change_factor.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  cholmod_memory.o: ../Core/cholmod_memory.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  cholmod_sparse.o: ../Core/cholmod_sparse.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  cholmod_complex.o: ../Core/cholmod_complex.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  cholmod_transpose.o: ../Core/cholmod_transpose.c ../Core/t_cholmod_transpose.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  cholmod_band.o: ../Core/cholmod_band.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  cholmod_copy.o: ../Core/cholmod_copy.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  cholmod_triplet.o: ../Core/cholmod_triplet.c ../Core/t_cholmod_triplet.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  cholmod_error.o: ../Core/cholmod_error.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  cholmod_aat.o: ../Core/cholmod_aat.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  cholmod_add.o: ../Core/cholmod_add.c
 -      $(C) -c $(I) $<
-+      libtool --tag=CC --mode=compile $(C) $(I) -c $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
+ cholmod_version.o: ../Core/cholmod_version.c
+-      $(C) -c $(I) $<
++      libtool --tag=CC --mode=compile $(C) -c $(I) $<
  
  #-------------------------------------------------------------------------------
  
  cholmod_l_common.o: ../Core/cholmod_common.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  cholmod_l_dense.o: ../Core/cholmod_dense.c ../Core/t_cholmod_dense.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  cholmod_l_factor.o: ../Core/cholmod_factor.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  cholmod_l_change_factor.o: ../Core/cholmod_change_factor.c \
        ../Core/t_cholmod_change_factor.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  cholmod_l_memory.o: ../Core/cholmod_memory.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  cholmod_l_sparse.o: ../Core/cholmod_sparse.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  cholmod_l_complex.o: ../Core/cholmod_complex.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  cholmod_l_transpose.o: ../Core/cholmod_transpose.c ../Core/t_cholmod_transpose.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  cholmod_l_band.o: ../Core/cholmod_band.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  cholmod_l_copy.o: ../Core/cholmod_copy.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  cholmod_l_triplet.o: ../Core/cholmod_triplet.c ../Core/t_cholmod_triplet.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  cholmod_l_error.o: ../Core/cholmod_error.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  cholmod_l_aat.o: ../Core/cholmod_aat.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  cholmod_l_add.o: ../Core/cholmod_add.c
 -      $(C) -DDLONG -c $(I) $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -DDLONG $(I) -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
+ cholmod_l_version.o: ../Core/cholmod_version.c
+-      $(C) -DDLONG -c $(I) $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $(I) $< -o $@
  
  
  #-------------------------------------------------------------------------------
-@@ -261,116 +265,116 @@
+@@ -279,116 +283,116 @@
  #-------------------------------------------------------------------------------
  
  cholmod_amd.o: ../Cholesky/cholmod_amd.c
  
  
  #-------------------------------------------------------------------------------
-@@ -378,88 +382,88 @@
+@@ -396,88 +400,88 @@
  #-------------------------------------------------------------------------------
  
  cholmod_horzcat.o: ../MatrixOps/cholmod_horzcat.c
  
  
  #-------------------------------------------------------------------------------
-@@ -469,24 +473,24 @@
+@@ -487,24 +491,24 @@
  cholmod_super_numeric.o: ../Supernodal/cholmod_super_numeric.c \
          ../Supernodal/t_cholmod_gpu.c \
        ../Supernodal/t_cholmod_super_numeric.c
index e68f4bd7a40654ad9290cc6424321aafcec91d96..e70aa78925a120bef2f763bdb1fcb8f59b100751 100644 (file)
@@ -53,9 +53,9 @@ diff -ur CHOLMOD/Include/cholmod_internal.h CHOLMOD-uf/Include/cholmod_internal.
  
  /* -------------------------------------------------------------------------- */
  /* Size_max: the largest value of size_t */
---- CHOLMOD/Lib/Makefile.orig  2012-06-21 07:35:19.000000000 +0200
-+++ CHOLMOD/Lib/Makefile       2012-08-28 19:15:04.193753493 +0200
-@@ -6,7 +6,7 @@
+--- CHOLMOD/Lib/Makefile.orig  2013-04-15 22:11:51.000000000 +0200
++++ CHOLMOD/Lib/Makefile       2013-04-20 07:40:54.087771768 +0200
+@@ -6,45 +6,38 @@
  
  ccode: all
  
@@ -63,30 +63,46 @@ diff -ur CHOLMOD/Include/cholmod_internal.h CHOLMOD-uf/Include/cholmod_internal.
 +include /usr/share/misc/SuiteSparse_config.mk
  
  #-------------------------------------------------------------------------------
- # the optional Partition module requires METIS, CAMD, and CCOLAMD
-@@ -15,24 +15,19 @@
- CONFIG = -DNPARTITION
- # check if METIS is requested and available
- ifeq (,$(findstring -DNPARTITION, $(CHOLMOD_CONFIG)))
--    # METIS is requested.  See if it is available
--    ifeq ($(METIS_PATH), $(wildcard $(METIS_PATH)))
--        ifeq (../../CAMD, $(wildcard ../../CAMD))
--            ifeq (../../CCOLAMD, $(wildcard ../../CCOLAMD))
-+    # METIS is requested.
-+    ifeq ($(WITH_METIS), 1)
-                 # METIS, CAMD, and CCOLAMD are available
--                LIB_WITH_PARTITION = $(METIS) ../../CCOLAMD/Lib/libccolamd.a \
--                    ../../CAMD/Lib/libcamd.a
--                I_WITH_PARTITION = -I$(METIS_PATH)/Lib \
--                    -I../../CCOLAMD/Include -I../../CAMD/Include
-+                LIB_WITH_PARTITION = -lmetis -lccolamd -lcamd
-+                I_WITH_PARTITION = -I/usr/include/metis \
-+                    -I/usr/include/ccolamd -I/usr/include/camd
-                 CONFIG =
--            endif
+ # the optional Partition module requires METIS, CAMD, and CCOLAMD.
+ # CAMD and CCOLAMD can be installed without METIS, but are optional.
+ I_WITH_PARTITION = 
+ LIB_WITH_PARTITION =
+-CONFIG = -DNPARTITION -DNCAMD
++CONFIG = -DNPARTITION
+ # check if CAMD/CCOLAMD and METIS are requested and available
+ ifeq (,$(findstring -DNCAMD, $(CHOLMOD_CONFIG)))
+-    # CAMD and CCOLAMD are requested.  See if they are available
+-    ifeq (../../CAMD, $(wildcard ../../CAMD))
+-        ifeq (../../CCOLAMD, $(wildcard ../../CCOLAMD))
++    # CAMD and CCOLAMD are requested. Assume they are available
+             # CAMD and CCOLAMD are requested and available
+             LIB_WITH_PARTITION = \
+-                        ../../CCOLAMD/Lib/libccolamd.a ../../CAMD/Lib/libcamd.a
++                        -lccolamd -lcamd
+             I_WITH_PARTITION = \
+-                        -I../../CCOLAMD/Include -I../../CAMD/Include
++                        -I/usr/include/ccolamd -I/usr/include/camd
+             CONFIG = -DNPARTITION
+             # check if METIS is requested and available
+             ifeq (,$(findstring -DNPARTITION, $(CHOLMOD_CONFIG)))
+-                # METIS is requested.  See if it is available
+-                ifeq ($(METIS_PATH), $(wildcard $(METIS_PATH)))
++                # METIS is requested.  Assume it is available
+                     # METIS is available
+-                    LIB_WITH_PARTITION = $(METIS) \
+-                        ../../CCOLAMD/Lib/libccolamd.a ../../CAMD/Lib/libcamd.a
+-                    I_WITH_PARTITION = -I$(METIS_PATH)/Lib \
+-                        -I../../CCOLAMD/Include -I../../CAMD/Include
++                    LIB_WITH_PARTITION = -lmetis -lccolamd -lcamd
++                    I_WITH_PARTITION = -I/usr/include/metis \
++                        -I/usr/include/ccolamd -I/usr/include/camd
+                     CONFIG =
+-                endif
+             endif
 -        endif
-     endif
+-    endif
  endif
  #-------------------------------------------------------------------------------
  
 -I = -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include \
index bcae7ce206fbbd32aa012fabe9fe99c402eeb324..6b77594fa97960267b6971512f0b3a515069421f 100644 (file)
@@ -5,12 +5,12 @@
 Summary:       CHOLMOD: sparse supernodal Cholesky factorization and update/downdate
 Summary(pl.UTF-8):     CHOLMOD - rzadki wielowęzłowy rozkład Cholesky'ego z poprawianiem
 Name:          CHOLMOD
-Version:       2.1.0
+Version:       2.1.1
 Release:       1
 License:       GPL v2+ (some parts LGPL v2.1+)
 Group:         Libraries
 Source0:       http://www.cise.ufl.edu/research/sparse/cholmod/%{name}-%{version}.tar.gz
-# Source0-md5: 9bc275f9117c3e3a6c4f23c29fd01761
+# Source0-md5: 3b9a68ebc60825a6f3cd5f5fa5930de8
 Patch0:                %{name}-ufconfig.patch
 Patch1:                %{name}-shared.patch
 # http://www.cise.ufl.edu/research/sparse/cholmod/metis.patch (for METIS 5)
@@ -82,7 +82,6 @@ Statyczna biblioteka CHOLMOD.
 %{__make} \
        CC="%{__cc}" \
        %{?with_metis:WITH_METIS=1} \
-       %{!?with_metis:PARTITION= LPARTITION=} \
        CFLAGS="%{rpmcflags}" \
        LDFLAGS="%{rpmldflags}" \
        libdir=%{_libdir}
@@ -93,7 +92,6 @@ install -d $RPM_BUILD_ROOT%{_includedir}/cholmod
 
 %{__make} -C Lib install \
        DESTDIR=$RPM_BUILD_ROOT \
-       %{!?with_metis:PARTITION= LPARTITION=} \
        libdir=%{_libdir}
 
 install Include/*.h $RPM_BUILD_ROOT%{_includedir}/cholmod
This page took 0.12668 seconds and 4 git commands to generate.