]> git.pld-linux.org Git - packages/CCOLAMD.git/commitdiff
- copied from colamd
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 2 Dec 2007 15:30:34 +0000 (15:30 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ccolamd-shared.patch -> 1.1
    ccolamd-ufconfig.patch -> 1.1

ccolamd-shared.patch [new file with mode: 0644]
ccolamd-ufconfig.patch [new file with mode: 0644]

diff --git a/ccolamd-shared.patch b/ccolamd-shared.patch
new file mode 100644 (file)
index 0000000..fe556c9
--- /dev/null
@@ -0,0 +1,65 @@
+diff -ur CCOLAMD/Demo/Makefile CCOLAMD-shared/Demo/Makefile
+--- CCOLAMD/Demo/Makefile      2007-12-02 15:48:48.000000000 +0100
++++ CCOLAMD-shared/Demo/Makefile       2007-12-02 15:48:31.000000000 +0100
+@@ -20,12 +20,12 @@
+ dist:
+ ccolamd_example: ccolamd_example.c library
+-      $(C) -o ccolamd_example ccolamd_example.c ../Lib/libccolamd.a -lm
++      libtool --tag=CC --mode=link $(CC) $(CFLAGS) $(I) -o ccolamd_example ccolamd_example.c ../Lib/libccolamd.la -lm
+       - ./ccolamd_example > my_ccolamd_example.out
+       - diff ccolamd_example.out my_ccolamd_example.out
+ ccolamd_l_example: ccolamd_l_example.c library
+-      $(C) -o ccolamd_l_example ccolamd_l_example.c ../Lib/libccolamd.a -lm
++      libtool --tag=CC --mode=link $(CC) $(CFLAGS) $(I) -o ccolamd_l_example ccolamd_l_example.c ../Lib/libccolamd.la -lm
+       - ./ccolamd_l_example > my_ccolamd_l_example.out
+       - diff ccolamd_example.out my_ccolamd_example.out
+diff -ur CCOLAMD/Lib/Makefile CCOLAMD-shared/Lib/Makefile
+--- CCOLAMD/Lib/Makefile       2007-12-02 15:48:48.000000000 +0100
++++ CCOLAMD-shared/Lib/Makefile        2007-12-02 15:47:12.000000000 +0100
+@@ -2,7 +2,8 @@
+ # CCOLAMD Makefile
+ #-------------------------------------------------------------------------------
+-default: libccolamd.a
++default: libccolamd.la
++libdir        := /usr/lib
+ include /usr/share/misc/UFconfig.mk
+@@ -13,15 +14,20 @@
+ SRC = ../Source/ccolamd.c ../Source/ccolamd_global.c
+ # creates libccolamd.a, a C-callable COLAMD library
+-libccolamd.a:  $(SRC) $(INC)
+-      $(CC) $(CFLAGS) $(I) -c ../Source/ccolamd_global.c
+-      $(CC) $(CFLAGS) $(I) -c ../Source/ccolamd.c
+-      $(CC) $(CFLAGS) $(I) -c ../Source/ccolamd.c -DDLONG -o ccolamd_l.o
+-      $(AR) libccolamd.a ccolamd.o ccolamd_l.o ccolamd_global.o
++libccolamd.a: libccolamd.la
++libccolamd.la:  $(SRC) $(INC)
++      libtool --tag=CC --mode=compile $(CC) $(CFLAGS) $(I) -c ../Source/ccolamd_global.c
++      libtool --tag=CC --mode=compile $(CC) $(CFLAGS) $(I) -c ../Source/ccolamd.c
++      libtool --tag=CC --mode=compile $(CC) $(CFLAGS) $(I) -c ../Source/ccolamd.c -DDLONG -o ccolamd_l.o
++      libtool --tag=CC --mode=link $(CC) -o libccolamd.la -rpath $(libdir) ccolamd.o ccolamd_l.o ccolamd_global.o -lm
++
++install: libccolamd.la
++      install -d $(DESTDIR)$(libdir)
++      libtool --mode=install cp libccolamd.la $(DESTDIR)$(libdir)/libccolamd.la
+-ccode: libccolamd.a
++ccode: libccolamd.la
+-library: libccolamd.a
++library: libccolamd.la
+ clean:
+       - $(RM) $(CLEAN)
+@@ -29,4 +35,4 @@
+ purge: distclean
+ distclean: clean
+-      - $(RM) libccolamd.a
++      - $(RM) libccolamd.la
diff --git a/ccolamd-ufconfig.patch b/ccolamd-ufconfig.patch
new file mode 100644 (file)
index 0000000..9e8932f
--- /dev/null
@@ -0,0 +1,95 @@
+--- CCOLAMD/Source/ccolamd.c~  2006-12-13 13:46:38.000000000 +0200
++++ CCOLAMD/Source/ccolamd.c   2007-03-27 01:17:49.118259378 +0300
+@@ -685,7 +685,7 @@
+ /* ========================================================================== */
+ /* define UF_long */
+-#include "UFconfig.h"
++#include <UFconfig.h>
+ #ifdef DLONG
+--- CCOLAMD/Include/ccolamd.h~ 2006-12-13 13:46:09.000000000 +0200
++++ CCOLAMD/Include/ccolamd.h  2007-03-27 01:18:06.598650636 +0300
+@@ -139,7 +139,7 @@
+ /* ========================================================================== */
+ /* define UF_long */
+-#include "UFconfig.h"
++#include <UFconfig.h>
+ size_t ccolamd_recommended    /* returns recommended value of Alen, */
+                               /* or 0 if input arguments are erroneous */
+--- CCOLAMD/Demo/ccolamd_l_example.c~  2006-12-13 13:47:22.000000000 +0200
++++ CCOLAMD/Demo/ccolamd_l_example.c   2007-03-27 01:18:17.698899095 +0300
+@@ -44,7 +44,7 @@
+ #define B_N 5
+ /* define UF_long */
+-#include "UFconfig.h"
++#include <UFconfig.h>
+ int main (void)
+ {
+--- CCOLAMD/Makefile~  2007-03-27 01:18:43.219470348 +0300
++++ CCOLAMD/Makefile   2007-03-27 01:18:44.569500568 +0300
+@@ -1,7 +1,7 @@
+ default: demo
+-include ../UFconfig/UFconfig.mk
++include /usr/share/misc/UFconfig.mk
+ # Compile all C code, including the C-callable routine and the mexFunctions.
+ # Do not the MATLAB interface.
+diff -ur CCOLAMD/Demo/Makefile CCOLAMD.UF/Demo/Makefile
+--- CCOLAMD/Demo/Makefile      2007-05-05 15:42:44.000000000 +0200
++++ CCOLAMD.UF/Demo/Makefile   2007-12-02 15:41:19.000000000 +0100
+@@ -4,9 +4,9 @@
+ default: ccolamd_example ccolamd_l_example
+-include ../../UFconfig/UFconfig.mk
++include /usr/share/misc/UFconfig.mk
+-I = -I../Include -I../../UFconfig
++I = -I../Include
+ C = $(CC) $(CFLAGS) $(I)
+diff -ur CCOLAMD/Lib/Makefile CCOLAMD.UF/Lib/Makefile
+--- CCOLAMD/Lib/Makefile       2007-05-05 15:41:47.000000000 +0200
++++ CCOLAMD.UF/Lib/Makefile    2007-12-02 15:42:02.000000000 +0100
+@@ -4,11 +4,11 @@
+ default: libccolamd.a
+-include ../../UFconfig/UFconfig.mk
++include /usr/share/misc/UFconfig.mk
+-I = -I../Include -I../../UFconfig
++I = -I../Include
+-INC = ../Include/ccolamd.h ../../UFconfig/UFconfig.h
++INC = ../Include/ccolamd.h
+ SRC = ../Source/ccolamd.c ../Source/ccolamd_global.c
+diff -ur CCOLAMD/MATLAB/Makefile CCOLAMD.UF/MATLAB/Makefile
+--- CCOLAMD/MATLAB/Makefile    2007-05-06 04:41:53.000000000 +0200
++++ CCOLAMD.UF/MATLAB/Makefile 2007-12-02 15:42:15.000000000 +0100
+@@ -2,11 +2,11 @@
+ default: ccolamd2 symamd2
+-include ../../UFconfig/UFconfig.mk
++include /usr/share/misc/UFconfig.mk
+-I = -I../../UFconfig -I../Include
++I = -I../Include
+-INC = ../Include/ccolamd.h ../../UFconfig/UFconfig.h
++INC = ../Include/ccolamd.h
+ SRC = ../Source/ccolamd.c ../Source/ccolamd_global.c
This page took 0.05169 seconds and 4 git commands to generate.