]> git.pld-linux.org Git - packages/CCOLAMD.git/blob - CCOLAMD.spec
- fix SuiteSparse_config BR
[packages/CCOLAMD.git] / CCOLAMD.spec
1 Summary:        CCOLAMD: constrained column approximate minimum degree
2 Summary(pl.UTF-8):      CCOLAMD - przybliżony ograniczony algorytm minimalnego stopnia dla kolumn
3 Name:           CCOLAMD
4 Version:        2.9.0
5 Release:        3
6 License:        LGPL v2.1+
7 Group:          Libraries
8 Source0:        http://www.cise.ufl.edu/research/sparse/ccolamd/%{name}-%{version}.tar.gz
9 # Source0-md5:  ae0739c8bc2881587a0ce3c3dd0e1812
10 Patch0:         ccolamd-ufconfig.patch
11 Patch1:         ccolamd-shared.patch
12 URL:            http://www.cise.ufl.edu/research/sparse/ccolamd/
13 BuildRequires:  SuiteSparse_config-devel >= 4.3.0
14 BuildRequires:  libtool >= 2:1.5
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 The CCOLAMD column approximate minimum degree ordering algorithm
19 computes a permutation vector P such that the LU factorization of A
20 (:,P) tends to be sparser than that of A. The Cholesky factorization
21 of (A (:,P))'*(A (:,P)) will also tend to be sparser than that of
22 A'*A. CSYMAMD is a symmetric minimum degree ordering method based on
23 CCOLAMD, available as a MATLAB-callable function. It constructs a
24 matrix M such that M'*M has the same pattern as A, and then uses
25 CCOLAMD to compute a column ordering of M.
26
27 %description -l pl.UTF-8
28 Przybliżony algorytm porządkowania minimalnego stopnia dla kolumn
29 CCOLAMD oblicza wektor permutacji P taki, że rozkład LU A (:,P) jest
30 bardziej rzadki niż A. Rozkład Cholesky'ego (A (:,P))'*(A (:,P)) także
31 jest rzadszy niż A'*A. CSYMAND to przybliżony algorytm porządkowania
32 minimalnego stopnia dla macierzy symetrycznych oparty na CCOLAMD,
33 dostępny jako funkcja do wywołania z MATLAB-a. Tworzy macierz M taką,
34 że M'*M ma ten sam wzór co A, a następnie używa algorytmu CCOLAMD do
35 obliczenia porządku kolumn M.
36
37 %package devel
38 Summary:        Header files for CCOLAMD library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CCOLAMD
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       SuiteSparse_config >= 4.3.0
43
44 %description devel
45 Header files for CCOLAMD library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki CCOLAMD.
49
50 %package static
51 Summary:        Static CCOLAMD library
52 Summary(pl.UTF-8):      Statyczna biblioteka CCOLAMD
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static CCOLAMD library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka CCOLAMD.
61
62 %prep
63 %setup -q -n %{name}
64 %patch0 -p1
65 %patch1 -p1
66
67 %build
68 %{__make} \
69         CC="%{__cc}" \
70         CFLAGS="%{rpmcflags}" \
71         LDFLAGS="%{rpmldflags}" \
72         libdir=%{_libdir}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{_includedir}/ccolamd
77
78 %{__make} -C Lib install \
79         DESTDIR=$RPM_BUILD_ROOT \
80         libdir=%{_libdir}
81
82 install Include/*.h $RPM_BUILD_ROOT%{_includedir}/ccolamd
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc README.txt Doc/ChangeLog
93 %attr(755,root,root) %{_libdir}/libccolamd.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libccolamd.so.0
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libccolamd.so
99 %{_libdir}/libccolamd.la
100 %{_includedir}/ccolamd
101
102 %files static
103 %defattr(644,root,root,755)
104 %{_libdir}/libccolamd.a
This page took 0.072198 seconds and 4 git commands to generate.