]> git.pld-linux.org Git - packages/CCOLAMD.git/blob - CCOLAMD.spec
- rel 3
[packages/CCOLAMD.git] / CCOLAMD.spec
1 Summary:        CCOLAMD: constrained column approximate minimum degree
2 Summary(pl.UTF-8):      CCOLAMD - przybliżony ograniczony algorytm minimalnego stopnia dla kolumn
3 Name:           CCOLAMD
4 Version:        2.7.1
5 Release:        3
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://www.cise.ufl.edu/research/sparse/ccolamd/%{name}-%{version}.tar.gz
9 # Source0-md5:  04b0b27fae6795612ce779a3f6381cb7
10 Patch0:         ccolamd-ufconfig.patch
11 Patch1:         ccolamd-shared.patch
12 URL:            http://www.cise.ufl.edu/research/sparse/ccolamd/
13 BuildRequires:  UFconfig
14 BuildRequires:  libtool >= 2:1.5
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 The COLAMD column approximate minimum degree ordering algorithm
19 computes a permutation vector P such that the LU factorization of A
20 (:,P) tends to be sparser than that of A. The Cholesky factorization
21 of (A (:,P))'*(A (:,P)) will also tend to be sparser than that of
22 A'*A. SYMAMD is a symmetric minimum degree ordering method based on
23 COLAMD, available as a MATLAB-callable function. It constructs a
24 matrix M such that M'*M has the same pattern as A, and then uses
25 COLAMD to compute a column ordering of M. Colamd and symamd tend to be
26 faster and generate better orderings than their MATLAB counterparts,
27 colmmd and symmmd.
28
29 %description -l pl.UTF-8
30 Przybliżony algorytm porządkowania minimalnego stopnia dla kolumn
31 (COLAMD) oblicza wektor permutacji P taki, że rozkład LU A (:,P) jest
32 bardziej rzadki niż A. Rozkład Cholesky'ego (A (:,P))'*(A (:,P)) także
33 jest rzadszy niż A'*A. SYMAND to przybliżony algorytm porządkowania
34 minimalnego stopnia dla macierzy symetrycznych oparty na COLAMD,
35 dostępny jako funkcja do wywołania z MATLAB-a. Tworzy macierz M taką,
36 że M'*M ma ten sam wzór co A, a następnie używa algorytmu COLAMD do
37 obliczenia porządku kolumn M. COLAMD i SYMAMD są szybsze i generują
38 lepsze uporządkowania niż ich odpowiedniki z MATLAB-a: colmmd i
39 symmmd.
40
41 %package devel
42 Summary:        Header files for CCOLAMD library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CCOLAMD
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       UFconfig
47
48 %description devel
49 Header files for CCOLAMD library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki CCOLAMD.
53
54 %package static
55 Summary:        Static CCOLAMD library
56 Summary(pl.UTF-8):      Statyczna biblioteka CCOLAMD
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static CCOLAMD library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka CCOLAMD.
65
66 %prep
67 %setup -q -n %{name}
68 %patch0 -p1
69 %patch1 -p1
70
71 %build
72 %{__make} \
73         CC="%{__cc}" \
74         CFLAGS="%{rpmcflags} -fPIC" \
75         LDFLAGS="%{rpmldflags}" \
76         libdir=%{_libdir}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT%{_includedir}/ccolamd
81
82 %{__make} -C Lib install \
83         DESTDIR=$RPM_BUILD_ROOT \
84         libdir=%{_libdir}
85
86 install Include/*.h $RPM_BUILD_ROOT%{_includedir}/ccolamd
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc README.txt
97 %attr(755,root,root) %{_libdir}/libccolamd.so.*.*.*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libccolamd.so
102 %{_libdir}/libccolamd.la
103 %{_includedir}/ccolamd
104
105 %files static
106 %defattr(644,root,root,755)
107 %{_libdir}/libccolamd.a
This page took 0.052317 seconds and 4 git commands to generate.