]> git.pld-linux.org Git - packages/CAMD.git/commitdiff
- updated to 2.2.3 auto/th/CAMD-2_2_3-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 1 Jan 2012 13:03:41 +0000 (13:03 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- updated ufconfig,shared patches

Changed files:
    CAMD-shared.patch -> 1.4
    CAMD-ufconfig.patch -> 1.2
    CAMD.spec -> 1.14

CAMD-shared.patch
CAMD-ufconfig.patch
CAMD.spec

index 97c45fe4747e27956394c29102b0e48cd4af728f..a73301f0e2c67808a64295963db1265eef28e42b 100644 (file)
@@ -28,9 +28,8 @@ diff -ur camd/Demo/Makefile camd-shared/Demo/Makefile
        ./camd_simple > my_camd_simple.out
        - diff camd_simple.out my_camd_simple.out
  
-diff -ur camd/Lib/GNUmakefile camd-shared/Lib/GNUmakefile
---- camd/Lib/GNUmakefile       2007-12-02 19:00:35.000000000 +0100
-+++ camd-shared/Lib/GNUmakefile        2007-12-02 18:59:22.000000000 +0100
+--- CAMD/Lib/GNUmakefile.orig  2012-01-01 13:54:50.662901345 +0100
++++ CAMD/Lib/GNUmakefile       2012-01-01 14:04:33.546254197 +0100
 @@ -2,7 +2,7 @@
  # CAMD Makefile for compiling on Unix systems (for GNU make only)
  #-------------------------------------------------------------------------------
@@ -45,22 +44,22 @@ diff -ur camd/Lib/GNUmakefile camd-shared/Lib/GNUmakefile
  
  camd_global.o: ../Source/camd_global.c $(INC)
 -      $(C) -c $< -o $@
-+      libtool --tag=CC --mode=compile $(CC) $(CFLAGS) $(CONFIG) -I../Include -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -c $< -o $@
  
  camd_i_%.o: ../Source/camd_%.c $(INC)
 -      $(C) -DDINT -c $< -o $@
-+      libtool --tag=CC --mode=compile $(CC) -DDINT $(CFLAGS) $(CONFIG) -I../Include -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDINT -c $< -o $@
  
  camd_l_%.o: ../Source/camd_%.c $(INC)
 -      $(C) -DDLONG -c $< -o $@
-+      libtool --tag=CC --mode=compile $(CC) -DDLONG $(CFLAGS) $(CONFIG) -I../Include -c $< -o $@
++      libtool --tag=CC --mode=compile $(C) -DDLONG -c $< -o $@
  
  #-------------------------------------------------------------------------------
  # Create the libcamd.a library (C versions only)
  #-------------------------------------------------------------------------------
  
 -libcamd.a: camd_global.o $(CAMDI) $(CAMDL)
--      $(AR) libcamd.a $^
+-      $(ARCHIVE)  libcamd.a $^
 -      - $(RANLIB) libcamd.a
 +libcamd.la: camd_global.o $(CAMDI) $(CAMDL)
 +      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) -o libcamd.la -rpath $(libdir) $(^:.o=.lo) -lm
@@ -71,7 +70,7 @@ diff -ur camd/Lib/GNUmakefile camd-shared/Lib/GNUmakefile
  
  #-------------------------------------------------------------------------------
  # Remove all but the files in the original distribution
-@@ -73,4 +71,4 @@
+@@ -55,4 +58,4 @@
  purge: distclean
  
  distclean: clean
index ef23e93c2928b59c760e823dcf315eb1f4f69465..d0118e3b40d04ee11f2cf298af9e0471d7f06ca6 100644 (file)
@@ -10,9 +10,8 @@ diff -ur CAMD/Demo/camd_l_demo.c CAMD-uf/Demo/camd_l_demo.c
  
  int main (void)
  {
-diff -ur CAMD/Demo/Makefile CAMD-uf/Demo/Makefile
---- CAMD/Demo/Makefile 2007-05-05 16:25:26.000000000 +0200
-+++ CAMD-uf/Demo/Makefile      2007-12-02 18:01:51.000000000 +0100
+--- CAMD/Demo/Makefile.orig    2011-12-08 17:12:27.000000000 +0100
++++ CAMD/Demo/Makefile 2012-01-01 13:52:29.406229949 +0100
 @@ -4,13 +4,13 @@
  
  default: camd_simple camd_demo camd_demo2 camd_l_demo
@@ -20,12 +19,12 @@ diff -ur CAMD/Demo/Makefile CAMD-uf/Demo/Makefile
 -include ../../UFconfig/UFconfig.mk
 +include /usr/share/misc/UFconfig.mk
  
--C = $(CC) $(CFLAGS) $(CONFIG) -I../Include -I../../UFconfig
-+C = $(CC) $(CFLAGS) $(CONFIG) -I../Include
+-C = $(CC) $(CF) -I../Include -I../../UFconfig
++C = $(CC) $(CF) -I../Include
  
 -UFCONFIG = ../../UFconfig/UFconfig.h
 +UFCONFIG = /usr/share/misc/UFconfig.mk
-
 -INC = ../Include/camd.h $(UFCONFIG)
 +INC = ../Include/camd.h
  
@@ -67,9 +66,8 @@ diff -ur CAMD/Include/camd_internal.h CAMD-uf/Include/camd_internal.h
  
  #if defined (DLONG) || defined (ZLONG)
  
-diff -ur CAMD/Lib/Makefile CAMD-uf/Lib/Makefile
---- CAMD/Lib/Makefile  2007-05-06 14:32:40.000000000 +0200
-+++ CAMD-uf/Lib/Makefile       2007-12-02 18:02:11.000000000 +0100
+--- CAMD/Lib/Makefile.orig     2011-12-08 18:36:42.000000000 +0100
++++ CAMD/Lib/Makefile  2012-01-01 13:52:49.706230628 +0100
 @@ -8,9 +8,9 @@
  
  default: everything
@@ -77,8 +75,8 @@ diff -ur CAMD/Lib/Makefile CAMD-uf/Lib/Makefile
 -include ../../UFconfig/UFconfig.mk
 +include /usr/share/misc/UFconfig.mk
  
--C = $(CC) $(CFLAGS) $(CONFIG) -I../Include -I../../UFconfig
-+C = $(CC) $(CFLAGS) $(CONFIG) -I../Include
+-C = $(CC) $(CF) -I../Include -I../../UFconfig
++C = $(CC) $(CF) -I../Include
  
  everything:
        $(C) -DDINT -c ../Source/camd_aat.c -o camd_i_aat.o
@@ -126,22 +124,22 @@ diff -ur CAMD/MATLAB/Makefile CAMD-uf/MATLAB/Makefile
  
  SRC = ../Source/camd_1.c ../Source/camd_2.c ../Source/camd_aat.c \
      ../Source/camd_control.c ../Source/camd_defaults.c ../Source/camd_dump.c \
---- CAMD/Lib/GNUmakefile~      2007-05-06 14:32:19.000000000 +0200
-+++ CAMD/Lib/GNUmakefile       2007-12-02 18:23:35.000000000 +0100
+--- CAMD/Lib/GNUmakefile.orig  2011-12-08 18:36:27.000000000 +0100
++++ CAMD/Lib/GNUmakefile       2012-01-01 13:53:05.949564506 +0100
 @@ -4,9 +4,9 @@
  
- default: ../Lib/libamd.a
+ default: libcamd.a
  
 -include ../../UFconfig/UFconfig.mk
 +include /usr/share/misc/UFconfig.mk
  
--C = $(CC) $(CFLAGS) $(CONFIG) -I../Include -I../../UFconfig
-+C = $(CC) $(CFLAGS) $(CONFIG) -I../Include
+-C = $(CC) $(CF) -I../Include -I../../UFconfig
++C = $(CC) $(CF) -I../Include
  
  #-------------------------------------------------------------------------------
  # source files
-@@ -15,9 +15,7 @@
- CAMD = camd_aat camd_1 camd_2 camd_dump camd_postorder camd_post_tree camd_defaults \
+@@ -15,9 +15,7 @@ C = $(CC) $(CF) -I../Include -I../../UFc
+ CAMD = camd_aat camd_1 camd_2 camd_dump camd_postorder camd_defaults \
        camd_order camd_control camd_info camd_valid camd_preprocess
  
 -UFCONFIG = ../../UFconfig/UFconfig.h
index 2c719d2f38cc742cb73b3219bfa62b3b0352dbe5..26ee016f116bd25f13329dc03785e78b968be7b3 100644 (file)
--- a/CAMD.spec
+++ b/CAMD.spec
@@ -1,16 +1,16 @@
 Summary:       CAMD: Constrainted Approximate Minimum Degree
 Summary(pl.UTF-8):     CAMD - przybliżony ograniczony algorytm minimalnego stopnia
 Name:          CAMD
-Version:       2.2.2
+Version:       2.2.3
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://www.cise.ufl.edu/research/sparse/camd/%{name}-%{version}.tar.gz
-# Source0-md5: 540993c40f5540ce89a36fdf836becda
+# Source0-md5: 9b35e0663f96bb43d23cf3c5d8154c23
 Patch0:                %{name}-ufconfig.patch
 Patch1:                %{name}-shared.patch
 URL:           http://www.cise.ufl.edu/research/sparse/camd/
-BuildRequires: UFconfig
+BuildRequires: UFconfig >= 3.7.0
 BuildRequires: libtool >= 2:1.5
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -28,7 +28,7 @@ Summary:      Header files for CAMD library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki CAMD
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      UFconfig
+Requires:      UFconfig >= 3.7.0
 
 %description devel
 Header files for CAMD library.
This page took 0.121335 seconds and 4 git commands to generate.