]> git.pld-linux.org Git - packages/CAMD.git/commitdiff
- updated to 2.4.0 auto/th/CAMD-2.4.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 1 Oct 2014 18:50:42 +0000 (20:50 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 1 Oct 2014 18:50:42 +0000 (20:50 +0200)
- updated ufconfig,shared patches

CAMD-shared.patch
CAMD-ufconfig.patch
CAMD.spec

index 0f858358642750e8493c78b70b52d397228eb5b8..065e086ebede57b466b945b905e4919db4f88150 100644 (file)
@@ -1,35 +1,34 @@
-diff -ur camd/Demo/Makefile camd-shared/Demo/Makefile
---- camd/Demo/Makefile 2007-12-02 19:00:33.000000000 +0100
-+++ camd-shared/Demo/Makefile  2007-12-02 18:55:08.000000000 +0100
-@@ -23,22 +23,22 @@
+--- CAMD/Demo/Makefile.orig    2014-10-01 20:15:40.452951732 +0200
++++ CAMD/Demo/Makefile 2014-10-01 20:40:07.992890145 +0200
+@@ -22,22 +22,22 @@
  dist:
  
  camd_demo: camd_demo.c library $(INC)
--      $(C) -o camd_demo camd_demo.c ../Lib/libcamd.a $(LIB)
-+      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) $(CFLAGS) -I../Include -o camd_demo camd_demo.c ../Lib/libcamd.la $(LIB)
+-      $(C) -o camd_demo camd_demo.c ../Lib/libcamd.a $(LIB2)
++      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) $(CFLAGS) -I../Include -o camd_demo camd_demo.c ../Lib/libcamd.la $(LIB2)
        ./camd_demo > my_camd_demo.out
        - diff camd_demo.out my_camd_demo.out
  
  camd_l_demo: camd_l_demo.c library $(INC)
--      $(C) -o camd_l_demo camd_l_demo.c ../Lib/libcamd.a $(LIB)
-+      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) $(CFLAGS) -I../Include -o camd_l_demo camd_l_demo.c ../Lib/libcamd.la $(LIB)
+-      $(C) -o camd_l_demo camd_l_demo.c ../Lib/libcamd.a $(LIB2)
++      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) $(CFLAGS) -I../Include -o camd_l_demo camd_l_demo.c ../Lib/libcamd.la $(LIB2)
        ./camd_l_demo > my_camd_l_demo.out
        - diff camd_l_demo.out my_camd_l_demo.out
  
  camd_demo2: camd_demo2.c library $(INC)
--      $(C) -o camd_demo2 camd_demo2.c ../Lib/libcamd.a $(LIB)
-+      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) $(CFLAGS) -I../Include -o camd_demo2 camd_demo2.c ../Lib/libcamd.la $(LIB)
+-      $(C) -o camd_demo2 camd_demo2.c ../Lib/libcamd.a $(LIB2)
++      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) $(CFLAGS) -I../Include -o camd_demo2 camd_demo2.c ../Lib/libcamd.la $(LIB2)
        ./camd_demo2 > my_camd_demo2.out
        - diff camd_demo2.out my_camd_demo2.out
  
  camd_simple: camd_simple.c library $(INC)
--      $(C) -o camd_simple camd_simple.c ../Lib/libcamd.a $(LIB)
-+      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) $(CFLAGS) -I../Include -o camd_simple camd_simple.c ../Lib/libcamd.la $(LIB)
+-      $(C) -o camd_simple camd_simple.c ../Lib/libcamd.a $(LIB2)
++      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) $(CFLAGS) -I../Include -o camd_simple camd_simple.c ../Lib/libcamd.la $(LIB2)
        ./camd_simple > my_camd_simple.out
        - diff camd_simple.out my_camd_simple.out
  
---- CAMD/Lib/GNUmakefile.orig  2012-01-01 13:54:50.662901345 +0100
-+++ CAMD/Lib/GNUmakefile       2012-01-01 14:04:33.546254197 +0100
+--- CAMD/Lib/GNUmakefile.orig  2014-10-01 20:15:40.442951733 +0200
++++ CAMD/Lib/GNUmakefile       2014-10-01 20:41:30.242886694 +0200
 @@ -2,7 +2,7 @@
  # CAMD Makefile for compiling on Unix systems (for GNU make only)
  #-------------------------------------------------------------------------------
@@ -39,13 +38,9 @@ diff -ur camd/Demo/Makefile camd-shared/Demo/Makefile
  
  include /usr/share/misc/SuiteSparse_config.mk
  
-@@ -29,21 +29,24 @@
+@@ -29,18 +29,21 @@
  #-------------------------------------------------------------------------------
  
- camd_global.o: ../Source/camd_global.c $(INC)
--      $(C) -c $< -o $@
-+      libtool --tag=CC --mode=compile $(C) -c $< -o $@
  camd_i_%.o: ../Source/camd_%.c $(INC)
 -      $(C) -DDINT -c $< -o $@
 +      libtool --tag=CC --mode=compile $(C) -DDINT -c $< -o $@
@@ -58,19 +53,19 @@ diff -ur camd/Demo/Makefile camd-shared/Demo/Makefile
  # Create the libcamd.a library (C versions only)
  #-------------------------------------------------------------------------------
  
--libcamd.a: camd_global.o $(CAMDI) $(CAMDL)
+-libcamd.a: $(CAMDI) $(CAMDL)
 -      $(ARCHIVE)  libcamd.a $^
 -      - $(RANLIB) libcamd.a
-+libcamd.la: camd_global.o $(CAMDI) $(CAMDL)
-+      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) -o libcamd.la -rpath $(libdir) $(^:.o=.lo) -lm
++libcamd.la: $(CAMDI) $(CAMDL)
++      libtool --tag=CC --mode=link $(CC) $(LDFLAGS) -o libcamd.la -rpath $(libdir) $(^:.o=.lo) -lsuitesparseconfig -lm
 +
 +install: libcamd.la
 +      install -d $(DESTDIR)$(libdir)
-+      libtool --mode=install cp libcamd.la $(DESTDIR)$(libdir)/libcamd.la
++      libtool --mode=install install libcamd.la $(DESTDIR)$(libdir)
  
  #-------------------------------------------------------------------------------
  # Remove all but the files in the original distribution
-@@ -55,4 +58,4 @@
+@@ -52,4 +55,4 @@
  purge: distclean
  
  distclean: clean
index 8889e46ba44836b0d014be7995e70890e9d4f916..10053d0e3c39483f8c463774439ff273e404ca87 100644 (file)
@@ -1,6 +1,6 @@
 --- CAMD/Demo/Makefile.orig    2012-05-27 01:23:01.000000000 +0200
 +++ CAMD/Demo/Makefile 2012-06-27 16:48:20.148813310 +0200
-@@ -4,11 +4,11 @@
+@@ -4,16 +4,15 @@
  
  default: camd_simple camd_demo camd_demo2 camd_l_demo
  
 -INC = ../Include/camd.h ../../SuiteSparse_config/SuiteSparse_config.h
 +INC = ../Include/camd.h
  
+-LIB2 = ../../SuiteSparse_config/libsuitesparseconfig.a $(LIB)
++LIB2 = -lsuitesparseconfig $(LIB)
  library:
+-      ( cd ../../SuiteSparse_config ; $(MAKE) )
        ( cd ../Lib ; $(MAKE) )
+ #------------------------------------------------------------------------------
 diff -ur CAMD/Doc/Makefile CAMD-uf/Doc/Makefile
 --- CAMD/Doc/Makefile  2006-04-25 18:34:27.000000000 +0200
 +++ CAMD-uf/Doc/Makefile       2007-12-02 18:01:59.000000000 +0100
index c55e7e6bb7278cd2efe1251290ff514ffba2e53e..1a2fb7a53754c0eb3d1cf28834d2599c8629369b 100644 (file)
--- a/CAMD.spec
+++ b/CAMD.spec
@@ -1,17 +1,18 @@
 Summary:       CAMD: Constrainted Approximate Minimum Degree
 Summary(pl.UTF-8):     CAMD - przybliżony ograniczony algorytm minimalnego stopnia
 Name:          CAMD
-Version:       2.3.1
+Version:       2.4.0
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://www.cise.ufl.edu/research/sparse/camd/%{name}-%{version}.tar.gz
-# Source0-md5: 2df3aa57af6bf241fa7f9c4ebb696ac8
+# Source0-md5: cc9c726fed34365d18e45380890707c2
 Patch0:                %{name}-ufconfig.patch
 Patch1:                %{name}-shared.patch
 URL:           http://www.cise.ufl.edu/research/sparse/camd/
-BuildRequires: SuiteSparse_config >= 4.0.0
+BuildRequires: SuiteSparse_config >= 4.3.0
 BuildRequires: libtool >= 2:1.5
+Requires:      SuiteSparse_config-libs >= 4.3.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -28,7 +29,7 @@ Summary:      Header files for CAMD library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki CAMD
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      SuiteSparse_config >= 4.0.0
+Requires:      SuiteSparse_config >= 4.3.0
 
 %description devel
 Header files for CAMD library.
This page took 0.069507 seconds and 4 git commands to generate.