]> git.pld-linux.org Git - packages/Backbone.git/blob - Backbone.spec
- updated to 20070830 snap
[packages/Backbone.git] / Backbone.spec
1 %define cvs     20070830
2 Summary:        GNUstep backbone apps, including Preferences
3 Summary(pl.UTF-8):      Szkieletowe aplikacje GNUstepa, w tym Preferences
4 Name:           Backbone
5 Version:        1.2.99
6 Release:        0.%{cvs}.1
7 License:        GPL
8 Group:          X11/Applications
9 Source0:        %{name}-%{cvs}.tar.gz
10 # Source0-md5:  e27413e9e105cfa3bb2eaf953fa3661f
11 Patch0:         %{name}-buildinplace.patch
12 Patch1:         %{name}-installprefix.patch
13 Patch2:         %{name}-pass-arguments.patch
14 Patch3:         %{name}-install.patch
15 URL:            http://www.nongnu.org/backbone/
16 BuildRequires:  gnustep-gui-devel
17 Obsoletes:      Preferences
18 Obsoletes:      Terminal
19 Obsoletes:      TextEdit
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 GNUstep Backbone applications, including Preferences.
24
25 %description -l pl.UTF-8
26 Szkieletowe aplikacje GNUstepa, w tym Preferences (edytor ustawień).
27
28 %package devel
29 Summary:        Header files for Backbone frameworks
30 Summary(pl.UTF-8):      Pliki nagłówkowe dla bibliotek Backbone
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33 Requires:       gnustep-gui-devel
34 Obsoletes:      Preferences-devel
35
36 %description devel
37 Header files for Backbone frameworks.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe dla bibliotek Backbone.
41
42 %prep
43 %setup -q -n System
44 %patch0 -p1
45 %patch1 -p1
46 %patch2 -p1
47 %patch3 -p1
48
49 %build
50 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
51 export GNUSTEP_FLATTENED=yes
52 %{__make} -j1 \
53         OPTFLAG="%{rpmcflags}" \
54         messages=yes
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 export GNUSTEP_MAKEFILES=%{_datadir}/GNUstep/Makefiles
59 export GNUSTEP_FLATTENED=yes
60
61 %{__make} -j1 install \
62         GNUSTEP_INSTALLATION_DOMAIN=SYSTEM \
63         DESTDIR=$RPM_BUILD_ROOT 
64
65 for f in Calculator CurrencyConverter GSTest Ink NSBrowserTest NSImageTest NSPanelTest NSScreenTest md5Digest ; do
66         ln -sf %{_libdir}/GNUstep/Applications/$f.app/$f $RPM_BUILD_ROOT/%{_bindir}/$f
67 done
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post   -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files
76 %defattr(644,root,root,755)
77 %dir %{_libdir}/GNUstep/Applications/*.app
78 %dir %{_libdir}/GNUstep/Applications/*.app/Resources
79 %{_libdir}/GNUstep/Applications/*.app/Resources/*.desktop
80 %{_libdir}/GNUstep/Applications/*.app/Resources/*.plist
81 %{_libdir}/GNUstep/Applications/*.app/Resources/*.tiff
82 %{_libdir}/GNUstep/Applications/*.app/Resources/*.txt
83 %{_libdir}/GNUstep/Applications/*.app/Resources/*.svcs
84 %{_libdir}/GNUstep/Applications/*.app/Resources/English.lproj
85 %lang(fr) %{_libdir}/GNUstep/Applications/*.app/Resources/French.lproj
86 %lang(de) %{_libdir}/GNUstep/Applications/*.app/Resources/German.lproj
87 %lang(hu) %{_libdir}/GNUstep/Applications/*.app/Resources/Hungarian.lproj
88 %lang(nb) %{_libdir}/GNUstep/Applications/*.app/Resources/Norwegian.lproj
89 %lang(ru) %{_libdir}/GNUstep/Applications/*.app/Resources/Russian.lproj
90 %lang(es) %{_libdir}/GNUstep/Applications/*.app/Resources/Spanish.lproj
91 %lang(se) %{_libdir}/GNUstep/Applications/*.app/Resources/Swedish.lproj
92 %lang(tr) %{_libdir}/GNUstep/Applications/*.app/Resources/Turkish.lproj
93 %dir %{_libdir}/GNUstep/Applications/*.app/%{gscpu}
94 %dir %{_libdir}/GNUstep/Applications/*.app/%{gscpu}/%{gsos}
95 %dir %{_libdir}/GNUstep/Applications/*.app/%{gscpu}/%{gsos}/%{libcombo}
96 %attr(755,root,root) %{_libdir}/GNUstep/Applications/Preferences.app/Preferences
97 %attr(755,root,root) %{_libdir}/GNUstep/Applications/Preferences.app/%{gscpu}/%{gsos}/%{libcombo}/Preferences
98 %attr(755,root,root) %{_libdir}/GNUstep/Applications/Terminal.app/Terminal
99 %attr(755,root,root) %{_libdir}/GNUstep/Applications/Terminal.app/%{gscpu}/%{gsos}/%{libcombo}/Terminal
100 %attr(755,root,root) %{_libdir}/GNUstep/Applications/TextEdit.app/TextEdit
101 %attr(755,root,root) %{_libdir}/GNUstep/Applications/TextEdit.app/%{gscpu}/%{gsos}/%{libcombo}/TextEdit
102 %{_libdir}/GNUstep/Applications/*.app/%{gscpu}/%{gsos}/%{libcombo}/*.openapp
103 %attr(755,root,root) %{_libdir}/GNUstep/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
104
105 %dir %{_libdir}/GNUstep/Library/Frameworks/*.framework
106 %{_libdir}/GNUstep/Library/Frameworks/*.framework/Resources
107 %dir %{_libdir}/GNUstep/Library/Frameworks/*.framework/Versions
108 %dir %{_libdir}/GNUstep/Library/Frameworks/*.framework/Versions/*
109 %{_libdir}/GNUstep/Library/Frameworks/*.framework/Versions/1.1.0/Resources
110 %attr(755,root,root) %{_libdir}/GNUstep/Library/Frameworks/*.framework/Versions/1.1.0/%{gscpu}
111
112 %attr(755,root,root) %{_libdir}/GNUstep/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
113
114 %dir %{_libdir}/GNUstep/Library/Preferences
115 %dir %{_libdir}/GNUstep/Library/Preferences/*.prefs
116 %{_libdir}/GNUstep/Library/Preferences/*.prefs/Resources
117 %attr(755,root,root) %{_libdir}/GNUstep/Library/Preferences/*.prefs/%{gscpu}
118  
119 %files devel
120 %defattr(644,root,root,755)
121 %{_libdir}/GNUstep/Library/Frameworks/*.framework/Headers
122 %{_libdir}/GNUstep/Library/Frameworks/*.framework/Versions/1.1.0/Headers
123 %{_libdir}/GNUstep/Library/Headers/%{libcombo}/*
124
125 %attr(755,root,root) %{_libdir}/GNUstep/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
This page took 0.077793 seconds and 3 git commands to generate.