]> git.pld-linux.org Git - packages/Atlas-C++.git/blame_incremental - Atlas-C++.spec
- tabs in preamle
[packages/Atlas-C++.git] / Atlas-C++.spec
... / ...
CommitLineData
1# TODO:
2# add tutorial subpackage
3Summary: C++ reference implementation of the Atlas protocol
4Summary(pl.UTF-8): Implementacja protokołu Atlas
5Name: Atlas-C++
6Version: 0.6.0
7Release: 0.2
8Epoch: 1
9License: LGPL
10Group: Libraries
11Source0: http://dl.sourceforge.net/worldforge/%{name}-%{version}.tar.bz2
12# Source0-md5: 1343d74747a831f2b7b080a51cb4747a
13Patch0: %{name}-link.patch
14BuildRequires: autoconf >= 2.50
15BuildRequires: automake
16BuildRequires: bzip2-devel
17BuildRequires: libstdc++-devel
18BuildRequires: libtool >= 2:1.5
19BuildRequires: zlib-devel
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23Atlas-C++ is the current C++ implementation of the Atlas protocol, a
24communications layer designed to be used in the WorldForge MMORPG
25gaming system. This library is suitable for linking to either clients
26or servers.
27
28%description -l pl.UTF-8
29Atlas-C++ jest implementacją (w języku C++) protokołu Atlas, warstwy
30komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekę
31tę przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
32
33%package devel
34Summary: Header files for Atlas-C++ development
35Summary(pl.UTF-8): Pliki nagłówkowe do biblioteki Atlas-C++
36Group: Development/Libraries
37Requires: %{name} = %{epoch}:%{version}-%{release}
38Requires: libstdc++-devel
39# libAtlasFilters additionally R: bzip2-devel,zlib-devel
40
41%description devel
42Atlas-C++ is the current C++ implementation of the Atlas protocol, a
43communications layer designed to be used in the WorldForge MMORPG
44gaming system. This library is suitable for linking to either clients
45or servers.
46
47This package contains the header files needed to develop programs that
48use these Atlas-C++
49
50%description devel -l pl.UTF-8
51Atlas-C++ jest implementacją (w języku C++) protokołu Atlas, warstwy
52komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekę
53tę przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
54
55Pakiet zawiera pliki nagłówkowe niezbędne do kompilowania programów
56używających bibliotek Atlas-C++.
57
58%package static
59Summary: Static libraries for Atlas-C++ development
60Summary(pl.UTF-8): Statyczne biblioteki Atlas-C++
61Group: Development/Libraries
62Requires: %{name}-devel = %{epoch}:%{version}-%{release}
63
64%description static
65Atlas-C++ is the current C++ implementation of the Atlas protocol, a
66communications layer designed to be used in the WorldForge MMORPG
67gaming system. This library is suitable for linking to either clients
68or servers.
69
70This package contains the static Atlas-C++ libraries.
71
72%description static -l pl.UTF-8
73Atlas-C++ jest implementacją (w języku C++) protokołu Atlas, warstwy
74komunikacyjnej przeznaczonej do systemów WorldForge MMORPG. Bibliotekę
75tę przygotowano zarówno dla aplikacji klienckich, jak i serwerów.
76
77Pakiet zawiera statyczne biblioteki Atlas-C++.
78
79%prep
80%setup -q
81%patch0 -p1
82
83%build
84%{__libtoolize}
85%{__aclocal}
86%{__autoheader}
87%{__autoconf}
88%{__automake}
89%configure \
90 --enable-static
91%{__make}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
96%{__make} install \
97 DESTDIR=$RPM_BUILD_ROOT
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post -p /sbin/ldconfig
103%postun -p /sbin/ldconfig
104
105%files
106%defattr(644,root,root,755)
107%doc AUTHORS ChangeLog NEWS README
108%attr(755,root,root) %{_bindir}/atlas_convert
109%attr(755,root,root) %{_libdir}/libAtlas*.so.*.*.*
110
111%files devel
112%defattr(644,root,root,755)
113%attr(755,root,root) %{_libdir}/libAtlas*.so
114%{_libdir}/libAtlas*.la
115%{_includedir}/Atlas*
116%{_pkgconfigdir}/atlascpp*.pc
117
118%files static
119%defattr(644,root,root,755)
120%{_libdir}/libAtlas*.a
This page took 0.089657 seconds and 4 git commands to generate.