]> git.pld-linux.org Git - packages/Atari800.git/commitdiff
- added atari800-SDL support to chooser Atari800-1_2_0-2
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 20 Dec 2001 23:44:52 +0000 (23:44 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- use non-interactive configure style
- release 2 (configure options were not updated!)

Changed files:
    Atari800-chooser -> 1.2
    Atari800.spec -> 1.9

Atari800-chooser
Atari800.spec

index ff6d300fcc1478a59b910bad47b4be00169d8231..f77d1a5bb13ab3b28c2b035fbd6af8977e28dd9e 100644 (file)
@@ -3,7 +3,9 @@
 if [ -n "$DISPLAY" -a -x /usr/X11R6/bin/atari800-x11 ] ; then
   exec /usr/X11R6/bin/atari800-x11
 else
-  if [ -x /usr/bin/atari800-svga ] ; then
+  if [ -x /usr/X11R6/bin/atari800-SDL ] ; then
+    exec /usr/X11R6/bin/atari800-SDL
+  elif [ -x /usr/bin/atari800-svga ] ; then
     exec /usr/bin/atari800-svga
   else
     if [ -x /usr/X11R6/bin/atari800-x11 ] ; then
@@ -11,7 +13,7 @@ else
       echo "Atari800-x11 needs X-server running and DISPLAY variable set."
     else
       echo "Cannot run Atari800 - executable not found."
-      echo "Install Atari800-x11 or Atari800-svga package."
+      echo "Install Atari800-x11, Atari800-SDL or Atari800-svga package."
     fi
   fi
 fi
index b95c3ddc5d8e656497e9c4af8b055dfd1fbb5aaf..7f8b0598c3838d8264f7e79a81eb293d97626833 100644 (file)
@@ -7,7 +7,7 @@ Summary(pl):    Emulator Atari 800
 Name:          Atari800
 %define                ver_short       120
 Version:       1.2.0
-Release:       1
+Release:       2
 License:       GPL (Atari800), distributable if unmodified (xf25 with ROMs)
 Group:         Applications/Emulators
 Group(de):     Applikationen/Emulators
@@ -66,10 +66,10 @@ oraz X11.
 %package svga
 Summary:       Atari 800 Emulator - svgalib version
 Summary(pl):   Emulator Atari 800 - wersja pod svgalib
+License:       GPL
 Group:         Applications/Emulators
 Group(de):     Applikationen/Emulators
 Group(pl):     Aplikacje/Emulatory
-License:       GPL
 Requires:      %{name}-common = %{version}
 
 %description svga
@@ -87,10 +87,10 @@ svgalib z obs
 %package x11
 Summary:       Atari 800 Emulator - X Window version
 Summary(pl):   Emulator Atari 800 - wersja pod X Window
+License:       GPL
 Group:         Applications/Emulators
 Group(de):     Applikationen/Emulators
 Group(pl):     Aplikacje/Emulatory
-License:       GPL
 Requires:      %{name}-common = %{version}
 
 %description x11
@@ -108,10 +108,10 @@ obs
 %package SDL
 Summary:       Atari 800 Emulator - SDL version
 Summary(pl):   Emulator Atari 800 - wersja pod SDL
+License:       GPL
 Group:         Applications/Emulators
 Group(de):     Applikationen/Emulators
 Group(pl):     Aplikacje/Emulatory
-License:       GPL
 Requires:      %{name}-common = %{version}
 
 %description SDL
@@ -135,30 +135,30 @@ cd src
 
 autoheader
 autoconf
-%configure --target=svgalib <<EOF
-n
-y
-y
-y
-y
-n
-y
-n
-y
-n
-n
-y
-y
-y
-y
-n
-y
-n
-n
-n
-y
-y
-EOF
+%configure --target=svgalib \
+       --disable-VERY_SLOW \
+       --enable-NO_CYCLE_EXACT \
+       --enable-CRASH_MENU \
+       --enable-MONITOR_BREAK \
+       --enable-MONITOR_HINTS \
+       --enable-MONITOR_ASSEMBLER \
+       --enable-COMPILED_PALETTE \
+       --enable-SNAILMETER \
+       --disable-SVGA_SPEEDUP \
+       --enable-USE_CURSORBLOCK \
+       --disable-JOYMOUSE \
+       --enable-LINUX_JOYSTICK \
+       --enable-SOUND \
+       --enable-NO_VOL_ONLY \
+       --enable-NO_CONSOL_SOUND \
+       --disable-SERIO_SOUND \
+       --enable-NOSNDINTER \
+       --disable-CLIP \
+       --disable-STEREO \
+       --disable-BUFFERED_LOG \
+       --enable-SET_LED \
+       --enable-NO_LED_ON_SCREEN
+
 %{__make} \
        CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}" \
        LDFLAGS="%{rpmldflags}"
@@ -166,53 +166,56 @@ mv -f atari800 atari800-svga
 
 %{__make} clean
 
-%configure --target=x11-shm <<EOF
-n
-y
-y
-y
-y
-n
-n
-n
-y
-y
-y
-y
-y
-y
-n
-n
-EOF
+%configure --target=sdl \
+       --disable-VERY_SLOW \
+       --enable-NO_CYCLE_EXACT \
+       --enable-CRASH_MENU \
+       --enable-MONITOR_BREAK \
+       --enable-MONITOR_HINTS \
+       --enable-MONITOR_ASSEMBLER \
+       --enable-COMPILED_PALETTE \
+       --enable-SNAILMETER \
+       --enable-LINUX_JOYSTICK \
+       --enable-SOUND \
+       --enable-NO_VOL_ONLY \
+       --enable-NO_CONSOL_SOUND \
+       --disable-SERIO_SOUND \
+       --enable-NOSNDINTER \
+       --disable-CLIP \
+       --disable-STEREO \
+       --disable-BUFFERED_LOG \
+       --enable-SET_LED \
+       --enable-NO_LED_ON_SCREEN
+       
 %{__make} \
-       CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer} -I/usr/X11R6/include" \
+       CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer} -I/usr/X11R6/include/SDL" \
        LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
-mv -f atari800 atari800-x11
+mv -f atari800 atari800-SDL
 
-%{__make} clean
+%configure --target=x11-shm \
+       --disable-VERY_SLOW \
+       --enable-NO_CYCLE_EXACT \
+       --enable-CRASH_MENU \
+       --enable-MONITOR_BREAK \
+       --enable-MONITOR_HINTS \
+       --enable-MONITOR_ASSEMBLER \
+       --enable-COMPILED_PALETTE \
+       --enable-SNAILMETER \
+       --enable-LINUX_JOYSTICK \
+       --enable-SOUND \
+       --enable-NO_VOL_ONLY \
+       --enable-NO_CONSOL_SOUND \
+       --disable-SERIO_SOUND \
+       --enable-NOSNDINTER \
+       --disable-CLIP \
+       --disable-STEREO
 
-%configure --target=sdl <<EOF
-n
-y
-y
-y
-y
-n
-n
-n
-y
-y
-y
-y
-y
-y
-n
-n
-EOF
 %{__make} \
-       CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer} -I/usr/X11R6/include/SDL" \
+       CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer} -I/usr/X11R6/include" \
        LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
-mv -f atari800 atari800-SDL
+mv -f atari800 atari800-x11
+
+%{__make} clean
 
 sed s@/usr/local/lib/atari@%{_datadir}/atari800@g atari800.man >atari800.1
 
This page took 0.099889 seconds and 4 git commands to generate.