]> git.pld-linux.org Git - packages/Atari800.git/blobdiff - Atari800.spec
- refresh config.sub
[packages/Atari800.git] / Atari800.spec
index eaadf5a913d623b3e8433b58a9e7fa8f8c260839..98497a882273b770d0c095608347a3edcc573a7b 100644 (file)
@@ -1,17 +1,17 @@
 #
 # Conditional build:
-%bcond_with license_agreement   # with unzipped ROM files instead of xf25.zip
-%bcond_without svga            # without SVGA version
-
+%bcond_with    license_agreement       # with unzipped ROM files instead of xf25.zip
+%bcond_without svga                    # without SVGA version
+#
 Summary:       Atari 800 Emulator
 Summary(pl):   Emulator Atari 800
 Name:          Atari800
-Version:       1.3.1
-Release:       3
+Version:       1.3.2
+Release:       1
 License:       GPL (Atari800), distributable if unmodified (xf25 with ROMs)
 Group:         Applications/Emulators
 Source0:       http://dl.sourceforge.net/atari800/atari800-%{version}.tar.gz
-# Source0-md5: 02c824a4648732a3646d377ee02efd7d
+# Source0-md5: 8fcd251a3757270c02519ad7b86b7caa
 # NOTE: ROMs probably can be redistributed only in original XF25 archive
 Source1:       http://joy.sophics.cz/www/xf25.zip
 # Source1-md5: 4dc3b6b4313e9596c4d474785a37b94d
@@ -19,12 +19,10 @@ Source2:    %{name}-chooser
 URL:           http://atari800.atari.org/
 BuildRequires: SDL-devel
 BuildRequires: XFree86-devel
-%ifarch %{ix86} alpha ppc
-%if %{with svga}
-BuildRequires: svgalib-devel
-%endif
-%endif
+%{?with_svga:BuildRequires:    svgalib-devel}
+%if %{with license_agreement}
 BuildRequires: unzip
+%endif
 BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -41,8 +39,8 @@ Summary:      Atari 800 Emulator - common files for svgalib and X11 versions
 Summary(pl):   Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
 Group:         Applications/Emulators
 Obsoletes:     Atari800
-%if ! %{with license_agreement}
-Prereq:        unzip
+%if %{without license_agreement}
+Requires(post):        unzip
 %endif
 
 %description common
@@ -50,9 +48,9 @@ This is Atari 800, 800XL, 130XE and 5200 emulator.
 
 This package contains common files for both svgalib and X11 versions
 of Atari800.
-%if ! %{with license_agreement}
+%if %{without license_agreement}
 Note: because of license problems we had to include whole X-Former
-archive (xf25.zip). If you don't want it - rebuild Atari800 (--with 
+archive (xf25.zip). If you don't want it - rebuild Atari800 (--with
 license_agreement)
 %endif 
 
@@ -61,7 +59,7 @@ To jest emulator Atari 800, 800XL, 130XE i 5200.
 
 Ten pakiet zawiera pliki wspólne dla wersji dzia³aj±cych pod svgalib
 oraz X11.
-%if ! %{with license_agreement}
+%if %{without license_agreement}
 Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê
 z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -
 przebuduj pakiet z opcja --with license_agreement.
@@ -129,12 +127,12 @@ obs
 
 %build
 cd src
+cp -f /usr/share/automake/config.sub .
+
 
 CFLAGS="%{rpmcflags}"
 
 %if %{with svga}
-%ifarch %{ix86} alpha ppc
-
 %configure \
        --target=svgalib \
        --disable-VERY_SLOW \
@@ -166,7 +164,6 @@ mv -f atari800 atari800-svga
 
 %{__make} clean
 %endif
-%endif
 
 %configure \
        --target=sdl \
@@ -223,11 +220,9 @@ mv -f atari800 atari800-x11
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/atari800,%{_mandir}/man1}
 
-%ifarch %{ix86} alpha ppc
 %if %{with svga}
 install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}
 %endif
-%endif
 install src/atari800-x11 $RPM_BUILD_ROOT%{_bindir}
 install src/atari800-SDL $RPM_BUILD_ROOT%{_bindir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
@@ -243,16 +238,19 @@ install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if ! %{with license_agreement}
+%if %{without license_agreement}
 %post common
 cd %{_datadir}/atari800
-unzip -q -L xf25.zip
+if [ "`echo *.rom`" = "*.rom" ]; then
+       umask 022
+       unzip -q -L xf25.zip
+       rm -f xf25.doc xf25.exe
+fi
 %endif
 
 %files common
 %defattr(644,root,root,755)
-%doc DOC/{BUGS,CHANGES,CREDITS,FAQ,README,TODO,USAGE} README.1ST
-%doc DOC/{LPTjoy.txt,cart.txt,emuos.txt,pokeysnd.txt}
+%doc DOC/{BUGS,CREDITS,ChangeLog,FAQ,NEWS,README,TODO,USAGE,*.txt} README.1ST
 %attr(755,root,root) %{_bindir}/atari800
 %{_datadir}/atari800
 %{_mandir}/man1/atari800.1*
@@ -265,10 +263,8 @@ unzip -q -L xf25.zip
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/atari800-SDL
 
-%ifarch %{ix86} alpha ppc
 %if %{with svga}
 %files svga
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/atari800-svga
 %endif
-%endif
This page took 0.210165 seconds and 4 git commands to generate.