]> git.pld-linux.org Git - packages/Atari800.git/blobdiff - Atari800.spec
- updated to 1.3.3
[packages/Atari800.git] / Atari800.spec
index 5b05f7a5e1253c8d92922d50f68d83dc402e4219..15d8eaad82f5ac405dba445f63cdea5ed546cfcd 100644 (file)
@@ -1,31 +1,32 @@
 #
 # Conditional build:
-# _with_license_agreement - with unzipped ROM files instead of xf25.zip
-# _without_svgalib       - without SVGA version
+%bcond_with    license_agreement       # with unzipped ROM files instead of xf25.zip
+%bcond_without svga                    # without SVGA version
 #
 Summary:       Atari 800 Emulator
 Summary(pl):   Emulator Atari 800
 Name:          Atari800
-Version:       1.2.2
-Release:       2
+Version:       1.3.3
+Release:       1
 License:       GPL (Atari800), distributable if unmodified (xf25 with ROMs)
 Group:         Applications/Emulators
-Source0:       ftp://ftp.sourceforge.net/pub/sourceforge/atari800/atari800-%{version}.tar.gz
+Source0:       http://dl.sourceforge.net/atari800/atari800-%{version}.tar.gz
+# Source0-md5: af71826a71a46c786af7c88ff53b8ae8
 # NOTE: ROMs probably can be redistributed only in original XF25 archive
 Source1:       http://joy.sophics.cz/www/xf25.zip
+# Source1-md5: 4dc3b6b4313e9596c4d474785a37b94d
 Source2:       %{name}-chooser
-Patch0:                %{name}-shm_fix.patch
 URL:           http://atari800.atari.org/
+BuildRequires: SDL-devel
+BuildRequires: XFree86-devel
+%{?with_svga:BuildRequires:    svgalib-devel}
+%if %{with license_agreement}
 BuildRequires: unzip
-%ifarch %{ix86}
-%{!?_without_svgalib:BuildRequires:    svgalib-devel}
 %endif
-BuildRequires: XFree86-devel
 BuildRequires: zlib-devel
-BuildRequires: SDL-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _xbindir        %{_prefix}/X11R6/bin
+%define                specflags       -fomit-frame-pointer
 
 %description
 This is Atari 800, 800XL, 130XE and 5200 emulator.
@@ -38,28 +39,31 @@ Summary:    Atari 800 Emulator - common files for svgalib and X11 versions
 Summary(pl):   Emulator Atari 800 - pliki wspólne dla wersji svgalib oraz X11
 Group:         Applications/Emulators
 Obsoletes:     Atari800
-%{!?_with_license_agreement:Prereq:    unzip}
+%if %{without license_agreement}
+Requires(post):        unzip
+%endif
 
 %description common
 This is Atari 800, 800XL, 130XE and 5200 emulator.
 
 This package contains common files for both svgalib and X11 versions
 of Atari800.
-
-%{!?_with_license_agreement:Note: because of license problems we had to include whole X-Former}
-%{!?_with_license_agreement:archive (xf25.zip). If you don't want it - rebuild Atari800 by:}
-%{!?_with_license_agreement:rpm --rebuild --with license_agreement ftp://ftp.pld.org.pl/PLD-1.0/SRPMS/SRPMS/%{name}-%{version}-%{release}.src.rpm}
+%if %{without license_agreement}
+Note: because of license problems we had to include whole X-Former
+archive (xf25.zip). If you don't want it - rebuild Atari800 (--with
+license_agreement)
+%endif 
 
 %description common -l pl
 To jest emulator Atari 800, 800XL, 130XE i 5200.
 
 Ten pakiet zawiera pliki wspólne dla wersji dzia³aj±cych pod svgalib
 oraz X11.
-
-%{!?_with_license_agreement:Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê}
-%{!?_with_license_agreement:z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -}
-%{!?_with_license_agreement:przebuduj pakiet poleceniem:}
-%{!?_with_license_agreement:rpm --rebuild --with license_agreement ftp://ftp.pld.org.pl/PLD-1.0/SRPMS/SRPMS/%{name}-%{version}-%{release}.src.rpm}
+%if %{without license_agreement}
+Uwaga: z powodu problemów z licencj± musieli¶my za³±czyæ ca³± paczkê
+z emulatorem X-Former (xf25.zip). Je¶li jej nie chcesz w pakiecie -
+przebuduj pakiet z opcja --with license_agreement.
+%endif
 
 %package svga
 Summary:       Atari 800 Emulator - svgalib version
@@ -120,15 +124,17 @@ obs
 
 %prep
 %setup -q -n atari800-%{version}
-%patch0 -p1
 
 %build
 cd src
+rm config.sub
+cp -f /usr/share/automake/config.sub .
 
-%if %{?_without_svgalib:0}%{!?_without_svgalib:1}
-%ifarch %{ix86}
+CFLAGS="%{rpmcflags}"
 
-%configure2_13 --target=svgalib \
+%if %{with svga}
+%configure \
+       --target=svgalib \
        --disable-VERY_SLOW \
        --enable-NO_CYCLE_EXACT \
        --enable-CRASH_MENU \
@@ -152,16 +158,15 @@ cd src
        --enable-SET_LED \
        --enable-NO_LED_ON_SCREEN
 
-%{__make} \
-       CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}" \
-       LDFLAGS="%{rpmldflags}"
+%{__make}
+
 mv -f atari800 atari800-svga
 
 %{__make} clean
 %endif
-%endif
 
-%configure2_13 --target=sdl \
+%configure \
+       --target=sdl \
        --disable-VERY_SLOW \
        --enable-NO_CYCLE_EXACT \
        --enable-CRASH_MENU \
@@ -181,15 +186,15 @@ mv -f atari800 atari800-svga
        --disable-BUFFERED_LOG \
        --enable-SET_LED \
        --enable-NO_LED_ON_SCREEN
-       
-%{__make} \
-       CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer} -I/usr/X11R6/include/SDL" \
-       LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
+
+%{__make}
+
 mv -f atari800 atari800-SDL
 
 %{__make} clean
 
-%configure2_13 --target=x11-shm \
+%configure \
+       --target=shm \
        --disable-VERY_SLOW \
        --enable-NO_CYCLE_EXACT \
        --enable-CRASH_MENU \
@@ -207,64 +212,59 @@ mv -f atari800 atari800-SDL
        --disable-CLIP \
        --disable-STEREO
 
-%{__make} \
-       CFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer} -I/usr/X11R6/include" \
-       LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
-mv -f atari800 atari800-x11
+%{__make}
 
-sed s@/usr/local/lib/atari@%{_datadir}/atari800@g atari800.man >atari800.1
+mv -f atari800 atari800-x11
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_xbindir}} \
-       $RPM_BUILD_ROOT{%{_datadir}/atari800,%{_mandir}/man1}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/atari800,%{_mandir}/man1}
 
-%ifarch %{ix86}
-%{!?_without_svgalib:install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}}
+%if %{with svga}
+install src/atari800-svga $RPM_BUILD_ROOT%{_bindir}
 %endif
-install src/atari800-x11 $RPM_BUILD_ROOT%{_xbindir}
-install src/atari800-SDL $RPM_BUILD_ROOT%{_xbindir}
+install src/atari800-x11 $RPM_BUILD_ROOT%{_bindir}
+install src/atari800-SDL $RPM_BUILD_ROOT%{_bindir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
-install src/atari800.1 $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
+install src/atari800.man $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
 
-%if %{?_with_license_agreement:1}%{!?_with_license_agreement:0}
+%if %{with license_agreement}
 unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
 rm -f $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
 %else
 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
 %endif
 
-gzip -9nf DOC/{BUGS,CHANGES,CREDITS,FAQ,README,TODO,USAGE} README.1ST \
-       DOC/{LPTjoy.txt,cart.txt,emuos.txt,pokeysnd.txt}
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if %{?_with_license_agreement:0}%{!?_with_license_agreement:1}
+%if %{without license_agreement}
 %post common
 cd %{_datadir}/atari800
-unzip -q -L xf25.zip
+if [ "`echo *.rom`" = "*.rom" ]; then
+       umask 022
+       unzip -q -L xf25.zip
+       rm -f xf25.doc xf25.exe
+fi
 %endif
 
 %files common
 %defattr(644,root,root,755)
-%doc  *.gz DOC/*.gz
+%doc DOC/{BUGS,CREDITS,ChangeLog,FAQ,NEWS,README,TODO,USAGE,*.txt} README.1ST
+%attr(755,root,root) %{_bindir}/atari800
 %{_datadir}/atari800
 %{_mandir}/man1/atari800.1*
-%attr(755,root,root) %{_bindir}/atari800
 
 %files x11
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_xbindir}/atari800-x11
+%attr(755,root,root) %{_bindir}/atari800-x11
 
 %files SDL
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_xbindir}/atari800-SDL
+%attr(755,root,root) %{_bindir}/atari800-SDL
 
-%ifarch %{ix86}
-%if %{?_without_svgalib:0}%{!?_without_svgalib:1}
+%if %{with svga}
 %files svga
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/atari800-svga
 %endif
-%endif
This page took 0.083886 seconds and 4 git commands to generate.