]> git.pld-linux.org Git - packages/Atari800.git/blob - Atari800.spec
- Up to 5.2.0.
[packages/Atari800.git] / Atari800.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # with unzipped ROM files instead of xf25.zip
4 #
5 Summary:        Atari 800 Emulator
6 Summary(pl.UTF-8):      Emulator Atari 800
7 Name:           Atari800
8 Version:        4.0.0
9 Release:        1
10 License:        GPL v2+ (Atari800), distributable if unmodified (xf25 with ROMs)
11 Group:          Applications/Emulators
12 Source0:        https://sourceforge.net/projects/atari800/files/atari800/%{version}/atari800-%{version}.tar.gz
13 # Source0-md5:  72ba8e390a8fba7d087c2c089dae6d3c
14 # NOTE: ROMs probably can be redistributed only in original XF25 archive
15 Source1:        http://joy.sophics.cz/www/xf25.zip
16 # Source1-md5:  4dc3b6b4313e9596c4d474785a37b94d
17 Source2:        %{name}-chooser
18 URL:            https://atari800.github.io/
19 BuildRequires:  SDL-devel
20 BuildRequires:  automake
21 %if %{with license_agreement}
22 BuildRequires:  unzip
23 %endif
24 BuildRequires:  xorg-lib-libX11-devel
25 BuildRequires:  xorg-lib-libXext-devel
26 BuildRequires:  zlib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         specflags       -fomit-frame-pointer
30
31 %description
32 This is Atari 800, 800XL, 130XE and 5200 emulator.
33
34 %description -l pl.UTF-8
35 To jest emulator Atari 800, 800XL, 130XE i 5200.
36
37 %package common
38 Summary:        Atari 800 Emulator - common files for SDL and X11 versions
39 Summary(pl.UTF-8):      Emulator Atari 800 - pliki wspólne dla wersji SDL oraz X11
40 Group:          Applications/Emulators
41 Obsoletes:      Atari800
42 %if !%{with license_agreement}
43 Requires(post): unzip
44 %endif
45
46 %description common
47 This is Atari 800, 800XL, 130XE and 5200 emulator.
48
49 This package contains common files for both SDL and X11 versions
50 of Atari800.
51 %if !%{with license_agreement}
52 Note: because of license problems we had to include whole X-Former
53 archive (xf25.zip). If you don't want it - rebuild Atari800 (--with
54 license_agreement)
55 %endif 
56
57 %description common -l pl.UTF-8
58 To jest emulator Atari 800, 800XL, 130XE i 5200.
59
60 Ten pakiet zawiera pliki wspólne dla wersji działających pod SDL
61 oraz X11.
62 %if !%{with license_agreement}
63 Uwaga: z powodu problemów z licencją musieliśmy załączyć całą paczkę
64 z emulatorem X-Former (xf25.zip). Jeśli jej nie chcesz w pakiecie -
65 przebuduj pakiet z opcja --with license_agreement.
66 %endif
67
68 %package x11
69 Summary:        Atari 800 Emulator - X Window version
70 Summary(pl.UTF-8):      Emulator Atari 800 - wersja dla systemu X Window
71 License:        GPL
72 Group:          Applications/Emulators
73 Requires:       %{name}-common = %{version}-%{release}
74
75 %description x11
76 This is Atari 800, 800XL, 130XE and 5200 emulator.
77
78 This package contains Atari800 executable file configured for X11 with
79 OSS sound and joystick support.
80
81 %description x11 -l pl.UTF-8
82 To jest emulator Atari 800, 800XL, 130XE i 5200.
83
84 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla X11 z
85 obsługą dźwięku OSS i joysticka.
86
87 %package SDL
88 Summary:        Atari 800 Emulator - SDL version
89 Summary(pl.UTF-8):      Emulator Atari 800 - wersja SDL
90 License:        GPL
91 Group:          Applications/Emulators
92 Requires:       %{name}-common = %{version}-%{release}
93 Obsoletes:      Atari800-svga
94
95 %description SDL
96 This is Atari 800, 800XL, 130XE and 5200 emulator.
97
98 This package contains Atari800 executable file configured for SDL with
99 sound and joystick support.
100
101 %description SDL -l pl.UTF-8
102 To jest emulator Atari 800, 800XL, 130XE i 5200.
103
104 Ten pakiet zawiera wykonywalny plik emulatora skonfigurowany dla SDL z
105 obsługą dźwięku i joysticka.
106
107 %prep
108 %setup -q -n atari800-%{version}
109
110 %build
111 cd src
112 rm config.sub
113 cp -f /usr/share/automake/config.sub .
114
115 %configure \
116         --target=x11-shm \
117         --enable-crashmenu \
118         --disable-stereosound \
119         --with-sound=sdl \
120         --with-video=sdl
121
122 %{__make}
123
124 %{__mv} atari800 atari800-SDL
125
126 %{__make} clean
127
128 %configure \
129         --target=x11-shm \
130         --enable-crashmenu \
131         --disable-stereosound \
132         --with-sound=oss \
133         --with-video=no
134
135 %{__make}
136
137 %{__mv} atari800 atari800-x11
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/atari800,%{_mandir}/man1}
142
143 install src/atari800-x11 $RPM_BUILD_ROOT%{_bindir}
144 install src/atari800-SDL $RPM_BUILD_ROOT%{_bindir}
145 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/atari800
146 install src/atari800.man $RPM_BUILD_ROOT%{_mandir}/man1/atari800.1
147
148 %if %{with license_agreement}
149 unzip -q -L %{SOURCE1} -d $RPM_BUILD_ROOT%{_datadir}/atari800
150 %{__rm} $RPM_BUILD_ROOT%{_datadir}/atari800/xf25.*
151 %else
152 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/atari800
153 %endif
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %if !%{with license_agreement}
159 %post common
160 cd %{_datadir}/atari800
161 if [ "`echo *.rom`" = "*.rom" ]; then
162         umask 022
163         unzip -q -L xf25.zip
164         rm -f xf25.doc xf25.exe
165 fi
166 %endif
167
168 %files common
169 %defattr(644,root,root,755)
170 %doc DOC/{BUGS,CREDITS,ChangeLog,FAQ,NEWS,README,TODO,USAGE,*.txt} README.1ST
171 %attr(755,root,root) %{_bindir}/atari800
172 %{_datadir}/atari800
173 %{_mandir}/man1/atari800.1*
174
175 %files x11
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_bindir}/atari800-x11
178
179 %files SDL
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_bindir}/atari800-SDL
This page took 0.093356 seconds and 3 git commands to generate.