]> git.pld-linux.org Git - packages/AppStream.git/commitdiff
- fix upstream cmake breakage auto/th/AppStream-0.11.8-2
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 24 Mar 2018 10:45:30 +0000 (11:45 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 24 Mar 2018 10:45:30 +0000 (11:45 +0100)
- rel 2

AppStream.spec
cmake.patch [new file with mode: 0644]

index e9c059a83bb0007e3dc3d7ed458057f53eb90aa4..70fb08c616eeb02fc7858489bb2abceff084a6eb 100644 (file)
@@ -9,11 +9,12 @@ Summary:      AppStream-Core library and tools
 Summary(pl.UTF-8):     Biblioteka i narzędzia AppStream-Core
 Name:          AppStream
 Version:       0.11.8
-Release:       1
+Release:       2
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       https://www.freedesktop.org/software/appstream/releases/%{name}-%{version}.tar.xz
 # Source0-md5: 887436049bd96c47ffccef107452c87d
+Patch0:                cmake.patch
 URL:           https://www.freedesktop.org/wiki/Distributions/AppStream/
 BuildRequires: docbook-style-xsl-nons
 BuildRequires: gettext-tools
@@ -138,6 +139,7 @@ API języka Vala do biblioteki AppStream.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %meson build \
diff --git a/cmake.patch b/cmake.patch
new file mode 100644 (file)
index 0000000..a4cee27
--- /dev/null
@@ -0,0 +1,25 @@
+From 3e58f9c97d95785b2bcab632871a59a04050a458 Mon Sep 17 00:00:00 2001
+From: Gabriel Souza Franco <gabrielfrancosouza@gmail.com>
+Date: Wed, 24 Jan 2018 14:26:28 +0100
+Subject: [PATCH] qt: Fix regression from #153
+
+Define location and soname for all configurations, not just Debug.
+---
+ qt/cmake/AppStreamQtConfig.cmake.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/qt/cmake/AppStreamQtConfig.cmake.in b/qt/cmake/AppStreamQtConfig.cmake.in
+index aa61e820..b64a4f57 100644
+--- a/qt/cmake/AppStreamQtConfig.cmake.in
++++ b/qt/cmake/AppStreamQtConfig.cmake.in
+@@ -32,8 +32,8 @@ add_library(AppStreamQt SHARED IMPORTED)
+ set_target_properties(AppStreamQt PROPERTIES
+   INTERFACE_INCLUDE_DIRECTORIES "${PACKAGE_PREFIX_DIR}/include/"
+   INTERFACE_LINK_LIBRARIES "Qt5::Core"
+-  IMPORTED_LOCATION_DEBUG "@LIBDIR_FULL@/libAppStreamQt.so.${AppStreamQt_VERSION}"
+-  IMPORTED_SONAME_DEBUG "libAppStreamQt.${AppStreamQt_VERSION_MAJOR}"
++  IMPORTED_LOCATION "@LIBDIR_FULL@/libAppStreamQt.so.${AppStreamQt_VERSION}"
++  IMPORTED_SONAME "libAppStreamQt.${AppStreamQt_VERSION_MAJOR}"
+ )
+ ####################################################################################
This page took 0.044247 seconds and 4 git commands to generate.