]> git.pld-linux.org Git - packages/AppStream.git/blob - AppStream.spec
- new
[packages/AppStream.git] / AppStream.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation build
4 %bcond_without  vala            # Vala API (VAPI)
5 #
6 Summary:        AppStream-Core library and tools
7 Summary(pl.UTF-8):      Biblioteka i narzędzia AppStream-Core
8 Name:           AppStream
9 Version:        0.6.2
10 Release:        1
11 License:        LGPL v3
12 Group:          Libraries
13 Source0:        http://www.freedesktop.org/software/appstream/releases/%{name}-%{version}.tar.gz
14 # Source0-md5:  c5df357df76156f7a6d4dd9a27b50b66
15 URL:            http://www.freedesktop.org/wiki/Distributions/AppStream/Software/
16 BuildRequires:  PackageKit-devel
17 BuildRequires:  cmake >= 2.8.6
18 BuildRequires:  gettext-devel
19 BuildRequires:  glib2-devel >= 1:2.36
20 BuildRequires:  gobject-introspection-devel
21 BuildRequires:  intltool
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libxml2-devel >= 2.0
24 BuildRequires:  pkgconfig
25 %{?with_vala:BuildRequires:     vala}
26 BuildRequires:  xapian-core-devel >= 1.2
27 %if %{with apidocs}
28 BuildRequires:  gtk-doc
29 BuildRequires:  publican
30 BuildRequires:  xmlto
31 %endif
32 Requires:       glib2 >= 1:2.36
33 Requires:       xapian-core-libs >= 1.2
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 AppStream-Core library and tools to access the AppStream component
38 database.
39
40 %description -l pl.UTF-8
41 Biblioteka i narzędzia AppStream-Core służące do dostępu do bazy
42 danych komponentu AppStream.
43
44 %package devel
45 Summary:        Header files for AppStream library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki AppStream
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       glib2-devel >= 1:2.36
50
51 %description devel
52 Header files for AppStream library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki AppStream.
56
57 %package apidocs
58 Summary:        AppStream API documentation
59 Summary(pl.UTF-8):      Dokumentacja API biblioteki AppStream
60 Group:          Documentation
61
62 %description apidocs
63 API documentation for AppStream library.
64
65 %description apidocs -l pl.UTF-8
66 Dokumentacja API biblioteki AppStream.
67
68 %package -n vala-appstream
69 Summary:        Vala API for AppStream library
70 Summary(pl.UTF-8):      API języka Vala do biblioteki AppStream
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73 Requires:       vala
74
75 %description -n vala-appstream
76 Vala API for AppStream library.
77
78 %description -n vala-appstream -l pl.UTF-8
79 API języka Vala do biblioteki AppStream.
80
81 %package -n PackageKit-plugin-appstream
82 Summary:        AppStream plugin for PackageKit
83 Summary(pl.UTF-8):      Wtyczka AppStream dla PackageKita
84 Group:          Libraries
85 Requires:       %{name} = %{version}-%{release}
86 Requires:       PackageKit
87
88 %description -n PackageKit-plugin-appstream
89 AppStream plugin for PackageKit. It refreshes the AppStream database
90 of available applications.
91
92 %description -n PackageKit-plugin-appstream -l pl.UTF-8
93 Wtyczka AppStream dla PackageKita. Odświeża bazę danych AppStream
94 dostępnych aplikacji.
95
96 %prep
97 %setup -q
98
99 %build
100 install -d build
101 cd build
102 %cmake .. \
103         %{?with_apidocs:-DDOCUMENTATION=ON} \
104         %{?with_vala:-DVAPI=ON}
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} -C build install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS MAINTAINERS NEWS README RELEASE
123 %attr(755,root,root) %{_bindir}/appstream-index
124 %attr(755,root,root) %{_bindir}/appstream-validate
125 %attr(755,root,root) %{_libdir}/libappstream.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libappstream.so.0
127 %{_libdir}/girepository-1.0/Appstream-0.6.typelib
128 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/appstream.conf
129 %dir %{_datadir}/app-info
130 %{_datadir}/app-info/categories.xml
131 %{_mandir}/man1/appstream-index.1*
132 %{_mandir}/man1/appstream-validate.1*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libappstream.so
137 %{_datadir}/gir-1.0/Appstream-0.6.gir
138 %{_includedir}/Appstream
139 %{_pkgconfigdir}/appstream.pc
140
141 %if %{with apidocs}
142 %files apidocs
143 %defattr(644,root,root,755)
144 %doc docs/html/*
145 %endif
146
147 %if %{with vala}
148 %files -n vala-appstream
149 %defattr(644,root,root,755)
150 %{_datadir}/vala/vapi/appstream.vapi
151 %endif
152
153 %files -n PackageKit-plugin-appstream
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin_appstream.so
This page took 0.099259 seconds and 4 git commands to generate.