]> git.pld-linux.org Git - packages/AppStream.git/blob - AppStream.spec
70556710039bc08a7051192393f608a7d1f43a7b
[packages/AppStream.git] / AppStream.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation build
4 %bcond_with     apt             # Debian/APT support
5 %bcond_without  qt              # Qt library (libappstream-qt)
6 %bcond_without  vala            # Vala API (VAPI)
7
8 Summary:        AppStream-Core library and tools
9 Summary(pl.UTF-8):      Biblioteka i narzędzia AppStream-Core
10 Name:           AppStream
11 Version:        0.9.3
12 Release:        1
13 License:        LGPL v2.1+
14 Group:          Libraries
15 Source0:        https://www.freedesktop.org/software/appstream/releases/%{name}-%{version}.tar.xz
16 # Source0-md5:  38a2a1d63a71feaa022ce340dd0e922b
17 URL:            https://www.freedesktop.org/wiki/Distributions/AppStream/
18 BuildRequires:  cmake >= 3.2.0
19 BuildRequires:  gettext-tools
20 BuildRequires:  glib2-devel >= 1:2.36
21 BuildRequires:  gobject-introspection-devel
22 BuildRequires:  intltool
23 BuildRequires:  libstdc++-devel >= 6:4.7
24 BuildRequires:  libxml2-devel >= 2.0
25 BuildRequires:  pkgconfig
26 BuildRequires:  protobuf-devel
27 BuildRequires:  tar >= 1:1.22
28 %{?with_vala:BuildRequires:     vala}
29 BuildRequires:  xapian-core-devel >= 1.2
30 BuildRequires:  xz
31 BuildRequires:  yaml-devel >= 0.1
32 %if %{with qt}
33 BuildRequires:  Qt5Core-devel >= 5.0
34 BuildRequires:  qt5-qmake >= 5.0
35 %endif
36 %if %{with apidocs}
37 BuildRequires:  gtk-doc
38 BuildRequires:  publican
39 BuildRequires:  xmlto
40 %endif
41 Requires:       glib2 >= 1:2.36
42 Requires:       xapian-core-libs >= 1.2
43 Obsoletes:      PackageKit-plugin-appstream
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 AppStream-Core library and tools to access the AppStream component
48 database.
49
50 %description -l pl.UTF-8
51 Biblioteka i narzędzia AppStream-Core służące do dostępu do bazy
52 danych komponentu AppStream.
53
54 %package devel
55 Summary:        Header files for AppStream library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki AppStream
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       glib2-devel >= 1:2.36
60
61 %description devel
62 Header files for AppStream library.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki AppStream.
66
67 %package apidocs
68 Summary:        AppStream API documentation
69 Summary(pl.UTF-8):      Dokumentacja API biblioteki AppStream
70 Group:          Documentation
71 %if "%{_rpmversion}" >= "5"
72 BuildArch:      noarch
73 %endif
74
75 %description apidocs
76 API documentation for AppStream library.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API biblioteki AppStream.
80
81 %package qt
82 Summary:        AppstreamQt library
83 Summary(pl.UTF-8):      Biblioteka AppstreamQt
84 Group:          Libraries
85 Requires:       Qt5Core >= 5.0
86 Requires:       xapian-core-libs >= 1.2
87
88 %description qt
89 AppstreamQt library.
90
91 %description qt -l pl.UTF-8
92 Biblioteka AppstreamQt.
93
94 %package qt-devel
95 Summary:        Header files for AppstreamQt library
96 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki AppstreamQt
97 Group:          Libraries
98 Requires:       %{name}-qt = %{version}-%{release}
99 Requires:       Qt5Core-devel >= 5.0
100
101 %description qt-devel
102 Header files for AppstreamQt library.
103
104 %description qt-devel -l pl.UTF-8
105 Pliki nagłówkowe biblioteki AppstreamQt.
106
107 %package -n gettext-its-metainfo
108 Summary:        AppStream metainfo ITS data for gettext tools
109 Summary(pl.UTF-8):      Dane ITS AppStream metainfo dla narzędzi gettext
110 Group:          Development/Tools
111 Requires:       gettext-tools >= 0.19
112
113 %description -n gettext-its-metainfo
114 AppStream metainfo ITS data for gettext tools.
115
116 %description -n gettext-its-metainfo -l pl.UTF-8
117 Dane ITS AppStream metainfo dla narzędzi gettext.
118
119 %package -n vala-appstream
120 Summary:        Vala API for AppStream library
121 Summary(pl.UTF-8):      API języka Vala do biblioteki AppStream
122 Group:          Development/Libraries
123 Requires:       %{name}-devel = %{version}-%{release}
124 Requires:       vala
125 %if "%{_rpmversion}" >= "5"
126 BuildArch:      noarch
127 %endif
128
129 %description -n vala-appstream
130 Vala API for AppStream library.
131
132 %description -n vala-appstream -l pl.UTF-8
133 API języka Vala do biblioteki AppStream.
134
135 %prep
136 %setup -q
137
138 %build
139 install -d build
140 cd build
141 %cmake .. \
142         %{?with_apt:-DAPT_SUPPORT=ON} \
143         %{?with_apidocs:-DDOCUMENTATION=ON} \
144         %{?with_qt:-DQT=ON} \
145         %{?with_vala:-DVAPI=ON}
146
147 %{__make} -j1
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 %{__make} -C build install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 install -d $RPM_BUILD_ROOT%{_docdir}
156 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc $RPM_BUILD_ROOT%{_docdir}
157
158 %find_lang appstream
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %post   qt -p /sbin/ldconfig
167 %postun qt -p /sbin/ldconfig
168
169 %files -f appstream.lang
170 %defattr(644,root,root,755)
171 %doc AUTHORS MAINTAINERS NEWS README.md RELEASE
172 %attr(755,root,root) %{_bindir}/appstreamcli
173 %attr(755,root,root) %{_libdir}/libappstream.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libappstream.so.3
175 %{_libdir}/girepository-1.0/AppStream-1.0.typelib
176 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/appstream.conf
177 %dir %{_datadir}/app-info
178 %{_datadir}/app-info/categories.xml
179 %if %{with apt}
180 /etc/apt/apt.conf.d/50appstream
181 %endif
182 %{_mandir}/man1/appstreamcli.1*
183
184 %files devel
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/libappstream.so
187 %{_datadir}/gir-1.0/AppStream-1.0.gir
188 %{_includedir}/AppStream
189 %{_pkgconfigdir}/appstream.pc
190
191 %if %{with apidocs}
192 %files apidocs
193 %defattr(644,root,root,755)
194 %{_docdir}/appstream
195 %{_gtkdocdir}/appstream
196 %endif
197
198 %if %{with qt}
199 %files qt
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_libdir}/libAppstreamQt.so.*.*.*
202 %attr(755,root,root) %ghost %{_libdir}/libAppstreamQt.so.1
203
204 %files qt-devel
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_libdir}/libAppstreamQt.so
207 %{_includedir}/AppstreamQt
208 %{_libdir}/cmake/AppstreamQt
209 %endif
210
211 %files -n gettext-its-metainfo
212 %defattr(644,root,root,755)
213 %{_datadir}/gettext/its/metainfo.its
214 %{_datadir}/gettext/its/metainfo.loc
215
216 %if %{with vala}
217 %files -n vala-appstream
218 %defattr(644,root,root,755)
219 %{_datadir}/vala/vapi/appstream.vapi
220 %endif
This page took 0.054484 seconds and 2 git commands to generate.