]> git.pld-linux.org Git - packages/AppStream.git/blob - AppStream.spec
0d7e60f80f52ae9b7170eee6763039a318d21bfc
[packages/AppStream.git] / AppStream.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation build
4 %bcond_with     apt             # Debian/APT support
5 %bcond_without  qt              # Qt library (libappstream-qt)
6 %bcond_without  vala            # Vala API (VAPI)
7
8 Summary:        AppStream-Core library and tools
9 Summary(pl.UTF-8):      Biblioteka i narzędzia AppStream-Core
10 Name:           AppStream
11 Version:        0.9.0
12 Release:        1
13 License:        LGPL v2.1+
14 Group:          Libraries
15 Source0:        http://www.freedesktop.org/software/appstream/releases/%{name}-%{version}.tar.xz
16 # Source0-md5:  ed98d9329a6f892ac466e3465a26750c
17 URL:            http://www.freedesktop.org/wiki/Distributions/AppStream/Software/
18 BuildRequires:  cmake >= 3.2.0
19 BuildRequires:  gettext-tools
20 BuildRequires:  glib2-devel >= 1:2.36
21 BuildRequires:  gobject-introspection-devel
22 BuildRequires:  intltool
23 BuildRequires:  libstdc++-devel >= 6:4.7
24 BuildRequires:  libxml2-devel >= 2.0
25 BuildRequires:  pkgconfig
26 BuildRequires:  protobuf-devel
27 BuildRequires:  tar >= 1:1.22
28 %{?with_vala:BuildRequires:     vala}
29 BuildRequires:  xapian-core-devel >= 1.2
30 BuildRequires:  xz
31 BuildRequires:  yaml-devel >= 0.1
32 %if %{with qt}
33 BuildRequires:  Qt5Core-devel >= 5.0
34 BuildRequires:  qt5-qmake >= 5.0
35 %endif
36 %if %{with apidocs}
37 BuildRequires:  gtk-doc
38 BuildRequires:  publican
39 BuildRequires:  xmlto
40 %endif
41 Requires:       glib2 >= 1:2.36
42 Requires:       xapian-core-libs >= 1.2
43 Obsoletes:      PackageKit-plugin-appstream
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 AppStream-Core library and tools to access the AppStream component
48 database.
49
50 %description -l pl.UTF-8
51 Biblioteka i narzędzia AppStream-Core służące do dostępu do bazy
52 danych komponentu AppStream.
53
54 %package devel
55 Summary:        Header files for AppStream library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki AppStream
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       glib2-devel >= 1:2.36
60
61 %description devel
62 Header files for AppStream library.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki AppStream.
66
67 %package apidocs
68 Summary:        AppStream API documentation
69 Summary(pl.UTF-8):      Dokumentacja API biblioteki AppStream
70 Group:          Documentation
71 %if "%{_rpmversion}" >= "5"
72 BuildArch:      noarch
73 %endif
74
75 %description apidocs
76 API documentation for AppStream library.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API biblioteki AppStream.
80
81 %package qt
82 Summary:        AppstreamQt library
83 Summary(pl.UTF-8):      Biblioteka AppstreamQt
84 Group:          Libraries
85 Requires:       Qt5Core >= 5.0
86 Requires:       xapian-core-libs >= 1.2
87
88 %description qt
89 AppstreamQt library.
90
91 %description qt -l pl.UTF-8
92 Biblioteka AppstreamQt.
93
94 %package qt-devel
95 Summary:        Header files for AppstreamQt library
96 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki AppstreamQt
97 Group:          Libraries
98 Requires:       %{name}-qt = %{version}-%{release}
99 Requires:       Qt5Core-devel >= 5.0
100
101 %description qt-devel
102 Header files for AppstreamQt library.
103
104 %description qt-devel -l pl.UTF-8
105 Pliki nagłówkowe biblioteki AppstreamQt.
106
107 %package -n vala-appstream
108 Summary:        Vala API for AppStream library
109 Summary(pl.UTF-8):      API języka Vala do biblioteki AppStream
110 Group:          Development/Libraries
111 Requires:       %{name}-devel = %{version}-%{release}
112 Requires:       vala
113
114 %description -n vala-appstream
115 Vala API for AppStream library.
116
117 %description -n vala-appstream -l pl.UTF-8
118 API języka Vala do biblioteki AppStream.
119
120 %prep
121 %setup -q
122
123 %build
124 install -d build
125 cd build
126 %cmake .. \
127         %{?with_apt:-DAPT_SUPPORT=ON} \
128         %{?with_apidocs:-DDOCUMENTATION=ON} \
129         %{?with_qt:-DQT=ON} \
130         %{?with_vala:-DVAPI=ON}
131
132 %{__make} -j1
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} -C build install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 install -d $RPM_BUILD_ROOT%{_docdir}
141 %{__mv} $RPM_BUILD_ROOT%{_datadir}/gtk-doc $RPM_BUILD_ROOT%{_docdir}
142
143 %find_lang appstream
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -p /sbin/ldconfig
149 %postun -p /sbin/ldconfig
150
151 %post   qt -p /sbin/ldconfig
152 %postun qt -p /sbin/ldconfig
153
154 %files -f appstream.lang
155 %defattr(644,root,root,755)
156 %doc AUTHORS MAINTAINERS NEWS README.md RELEASE
157 %attr(755,root,root) %{_bindir}/appstreamcli
158 %attr(755,root,root) %{_libdir}/libappstream.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libappstream.so.3
160 %{_libdir}/girepository-1.0/AppStream-1.0.typelib
161 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/appstream.conf
162 %dir %{_datadir}/app-info
163 %{_datadir}/app-info/categories.xml
164 %if %{with apt}
165 /etc/apt/apt.conf.d/50appstream
166 %endif
167 %{_mandir}/man1/appstreamcli.1*
168
169 %files devel
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/libappstream.so
172 %{_datadir}/gir-1.0/AppStream-1.0.gir
173 %{_includedir}/AppStream
174 %{_pkgconfigdir}/appstream.pc
175
176 %if %{with apidocs}
177 %files apidocs
178 %defattr(644,root,root,755)
179 %{_docdir}/appstream
180 %{_gtkdocdir}/appstream
181 %endif
182
183 %if %{with qt}
184 %files qt
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/libAppstreamQt.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libAppstreamQt.so.1
188
189 %files qt-devel
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/libAppstreamQt.so
192 %{_includedir}/AppstreamQt
193 %{_libdir}/cmake/AppstreamQt
194 %endif
195
196 %if %{with vala}
197 %files -n vala-appstream
198 %defattr(644,root,root,755)
199 %{_datadir}/vala/vapi/appstream.vapi
200 %endif
This page took 0.049914 seconds and 2 git commands to generate.