]> git.pld-linux.org Git - packages/ApacheJServ.git/blobdiff - ApacheJServ.spec
s/Freely/freely in License
[packages/ApacheJServ.git] / ApacheJServ.spec
index 68fa7740599ec6df7aa7fe514cc1f9308f963e36..00966e8581e7582a811a31988b3bd856807476bd 100644 (file)
@@ -8,21 +8,20 @@
 %define logdir    /var/log/httpd
 %define servletdir /home/httpd/servlets
 %define classesdir /home/httpd/classes
-%define jsdkversion 19991120
+%define jsdkversion 20000924
 
 Summary:       Servlet engine with support for the leading web server
+Summary(pl):   Silnik serwletów ze wsparciem dla wiod±cego serwera WWW
 Name:          ApacheJServ
 Version:       1.1
 Release:       3
 Source0:       http://java.apache.org/jserv/dist/%{name}-%{version}.tar.gz
-Source1:       http://www.euronet.nl/~pauls/java/servlet/download/%{version}%{name}classpathx_servlet-%{jsdkversion}.tar.gz
-Patch0:                ApacheJServ-enable-secret.patch
-Patch1:                ApacheJServ-DESTDIR.patch
+Source1:       http://www.euronet.nl/~pauls/java/servlet/download/classpathx_servlet-%{jsdkversion}.tar.gz
+Patch0:                %{name}-enable-secret.patch
+Patch1:                %{name}-DESTDIR.patch
 URL:           http://java.apache.org/
-Copyright:     Freely distributable & usable
+License:       freely distributable & usable
 Group:         Networking/Daemons
-Group(pl):     Sieciowe/Serwery
-Docdir:                %{prefix}/doc
 Requires:      apache >= 1.3.6
 Provides:      jserv jsdk20
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -31,26 +30,35 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 BuildRequires: automake     >= 1.4
 BuildRequires: autoconf     >= 2.13
-BuildRequires: libtool      >= 1.3.3 
+BuildRequires: libtool      >= 1.3.3
 BuildRequires: apache-devel >= 1.3.9-8
 
 %description
 Apache JServ is a servlet engine, developed by the Java Apache Project
-<http://java.apache.org/>. The Apache JServ servlet engine is written in
-100pc Java application, and listens for servlet requests using the Apache
-Java protocol (AJp). Typically, these requests will originate from the
-mod_jserv Apache module (DSO included). This package contains a LGPL'ed
-implementation of sun's java servlet api version 2.0 by Paul Siegmann
+<http://java.apache.org/>. The Apache JServ servlet engine is written
+in 100pc Java application, and listens for servlet requests using the
+Apache Java protocol (AJp). Typically, these requests will originate
+from the mod_jserv Apache module (DSO included). This package contains
+a LGPL'ed implementation of sun's java servlet api version 2.0 by Paul
+Siegmann <http://www.euronet.nl/~pauls/java/servlet/>
+
+%description -l pl
+Apache JServ jest silnikiem serwletowym, rozwijanym przez Java Apache
+Project <http://java.apache.org/>. Silnik serwletowy Apache JServ
+zosta³ napisany od pocz±tku do koñca w Javie; nas³uchuje wywo³añ
+serwletu wykorzystuj±c protokó³ Apache Java (AJp). Zazwyczaj wywo³ania
+te pochodz± z modu³u Apache mod_jservmodule (³±cznie z DSO). Pakiet
+ten zawiera sunowsk± implementacjê api serletów w javie w wersji 2.0
+(na licencji LGPL) napisana przez Paula Siegmanna
 <http://www.euronet.nl/~pauls/java/servlet/>
 
 %prep
-rm -rf $RPM_BUILD_ROOT
 %setup -q -a 1
 
 %patch0
 %patch1 -p1
 
-# final position of GNU JSDK-Classes 
+# final position of GNU JSDK-Classes
 sed 's|@JSDK_CLASSES@|%{classesdir}/servlet-2.0.jar|g' \
     < conf/jserv.properties.in  > conf/jserv.properties.in.new
 mv conf/jserv.properties.in.new conf/jserv.properties.in
@@ -60,14 +68,14 @@ sed 's|@LOAD_OR_NOT@|#|g' \
     < conf/jserv.conf.in  > conf/jserv.conf.in.new
 mv conf/jserv.conf.in.new conf/jserv.conf.in
 
+%build
 # prepare compilation
 aclocal
 autoconf
-automake
+automake -a -c -f
 
-%build
-make -C classpathx_servlet-%{jsdkversion} jar_2_0
-make -C classpathx_servlet-%{jsdkversion}/apidoc
+%{__make} -C classpathx_servlet-%{jsdkversion} jar_2_0
+%{__make} -C classpathx_servlet-%{jsdkversion}/apidoc
 
 # copy API-doc
 mkdir jsdk-doc
@@ -79,59 +87,20 @@ cp -r classpathx_servlet-%{jsdkversion}/apidoc jsdk-doc
 
 ### JSERV
 
-# find apxs utility ..
-# .. in PATH
-APXS_UTIL=`type -p apxs || true`
-
-# .. from RPM
-if test "x$APXS_UTIL" = x ; then
-  # mmh, is it possible to query just for
-  # the executeables  (like -qd and -qc) ?
-  APXSMATCH=`rpm -ql apache-devel apache | grep apxs`
-  for f in $APXSMATCH ; do
-    if test -x "$f"  ; then
-       APXS_UTIL=$f
-       break
-    fi
-  done
-fi
-
-# .. at usual places
-if test "x$APXS_UTIL" = x ; then
-   for loc in \
-    %{_bindir}               \
-    %{_sbindir}              \
-    %{_prefix}/local/apache/bin  \
-    %{_prefix}/local/apache/sbin \
-    %{_prefix}/local/httpd/bin   \
-    %{_prefix}/local/httpd/sbin 
-  do
-    if test -x "$loc/apxs" ; then
-       APXS_UTIL="$loc/apxs"
-       break
-    fi
-  done
-fi
-
-if test "x$APXS_UTIL" = x ; then
-   echo "Didn't find apxs .. exiting"
-   exit -1
-fi
-
 APXS_CFLAGS=`$APXS_UTIL -q CFLAGS`
-CFLAGS="$APXS_CFLAGS $RPM_OPT_FLAGS" ./configure \
-       --prefix=%{_prefix}          \
-       --disable-debugging           \
-       --with-apxs=$APXS_UTIL        \
-       --with-logdir=%{logdir}       \
+CFLAGS="$APXS_CFLAGS %{rpmcflags}" ./configure \
+       --prefix=%{_prefix} \
+       --disable-debugging \
+       --with-apxs=/usr/sbin/apxs \
+       --with-logdir=%{logdir} \
        --with-servlets=%{servletdir} \
        --with-JSDK=`pwd`/classpathx_servlet-%{jsdkversion}/servlet-2.0.jar
-make
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-make DESTDIR=$RPM_BUILD_ROOT install
+%{__make} DESTDIR=$RPM_BUILD_ROOT install
 
 echo "default - change on install `date`" > $RPM_BUILD_ROOT/%{jservconf}/jserv.secret.key
 chmod 600 $RPM_BUILD_ROOT/%{jservconf}/jserv.secret.key
@@ -157,7 +126,7 @@ rm -rf $RPM_BUILD_ROOT
 # guessable secret key. Use md5sum to create a hash from this, if available:
 (%{_prefix}/games/fortune 2>/dev/null ; date ; ps -eal 2>/dev/null)   \
                    | (md5sum 2>/dev/null || cat)               \
-                   > %{jservconf}/jserv.secret.key 
+                   > %{jservconf}/jserv.secret.key
 chmod 600 %{jservconf}/jserv.secret.key
 
 #
@@ -167,7 +136,7 @@ APACHEUSER=`grep "^User[     ]\+" %{httpdconf}/httpd.conf | awk '{print $2}'`
 if test ! "x$APACHEUSER" = x ; then
    USERCOMMENT="(which is '$APACHEUSER' ?)"
 else
-   # assumption:       
+   # assumption:
    APACHEUSER=nobody
 fi
 chown $APACHEUSER %{jservconf}/jserv.secret.key
@@ -200,7 +169,7 @@ if test $? -eq 0 ; then
        > %{httpdconf}/httpd.conf
 else
    # append it
-   ( 
+   (
      echo "<IfModule mod_jserv.c>"
      echo "         Include %{jservconf}/jserv.conf"
      echo "</IfModule>"
This page took 0.044501 seconds and 4 git commands to generate.