]> git.pld-linux.org Git - packages/AfterStep.git/commitdiff
- fix building with libpng-1.5
authorKacper Kornet <draenog@pld-linux.org>
Mon, 18 Jun 2012 01:19:48 +0000 (01:19 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    AfterStep-libpng-1.5.patch -> 1.1
    AfterStep.spec -> 1.86

AfterStep-libpng-1.5.patch [new file with mode: 0644]
AfterStep.spec

diff --git a/AfterStep-libpng-1.5.patch b/AfterStep-libpng-1.5.patch
new file mode 100644 (file)
index 0000000..0a4f321
--- /dev/null
@@ -0,0 +1,33 @@
+diff -ur AfterStep-2.2.11.orig/libAfterImage/export.c AfterStep-2.2.11/libAfterImage/export.c
+--- AfterStep-2.2.11.orig/libAfterImage/export.c       2010-09-23 21:52:15.000000000 +0100
++++ AfterStep-2.2.11/libAfterImage/export.c    2012-06-18 01:48:11.054109582 +0100
+@@ -496,7 +496,7 @@
+       png_ptr = png_create_write_struct( PNG_LIBPNG_VER_STRING, NULL, NULL, NULL );
+     if ( png_ptr != NULL )
+       if( (info_ptr = png_create_info_struct(png_ptr)) != NULL )
+-                      if( setjmp(png_ptr->jmpbuf) )
++                      if( setjmp(png_jmpbuf(png_ptr)) )
+                       {
+                               png_destroy_info_struct(png_ptr, (png_infopp) &info_ptr);
+                               info_ptr = NULL ;
+diff -ur AfterStep-2.2.11.orig/libAfterImage/import.c AfterStep-2.2.11/libAfterImage/import.c
+--- AfterStep-2.2.11.orig/libAfterImage/import.c       2010-09-23 21:57:57.000000000 +0100
++++ AfterStep-2.2.11/libAfterImage/import.c    2012-06-18 01:55:43.547156261 +0100
+@@ -1251,7 +1251,7 @@
+                        * the normal method of doing things with libpng).  REQUIRED unless you
+                        * set up your own error handlers in the png_create_read_struct() earlier.
+                        */
+-                      if ( !setjmp (png_ptr->jmpbuf))
++                      if ( !setjmp(png_jmpbuf(png_ptr)))
+                       {
+                               ASFlagType rgb_flags = ASStorage_RLEDiffCompress|ASStorage_32Bit ;
+@@ -1468,7 +1468,7 @@
+ static void asim_png_read_data(png_structp png_ptr, png_bytep data, png_size_t length)
+ {
+-   ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_ptr->io_ptr;
++   ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *) png_get_io_ptr(png_ptr);
+    memcpy(data, buf->buffer, length);
+    buf->buffer += length;
+ }
index 3ee95df5409849ad4d13759e0d680242d99c222c..adf31e38c377a0e2aff71a9e62a974a63a90e322 100644 (file)
@@ -14,7 +14,7 @@ Summary(ja.UTF-8):    AfterStep ウィンドウマネージャ (NeXT風)
 Summary(pl.UTF-8):     AfterStep - zarządca okien
 Name:          AfterStep
 Version:       2.2.11
-Release:       0.3
+Release:       0.4
 License:       GPL v2+
 Group:         X11/Window Managers
 Source0:       ftp://ftp.afterstep.org/stable/%{name}-%{version}.tar.bz2
@@ -25,6 +25,7 @@ Patch0:               %{name}-no_bash_fix.patch
 Patch1:                %{name}-ldconfig.patch
 Patch2:                %{name}-opt.patch
 Patch3:                %{name}-link.patch
+Patch4:                %{name}-libpng-1.5.patch
 URL:           http://www.afterstep.org/
 BuildRequires: autoconf >= 2.59-9
 BuildRequires: automake
@@ -222,6 +223,7 @@ Statyczna biblioteka AfterImage.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 cp -f autoconf/configure*.in .
 
This page took 0.17639 seconds and 4 git commands to generate.