]> git.pld-linux.org Git - packages/AfterStep-APPS.git/blob - AfterStep-APPS.spec
- dropped pre-cvs changelog
[packages/AfterStep-APPS.git] / AfterStep-APPS.spec
1 Summary:        Applets you can use with AfterStep and compatible window managers
2 Summary(pl.UTF-8):      Aplety, których możesz używać z AfterStepem oraz innymi zarządcami okien, które są z nim kompatybilne
3 Name:           AfterStep-APPS
4 Version:        991125
5 Release:        4
6 License:        GPL
7 Group:          X11/Window Managers/Tools
8 Source0:        http://www.tigr.net/afterstep/download/as-apps-%{version}.tar
9 # Source0-md5:  9cdd656d4b2b36100cde4675602082b3
10 Patch0:         %{name}-1.5beta1-glibc.patch
11 Patch1:         xiterm-utmp.patch
12 Patch2:         as-apps-miniCHESS-change_install_dirs.patch
13 Patch3:         as-apps-ascd-configure_and_install_bugfix.patch
14 #Patch4:        ascp-paths.patch
15 #Patch5:        aterm-utemp.patch
16 Patch6:         %{name}-home_etc.patch
17 URL:            http://www.tigr.net/afterstep/
18 Requires:       /usr/sbin/utempter
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21
22 %description
23 What's a cool window manager without some cool applets? Well... it's
24 still cool, but these applets which can be used in the Wharf module
25 for AfterStep or Window Maker can add both spice and productivity to
26 your preferred window manager, such as a handy clock and information
27 about system resources.
28
29 If you've installed the AfterStep packages, you should also install
30 these packages. Enjoy!
31
32 %description -l pl.UTF-8
33 Czym jest fajny zarządca okien bez fajnych apletów? Cóż... jest nadal
34 fajnym zarządcą okien, ale aplety, które mogą być używane w module
35 Wharf AfterStepa lub Window Makera, mogłyby zwiększyć efektywność i
36 efektowność twojego ulubionego zarządcy okien.
37
38 Jeżeli masz zainstalowanego AfterStepa to powinieneś zainstalować
39 także ten pakiet. Miłej zabawy!
40
41 %prep
42 %setup -q -c
43 rm -f *.asc
44 for archive in *.tar.gz ; do
45         tar xzf $archive
46         rm -f $archive
47 done
48 %patch0 -p1
49 %patch1 -p1
50 %patch2 -p1
51 %patch3 -p1
52 #patch4
53 #patch5
54 %patch6 -p1
55
56 %build
57 mv ascd-0.12.1/ascd/themes/clean.tar ascd-0.12.1/ascd/themes/cleandir.tar
58 for package in `ls` ; do
59         cd $package
60         case $package in
61           ascd-* )
62                 ./configure << EOF
63 /dev/cdrom
64 %{_bindir}
65 %{_mandir}/man1
66 %{_datadir}/afterstep/AScd
67 2
68 EOF
69                 xmkmf
70                 make Makefiles CXXDEBUGFLAGS="%{rpmcflags}" \
71                         CDEBUGFLAGS="%{rpmcflags}"
72                 make MANDIR=%{_mandir}/man1 \
73                         BINDIR=%{_bindir} \
74                         SHLIBDIR=%{_libdir} \
75                         CXXDEBUGFLAGS="%{rpmcflags}" \
76                         CDEBUGFLAGS="%{rpmcflags}"
77                 ;;
78           aterm* )
79                 ## This program is provided by aterm rpm package.
80                 # configure2_13 --enable-utmp
81                 # make
82                 ;;
83           asclock*)
84                 CFLAGS="%{rpmcflags}" ./configure --prefix=%{_prefix} << EOF
85 classic
86
87 EOF
88                 make CFLAGS="%{rpmcflags}"
89                 ;;
90           ascp-* )
91                 ## There is strange problem with this program.
92                 ## The ./configure script tries to run /usr/local/bin/gtk-config
93                 ## program. In PLD it should be %{_bindir}/gtk-config.
94                 ##
95                 ##    --with-gtk-prefix
96                 ##    --with-gtk-exec-prefix
97                 ## or --disable-gtktest
98                 ## not help here. I don't now why.
99                 # export LD_LIBRARY_PATH=%{_prefix}/
100                 # configure2_13 \
101                 #       --enable-i18n \
102                 #       --x-includes=%{_includedir} \
103                 #       --x-libraries=%{_libdir} \
104                 #       --disable-gtktest
105                 #       --with-gtk-prefix=%{_prefix} \
106                 #       --with-gtk-exec-prefix=%{_bindir}
107                 # make
108                 ;;
109           asfatm-* )
110                 ## <sensors/sensors.h> is needed to compile this program.
111                 ## I don't have it.
112                 # cd asfatm
113                 # make
114                 ;;
115           asppp-* )
116                 ## xpminit.c:7: dial.xpm: No such file or directory
117                 # configure2_13
118                 # make
119                 ;;
120           miniCHESS-* )
121                 #chess.c: In function `mouseGame':
122                 #chess.c:1667: `fd_set' undeclared (first use in this function)
123                 #chess.c:1667: (Each undeclared identifier is reported only once
124                 #chess.c:1667: for each function it appears in.)
125                 #chess.c:1667: parse error before `fdset'
126                 #chess.c:1687: `fdset' undeclared (first use in this function)
127                 #chess.c: In function `main':
128                 #chess.c:1975: warning: return type of `main' is not `int'
129                 #make
130                 ;;
131           xiterm* )
132                 ## You can try to build this program,
133                 ## if only you have got utempter-devel.
134                 # cough cough, hack hack -- ewt
135                 # configure2_13 \
136                 #       --enable-xpm-background \
137                 #       --enable-utmp \
138                 #       --enable-wtmp   \
139                 #       --enable-menubar \
140                 #       --enable-next-scroll
141                 # xmkmf
142                 # make Makefiles
143                 # cd src
144                 # sed -e "s/EXTRA_LIBRARIES =/EXTRA_LIBRARIES = -lutempter/" \
145                 #       Makefile > Makefile.foo
146                 # sed -e "s/-lsocket //" Makefile.foo > Makefile
147                 # make CXXDEBUGFLAGS="%{rpmcflags}" \
148                 #       CDEBUGFLAGS="%{rpmcflags}"
149                 ;;
150           Tasks-*)
151                 ## I think this program is not finished yet.
152                 ## There is Makefile.in but I can't find anything to
153                 ## create Makefile (there is no ./configure or configure.in)
154                 ## I think that `mv Makefile.in Makefile' will be enough.
155                 ## I will try this later.
156                 ;;
157           xfascd-*)
158                 ## I'll try to build this program later.
159                 ;;
160           asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* \
161           | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* \
162           | astrash* | asxmcd* | asampmenu* | randbg-*)
163                 ## We don't compile these
164                 ;;
165           *)
166                 #just about every other thing supports autoconf
167                 %configure2_13
168                 make
169                 ;;
170         esac
171         cd ..
172 done
173
174 %install
175 rm -rf $RPM_BUILD_ROOT
176 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
177
178 for package in `ls` ; do
179         cd $package
180         case $package in
181           ascd-* )
182                 make install install.man \
183                         AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
184                         AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
185                         MANDIR=%{_mandir}/man1 \
186                         BINDIR=%{_bindir} \
187                         SHLIBDIR=%{_libdir} \
188                         DESTDIR=$RPM_BUILD_ROOT
189                         ;;
190           aterm*)
191                 ## This program is provided by aterm.rpm package.
192                 # make install \
193                 #       AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
194                 #       AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
195                 #       DESTDIR=$RPM_BUILD_ROOT
196                 ;;
197           xiterm*)
198                 ## You can try to install this program,
199                 ## if only you have got utempter-devel.
200                 ## Don't forget build it first.
201                 # make install install.man \
202                 #       AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
203                 #       AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
204                 #       MANDIR=%{_mandir}/man1 \
205                 #       BINDIR=%{_bindir} \
206                 #       SHLIBDIR=%{_libdir} \
207                 #       DESTDIR=$RPM_BUILD_ROOT
208                 ;;
209           asfatm-*)
210                 ## We don't install this.
211                 ;;
212           ascp-*)
213                 ## We do not install this. (If you want to know why check
214                 ## the build section above).
215                 # make install \
216                 #       ASCP_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
217                 #       ASCP_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
218                 #       prefx=$RPM_BUILD_ROOT \
219                 #       DESTDIR=$RPM_BUILD_ROOT
220                 ;;
221           asppp-* | miniCHESS-* | Tasks-* | xfascd-*)
222                 ## There were problems with these programs in build section.
223                 ## We can not install it.
224                 ;;
225           asmount* | asDrinks* | asbutton* | asdm* | aspbm* | aspostit* \
226           | ascdc-* | astuner* | ASFiles* | as[R-W]* | asfaces* | asmon* \
227           | astrash* | asxmcd* | asampmenu* | randbg-*)
228                 ## We don't install these
229                 ;;
230           *)
231                 echo
232                 make install install.man \
233                         AFTER_BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
234                         AFTER_MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
235                         DESTDIR=$RPM_BUILD_ROOT
236                 ;;
237         esac
238         cd ..
239 done
240 rm -f $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}/{sessreg,xpmroot,qplot}*
241
242 %clean
243 rm -rf $RPM_BUILD_ROOT
244
245 %post   -p /sbin/ldconfig
246 %postun -p /sbin/ldconfig
247
248 %files
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{_bindir}/*
251
252 %{_datadir}/afterstep/*
253 %{_mandir}/man1/*
254 /usr/X11R6/lib//*
This page took 0.099428 seconds and 3 git commands to generate.