]> git.pld-linux.org Git - packages/A3Com.git/blob - A3Com.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/A3Com.git] / A3Com.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        A3Com - manipulation of 3Com SuperStack II
3 Summary(pl.UTF-8):      A3Com - manipulacje 3Com SuperStack II
4 Name:           A3Com
5 Version:        0.2.3
6 Release:        2
7 License:        GPL v2
8 Group:          Networking/Utilities
9 Source0:        http://www.kernel.org/pub/software/admin/A3Com/%{name}-%{version}.tar.bz2
10 # Source0-md5:  16133ebf73fe3883b0d46ed88f03377a
11 URL:            http://www.kernel.org/software/A3Com/
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 A3Com is a set of Perl 5 modules which allow manipulation of 3Com
16 SuperStack II 3900/9300 and CoreBuilder 3500 LAN switches. Currently
17 there are modules which can use either the SNMP or telnet interface
18 to:
19
20 - dump the ARP tables
21 - dump bridge tables
22 - search switches for a MAC address, IP address, or hostname
23 - change admin passwords in batch mode
24 - save and restore switch configurations via SNMP
25 - upload new firmware via SNMP (batch mode)
26 - and collect per-port ethernet details like current autonegotiation
27   mode and duplex settings
28 - keep global caches of ARP and bridge tables for fast searches
29 - keep global ARP history as a merged ARP database
30
31 %description -l pl.UTF-8
32 A3Com to zestaw modułów Perla pozwalających na konfigurowanie switchy
33 LAN firmy 3Com: SuperStack II 3900/9300 i CoreBuilder 3500. Aktualnie
34 moduły te mogą używać interfejsu SNMP lub telnet do:
35 - wypisania tablic ARP
36 - wypisania tablic bridgingu
37 - wyszukiwania adresów MAC, IP lub nazw hostów
38 - zmiany haseł administratora w trybie wsadowym
39 - zapisywania i odtwarzania konfiguracji switchy po SNMP
40 - przesyłania nowego firmware'u po SNMP (w trybie wsadowym)
41 - zbierania dotyczących poszczególnych portów informacji takich jak
42   aktualny tryb autonegocjacji i duplex
43 - przechowywania globalnego cache tablic ARP i bridgingu w celu
44   szybkiego przeszukiwania
45 - przechowywania globalnej historii ARP jako połączonej bazy danych.
46
47 %prep
48 %setup -q
49
50 %build
51 # Change path for perl:
52 for i in tools/*; do
53         cat $i | sed -e "s/\/usr\/local\/bin/\%{_prefix}\/bin/" > tmp
54         mv tmp $i
55 done
56 # Change location of config:
57 for i in A3Com/*; do
58         cat $i | sed -e "s/\/usr\/local\/etc/\/etc/" > tmp
59         mv tmp $i
60 done
61
62 # Make modules:
63 %{__perl} Makefile.PL \
64         INSTALLDIRS=vendor
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/A3Com,%{_sysconfdir}}
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 install tools/*         $RPM_BUILD_ROOT%{_bindir}
75
76 cat << EOF >$RPM_BUILD_ROOT%{_sysconfdir}/a3com.conf
77 GLOBALCACHEDIR = /var/lib/A3Com
78 EOF
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc CHANGELOG TODO README test.pl
86 %attr(777,root,root) %dir /var/lib/A3Com
87 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/a3com.conf
88 %attr(755,root,root) %{_bindir}/*
89 %dir %{perl_vendorlib}/A3Com
90 %{perl_vendorlib}/A3Com/*.pm
This page took 0.071137 seconds and 3 git commands to generate.