]> git.pld-linux.org Git - packages/++DFB.git/blob - ++DFB.spec
- note where new versions can be found
[packages/++DFB.git] / ++DFB.spec
1 # NOTE: for version >= 1.7.0+ see -c++-* subpackages in DirectFB.spec
2 Summary:        Advanced version of C++ binding for DirectFB
3 Summary(pl.UTF-8):      Zaawansowana wersja interfejsu C++ do DirectFB
4 Name:           ++DFB
5 Version:        1.4.2
6 Release:        1.1
7 License:        LGPL v2+
8 Group:          Libraries
9 Source0:        http://www.directfb.org/downloads/Extras/%{name}-%{version}.tar.gz
10 # Source0-md5:  7f2672b391d9987f16a0768e87f12306
11 URL:            http://www.directfb.org/index.php?path=Projects%2F%2B%2BDFB
12 BuildRequires:  DirectFB-devel >= 1:%{version}
13 BuildRequires:  autoconf >= 2.52
14 BuildRequires:  automake
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.5
17 BuildRequires:  pkgconfig
18 Provides:       __DFB = %{version}-%{release}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 ++DFB is an advanced version of DFB++. It's an incompatible fork
23 with fundamental changes.
24
25 Applications no longer deal with interface pointers. The classes
26 wrapping around interfaces are used as container for an interface
27 pointer, providing garbage collection the "direct" way 8-)
28
29 %description -l pl.UTF-8
30 ++DFB to zaawansowana wersja DFB++. Jest to niekompatybilne
31 odgałęzienie z zasadniczymi zmianami.
32
33 Aplikacje nie zajmują się już wskaźnikami do interfejsów. Klasy
34 obudowujące interfejsy są używane jako kontenery dla wskaźnika na
35 interfejs, udostępniając odśmiecanie w "bezpośredni" sposób.
36
37 %package devel
38 Summary:        ++DFB header files
39 Summary(pl.UTF-8):      Pliki nagłówkowe ++DFB
40 Group:          Development/Libraries
41 # rpm can't stand cap beginning with '+'
42 #Requires:      %{name} = %{version}-%{release}
43 Requires:       __DFB = %{version}-%{release}
44 Requires:       DirectFB-devel >= 1:%{version}
45 Requires:       libstdc++-devel
46 Provides:       __DFB-devel = %{version}-%{release}
47
48 %description devel
49 Header files for ++DFB library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki ++DFB.
53
54 %package static
55 Summary:        ++DFB static library
56 Summary(pl.UTF-8):      Statyczna biblioteka ++DFB
57 Group:          Development/Libraries
58 # rpm can't stand cap beginning with '+'
59 #Requires:      %{name}-devel = %{version}-%{release}
60 Requires:       __DFB-devel = %{version}-%{release}
61
62 %description static
63 ++DFB static library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka ++DFB.
67
68 %prep
69 %setup -q
70
71 %build
72 %{__libtoolize}
73 %{__aclocal}
74 %{__autoconf}
75 %{__autoheader}
76 %{__automake}
77 %configure \
78         --enable-static
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 install examples/simple.cpp $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS ChangeLog README
99 %attr(755,root,root) %{_bindir}/dfbplay
100 # not needed, conflict with DFB++
101 #%attr(755,root,root) %{_bindir}/dfbshow
102 #%attr(755,root,root) %{_bindir}/dfbswitch
103 %attr(755,root,root) %{_libdir}/lib++dfb-1.4.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/lib++dfb-1.4.so.2
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_bindir}/++dfb-config
109 %attr(755,root,root) %{_libdir}/lib++dfb.so
110 %{_libdir}/lib++dfb.la
111 %{_includedir}/++dfb
112 %{_pkgconfigdir}/++dfb.pc
113 %{_examplesdir}/%{name}-%{version}
114
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/lib++dfb.a
This page took 0.103177 seconds and 3 git commands to generate.