]> git.pld-linux.org Git - packages/zabbix.git/blobdiff - zabbix.spec
Add fix for database monitoring (ZBX-11213)
[packages/zabbix.git] / zabbix.spec
index ca734ef792c01ed4442647cd2f68d1b4e0790cd7..650161b34294d46b874e1abdf5b85d9898e2ecda 100644 (file)
@@ -8,17 +8,18 @@
 %bcond_without java    # disable java support
 
 %define databases %{?with_pgsql:postgresql} %{?with_mysql:mysql} %{?with_sqlite3:sqlite3}
+%define any_database %{with pgsql}%{with mysql}%{with sqlite3}
 
 %define                php_min_version 5.4.0
 Summary:       Zabbix - network monitoring software
 Summary(pl.UTF-8):     Zabbix - oprogramowanie do monitorowania sieci
 Name:          zabbix
-Version:       3.2.0
-Release:       0.3
+Version:       3.2.1
+Release:       1
 License:       GPL v2+
 Group:         Networking/Utilities
 Source0:       http://downloads.sourceforge.net/zabbix/%{name}-%{version}.tar.gz
-# Source0-md5: e2491b482868059f251902d5f636eacb
+# Source0-md5: 4f363b923ef2b5eefddee8dfc5f51e2b
 Source1:       %{name}-apache.conf
 Source2:       %{name}_server.service
 Source3:       %{name}_agentd.service
@@ -27,6 +28,8 @@ Source5:      %{name}_java.service
 Source6:       %{name}.tmpfiles
 Patch0:                config.patch
 Patch1:                sqlite3_dbname.patch
+Patch2:                tag_conditions.patch
+Patch3:                ZBX-11213.patch
 URL:           http://zabbix.sourceforge.net/
 BuildRequires: OpenIPMI-devel
 BuildRequires: curl-devel
@@ -126,10 +129,14 @@ Requires: php(xml)
 Requires:      php(xmlreader)
 Requires:      php(xmlwriter)
 Requires:      webapps
+Requires:      webserver(alias)
+Requires:      webserver(indexfile)
 Requires:      webserver(php)
 Suggests:      php(mysql)
 Suggests:      php(pgsql)
 Suggests:      php(sqlite3)
+# used with sqlite3
+Suggests:      php(sysvsem)
 
 %description frontend-php
 This package provides web based (PHP) frontend for Zabbix.
@@ -272,9 +279,13 @@ Obsoletes: %{name}-server-postgresql
 %description server-sqlite3
 This package provides the Zabbix server binary for use with SQLite 3 database.
 
+NOTE: Support for SQLite 3 is EXPERIMENTAL and not recommended.
+
 %description server-sqlite3 -l pl.UTF-8
 Ten pakiet zawiera serwer Zabbiksa z obsługą bazy danych SQLite 3.
 
+INFO: Wsparcie dla SQLite 3 jest EKSPERYMENTALNE i nie rekomendowane.
+
 %package java
 Summary:       Zabbix Java Gateway
 Group:         Networking/Utilities
@@ -289,6 +300,8 @@ This package provides the Zabbix Java Gateway.
 
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
 
@@ -553,7 +566,9 @@ ln -sf %{_sbindir}/zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
 
 %files agentd
 %defattr(644,root,root,755)
+%doc conf/zabbix_agentd/*.conf
 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_agentd.conf
+%dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_agentd.conf.d
 %attr(755,root,root) %{_sbindir}/zabbix_agentd
 %{_mandir}/man8/zabbix_agentd*
 %{systemdunitdir}/zabbix_agentd.service
@@ -573,12 +588,15 @@ ln -sf %{_sbindir}/zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
 %attr(755,root,root) %{_bindir}/zabbix_get
 %{_mandir}/man1/zabbix_get*
 
+%if %{any_database}
 %files proxy
 %defattr(644,root,root,755)
 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_proxy.conf
+%dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_proxy.conf.d
 %ghost %attr(755,root,root) %{_sbindir}/zabbix_proxy
 %{_mandir}/man8/zabbix_proxy*
 %{systemdunitdir}/zabbix_proxy.service
+%endif
 
 %if %{with mysql}
 %files proxy-mysql
@@ -603,13 +621,16 @@ ln -sf %{_sbindir}/zabbix_proxy-sqlite3 %{_sbindir}/zabbix_proxy || :
 %attr(755,root,root) %{_bindir}/zabbix_sender
 %{_mandir}/man1/zabbix_sender*
 
+%if %{any_database}
 %files server
 %defattr(644,root,root,755)
 %doc upgrades/dbpatches
 %attr(640,root,zabbix) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zabbix_server.conf
+%dir %attr(751,root,zabbix) %{_sysconfdir}/zabbix_server.conf.d
 %ghost %attr(755,root,root) %{_sbindir}/zabbix_server
 %{_mandir}/man8/zabbix_server*
 %{systemdunitdir}/zabbix_server.service
+%endif
 
 %if %{with mysql}
 %files server-mysql
This page took 0.124396 seconds and 4 git commands to generate.