]> git.pld-linux.org Git - packages/zabbix.git/blobdiff - zabbix.spec
- updated to beta10
[packages/zabbix.git] / zabbix.spec
index d84f9e534e6bcac229770954e16fe4135b569966..4e7f022e8c880a7d4f25873878c5c5d754cb6e4d 100644 (file)
 #
 # Conditional build:
-# _with_mysql - enable postgresql support (by default use mysql)
-#
-%define        _beta   beta8
-Summary:       zabbix
-Summary(pl):   zabbix
+%bcond_with pgsql      # enable postgresql support (by default use mysql)
+
+%define        _beta   beta10
+Summary:       zabbix - network monitoring software
+Summary(pl):   zabbix - oprogramowanie do monitorowania sieci
 Name:          zabbix
 Version:       1.0
 Release:       0.%{_beta}.0.1
 License:       GPL v2+
 Group:         Networking/Admin
 Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}%{_beta}.tar.gz
+# Source0-md5: 6d1fd1c4e8166ceffa730060583d4014
 Source1:       %{name}-agent.inetd
 Source2:       %{name}-trapper.inetd
 URL:           http://zabbix.sourceforge.net/
-%{!?_with_mysql:BuildRequires:   mysql-devel}
-%{?_with_mysql:BuildRequires:   postgresql-devel}
-BuildRequires: ucd-snmp-devel
-BuildRequires: openssl-devel >= 0.9.6j
-#PreReq:               -
-Requires:      %{name}-common
-#Requires(pre,post):   -
-#Requires(preun):      -
-#Requires(postun):     -
-#Provides:     -
-#Obsoletes:    -
-#Conflicts:    -
+%{!?with_pgsql:BuildRequires:  mysql-devel}
+%{?with_pgsql:BuildRequires:   postgresql-devel}
+BuildRequires: net-snmp-devel
+BuildRequires: openssl-devel >= 0.9.7c
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define        _sysconfdir     /etc/%{name}
 
 %description
-none yet
-
-%package common
-Summary:       zabbix common
-Group:         Networking/Admin
-
-%description common
-blah
+zabbix is software that monitors numerous parameters of a network and
+the servers on that network. zabbix is a useful tool for monitoring
+the health and integrity of servers. zabbix uses a flexible
+notification mechanism that allows users to configure email based
+alerts for virtually any event. All monitored parameters are stored in
+a database. zabbix offers excellent reporting and data visualisation
+features based on the stored data. zabbix supports both polling and
+trapping. All zabbix reports and statistics, as well as configuration
+parameters, are accessed through a web-based front end.
+
+%description -l pl
+zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
+serwerów sieciowych. zabbix jest przydatny przy monitorowaniu
+dzia³ania serwerów. zabbix korzysta z elastycznego mechanizmu
+powiadamiania, który pozwala u¿ytkownikom konfigurowaæ powiadamianie
+poczt± elektroniczn± dla praktycznie wszelkich zdarzeñ. Monitorowane
+parametry s± przechowywane w bazie danych. zabbix oferuje, w oparciu o
+przechowywane dane, ¶wietne raportowanie i funkcje wizualizacji.
+zabbix wspiera zarówno odpytywanie, jak i pu³apkowanie. Dostêp do
+wszystkich raportów i statystyk zabbiksa jest mo¿liwy poprzez
+interfejs oparty o WWW.
 
 %package frontend-php
 Summary:       PHP frontend for zabbix
+Summary(pl):   Interfejs PHP dla zabbiksa
 Group:         Networking/Admin
 Requires:      apache
 Requires:      php
 
 %description frontend-php
-blah
+This package provides web based (PHP) frontend for zabbix.
+
+%description frontend-php -l pl
+Ten pakiet dostarcza napisany w PHP frontend dla zabbiksa.
 
 %package agent-inetd
 Summary:       inetd agent for zabbix
+Summary(pl):   Wersja inetd agenta zabbiksa
 Group:         Networking/Admin
-Requires:      %{name}-common
+Requires:      %{name}
 Requires:      inetdaemon
 Obsoletes:     %{name}-agent-standalone
 
 %description agent-inetd
-blah
+This package provides inetd version of zabbix agent.
+
+%description agent-inetd -l pl
+Ten pakiet dostarcza agenta zabbiksa dla inetd.
 
 %package agent-standalone
-Summary:       standalone agent for zabbix
+Summary:       Standalone agent for zabbix
+Summary(pl):   Wersja wolnostoj±ca agenta zabbiksa
 Group:         Networking/Admin
-Requires:      %{name}-common
+Requires:      %{name}
 Obsoletes:     %{name}-agent-inetd
 
 %description agent-standalone
-blah
+This package provides standalone version of zabbix agent.
+
+%description agent-standalone -l pl
+Ten pakiet dostarcza wolnostoj±cej wersji agenta zabbiksa.
 
 %package suckerd
 Summary:       sucker daemon for zabbix
 Group:         Networking/Admin
 Requires:      %{name}
+%{!?with_pgsql:Requires:       mysql}
+%{?with_pgsql:Requires:        postgresql}
 
 %description suckerd
-blah
+This package provides the sucker daemon for zabbix.
 
 %package trapper-inetd
 Summary:       inetd trapper for zabbix
+Summary(pl):   Wersja inetd programu pu³apkuj±cego zabbiksa
 Group:         Networking/Admin
 Requires:      %{name}
 Requires:      inetdaemon
 Obsoletes:     %{name}-trapper-standalone
 
 %description trapper-inetd
-blah
+This package provides inetd version of zabbix trapper.
 
 %package trapper-standalone
-Summary:       standalone trapper for zabbix
+Summary:       Standalone trapper for zabbix
+Summary(pl):   Wersja wolnostoj±ca programu pu³apkuj±cego zabbiksa
 Group:         Networking/Admin
 Requires:      %{name}
 Obsoletes:     %{name}-trapper-inetd
 
 %description trapper-standalone
-blah
+This package provides standalone version of zabbix trapper.
 
 %package sender
 Summary:       zabbix's sender
+Summary(pl):   Program zawiadamiaj±cy zabbiksa
 Group:         Networking/Admin
 
 %description sender
-blah
+This package provides the zabbix sender.
 
 %prep
 %setup -q -n %{name}-%{version}%{_beta}
@@ -110,8 +133,9 @@ rm -f missing
 %{__aclocal}
 %{__autoconf}
 %configure \
-       %{!?_with_mysql:--with-pgsql} \
-       %{?_with_mysql:--with-mysql}
+       %{!?with_pgsql:--with-mysql} \
+       %{?with_pgsql:--with-pgsql} \
+       --with-net-snmp
 
 %{__make}
 
@@ -129,7 +153,7 @@ install %SOURCE2 $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/zabbix-trapper
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%pre common
+%pre
 if [ -z "`/usr/bin/getgid zabbix`" ]; then
        /usr/sbin/groupadd zabbix
 fi
@@ -137,7 +161,7 @@ if [ -z "`/bin/id -u zabbix 2>/dev/null`" ]; then
        /usr/sbin/useradd -d / -g zabbix -c "Zabbix User" -s /bin/false zabbix
 fi
 
-%postun common
+%postun
 if [ "$1" = "0" ]; then
        /usr/sbin/userdel zabbix
        /usr/sbin/groupdel zabbix
@@ -170,9 +194,6 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc doc/manual.pdf AUTHORS ChangeLog FAQ TODO create bin/ZabbixW32.exe
-
-%files common
-%defattr(644,root,root,755)
 %attr(750,root,zabbix) %dir %{_sysconfdir}
 
 %files frontend-php
This page took 0.054555 seconds and 4 git commands to generate.