]> git.pld-linux.org Git - packages/zabbix.git/blobdiff - zabbix.spec
- updated to beta10
[packages/zabbix.git] / zabbix.spec
index c8cb48838cc6b6cd7bce22c4a85dcb1402e4c7dd..4e7f022e8c880a7d4f25873878c5c5d754cb6e4d 100644 (file)
 #
 # Conditional build:
-# _with_pgsql - enable postgresql support (by default use mysql)
-#
-%define        _beta   beta8
-Summary:       zabbix
-Summary(pl):   zabbix
+%bcond_with pgsql      # enable postgresql support (by default use mysql)
+
+%define        _beta   beta10
+Summary:       zabbix - network monitoring software
+Summary(pl):   zabbix - oprogramowanie do monitorowania sieci
 Name:          zabbix
 Version:       1.0
 Release:       0.%{_beta}.0.1
 License:       GPL v2+
 Group:         Networking/Admin
 Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}%{_beta}.tar.gz
+# Source0-md5: 6d1fd1c4e8166ceffa730060583d4014
 Source1:       %{name}-agent.inetd
 Source2:       %{name}-trapper.inetd
 URL:           http://zabbix.sourceforge.net/
-%{!?_with_pgsql:BuildRequires:   mysql-devel}
-%{?_with_pgsql:BuildRequires:   postgresql-devel}
-BuildRequires: ucd-snmp-devel
-BuildRequires: openssl-devel >= 0.9.6j
-#PreReq:       -
-#Requires      -
-#Requires(pre,post):   -
-#Requires(preun):      -
-#Requires(postun):     -
-#Provides:     -
-#Obsoletes:    -
-#Conflicts:    -
+%{!?with_pgsql:BuildRequires:  mysql-devel}
+%{?with_pgsql:BuildRequires:   postgresql-devel}
+BuildRequires: net-snmp-devel
+BuildRequires: openssl-devel >= 0.9.7c
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define        _sysconfdir     /etc/%{name}
 
 %description
-none yet
+zabbix is software that monitors numerous parameters of a network and
+the servers on that network. zabbix is a useful tool for monitoring
+the health and integrity of servers. zabbix uses a flexible
+notification mechanism that allows users to configure email based
+alerts for virtually any event. All monitored parameters are stored in
+a database. zabbix offers excellent reporting and data visualisation
+features based on the stored data. zabbix supports both polling and
+trapping. All zabbix reports and statistics, as well as configuration
+parameters, are accessed through a web-based front end.
+
+%description -l pl
+zabbix to oprogramowanie do monitorowania licznych parametrów sieci i
+serwerów sieciowych. zabbix jest przydatny przy monitorowaniu
+dzia³ania serwerów. zabbix korzysta z elastycznego mechanizmu
+powiadamiania, który pozwala u¿ytkownikom konfigurowaæ powiadamianie
+poczt± elektroniczn± dla praktycznie wszelkich zdarzeñ. Monitorowane
+parametry s± przechowywane w bazie danych. zabbix oferuje, w oparciu o
+przechowywane dane, ¶wietne raportowanie i funkcje wizualizacji.
+zabbix wspiera zarówno odpytywanie, jak i pu³apkowanie. Dostêp do
+wszystkich raportów i statystyk zabbiksa jest mo¿liwy poprzez
+interfejs oparty o WWW.
 
 %package frontend-php
 Summary:       PHP frontend for zabbix
+Summary(pl):   Interfejs PHP dla zabbiksa
 Group:         Networking/Admin
 Requires:      apache
 Requires:      php
 
 %description frontend-php
-blah
+This package provides web based (PHP) frontend for zabbix.
+
+%description frontend-php -l pl
+Ten pakiet dostarcza napisany w PHP frontend dla zabbiksa.
 
 %package agent-inetd
 Summary:       inetd agent for zabbix
+Summary(pl):   Wersja inetd agenta zabbiksa
 Group:         Networking/Admin
 Requires:      %{name}
 Requires:      inetdaemon
 Obsoletes:     %{name}-agent-standalone
 
 %description agent-inetd
-blah
+This package provides inetd version of zabbix agent.
+
+%description agent-inetd -l pl
+Ten pakiet dostarcza agenta zabbiksa dla inetd.
 
 %package agent-standalone
-Summary:       standalone agent for zabbix
+Summary:       Standalone agent for zabbix
+Summary(pl):   Wersja wolnostoj±ca agenta zabbiksa
 Group:         Networking/Admin
 Requires:      %{name}
 Obsoletes:     %{name}-agent-inetd
 
 %description agent-standalone
-blah
+This package provides standalone version of zabbix agent.
+
+%description agent-standalone -l pl
+Ten pakiet dostarcza wolnostoj±cej wersji agenta zabbiksa.
 
 %package suckerd
 Summary:       sucker daemon for zabbix
 Group:         Networking/Admin
 Requires:      %{name}
-%{!?_with_pgsql:Requires:   mysql}
-%{?_with_pgsql:Requires:   postgresql}
+%{!?with_pgsql:Requires:       mysql}
+%{?with_pgsql:Requires:        postgresql}
 
 %description suckerd
-blah
+This package provides the sucker daemon for zabbix.
 
 %package trapper-inetd
 Summary:       inetd trapper for zabbix
+Summary(pl):   Wersja inetd programu pu³apkuj±cego zabbiksa
 Group:         Networking/Admin
 Requires:      %{name}
 Requires:      inetdaemon
 Obsoletes:     %{name}-trapper-standalone
 
 %description trapper-inetd
-blah
+This package provides inetd version of zabbix trapper.
 
 %package trapper-standalone
-Summary:       standalone trapper for zabbix
+Summary:       Standalone trapper for zabbix
+Summary(pl):   Wersja wolnostoj±ca programu pu³apkuj±cego zabbiksa
 Group:         Networking/Admin
 Requires:      %{name}
 Obsoletes:     %{name}-trapper-inetd
 
 %description trapper-standalone
-blah
+This package provides standalone version of zabbix trapper.
 
 %package sender
 Summary:       zabbix's sender
+Summary(pl):   Program zawiadamiaj±cy zabbiksa
 Group:         Networking/Admin
 
 %description sender
-blah
+This package provides the zabbix sender.
 
 %prep
 %setup -q -n %{name}-%{version}%{_beta}
@@ -105,8 +133,9 @@ rm -f missing
 %{__aclocal}
 %{__autoconf}
 %configure \
-       %{!?_with_pgsql:--with-mysql} \
-       %{?_with_pgsql:--with-pgsql}
+       %{!?with_pgsql:--with-mysql} \
+       %{?with_pgsql:--with-pgsql} \
+       --with-net-snmp
 
 %{__make}
 
This page took 0.05202 seconds and 4 git commands to generate.