]> git.pld-linux.org Git - packages/xen.git/blobdiff - xen.spec
- updated to 4.17.2
[packages/xen.git] / xen.spec
index 6384f3521c033dd47cb7fe06854ae88b1016fc4e..d9745aa7d7a9a907751effa7a0902e7c9826f821 100644 (file)
--- a/xen.spec
+++ b/xen.spec
 %bcond_without brlapi                  # brlapi support in Xen qemu
 %bcond_with    golang                  # Go library
 %bcond_without ocaml                   # Ocaml libraries for Xen tools
+%bcond_without pv_grub                 # pv-grub (deprecated)
 %bcond_with    python2                 # CPython 2.x module instead of 3.x
 %bcond_without efi                     # EFI hypervisor
 %bcond_without hypervisor              # Xen hypervisor build
 %bcond_without stubdom                 # stubdom build
 %bcond_without xsm                     # XSM security module (by default, Flask)
+%bcond_without systemd                 # systemd
 
 %ifnarch %{x8664} %{arm}
 %undefine      with_hypervisor
 Summary:       Xen - a virtual machine monitor
 Summary(pl.UTF-8):     Xen - monitor maszyny wirtualnej
 Name:          xen
-Version:       4.15.2
+Version:       4.17.2
 Release:       1
 License:       GPL v2, interface parts on BSD-like
 Group:         Applications/System
-# for available versions see https://www.xenproject.org/developers/teams/hypervisor.html
+# for available versions see https://xenproject.org/xen-project-archives/
 Source0:       https://downloads.xenproject.org/release/xen/%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: d85ce5d677c7713b6b91017d3aa8b68c
-# used by stubdoms
+# Source0-md5: f344056c4566ac1627db46ea92588c3a
+# used by stubdoms; Source10-19 versions set in stubdom/configure.ac
 Source10:      %{xen_extfiles_url}/lwip-1.3.0.tar.gz
 # Source10-md5:        36cc57650cffda9a0269493be2a169bb
 Source11:      %{xen_extfiles_url}/newlib-1.16.0.tar.gz
@@ -60,14 +62,15 @@ Source13:   %{xen_extfiles_url}/pciutils-2.2.9.tar.bz2
 # Source13-md5:        cec05e7785497c5e19da2f114b934ffd
 Source14:      %{xen_extfiles_url}/grub-0.97.tar.gz
 # Source14-md5:        cd3f3eb54446be6003156158d51f4884
-Source15:      %{xen_extfiles_url}/ipxe-git-1dd56dbd11082fb622c2ed21cfaced4f47d798a6.tar.gz
-# Source15-md5:        b3ab0488a989a089207302111d12e1a0
 Source17:      %{xen_extfiles_url}/polarssl-%{polarssl_version}-gpl.tgz
 # Source17-md5:        7b72caf22b01464ee7d6165f2fd85f44
 Source18:      %{xen_extfiles_url}/tpm_emulator-%{tpm_emulator_version}.tar.gz
 # Source18-md5:        e26becb8a6a2b6695f6b3e8097593db8
 Source19:      https://ftp.gnu.org/gnu/gmp/gmp-%{gmp_version}.tar.bz2
 # Source19-md5:        dd60683d7057917e34630b4a787932e8
+# ipxe tag set in tools/firmware/etherboot/Makefile
+Source20:      %{xen_extfiles_url}/ipxe-git-3c040ad387099483102708bb1839110bc788cefb.tar.gz
+# Source20-md5:        23ba00d5e2c5b4343d12665af73e1cb5
 Source35:      xenconsoled.sysconfig
 Source37:      xenstored.sysconfig
 Source38:      xenstored.tmpfiles
@@ -100,8 +103,10 @@ Patch10:   %{name}-stubdom-build.patch
 Patch12:       %{name}-systemd.patch
 Patch14:       gcc9.patch
 Patch15:       gcc10.patch
-Patch16:       ocaml-4.12.patch
 Patch17:       %{name}-golang-32bit.patch
+Patch18:       %{name}-gcc12.patch
+Patch19:       gcc13.patch
+Patch20:       python-fixes.patch
 URL:           http://www.xen.org/products/xenhyp.html
 BuildRequires: autoconf >= 2.67
 %ifarch %{ix86} %{x8664}
@@ -133,7 +138,7 @@ BuildRequires:      libuuid-devel
 BuildRequires: lzo-devel >= 2
 BuildRequires: ncurses-devel
 %if %{with ocaml}
-BuildRequires: ocaml >= 4.02.0
+BuildRequires: ocaml >= 1:4.02.0
 BuildRequires: ocaml-findlib
 %endif
 BuildRequires: pandoc
@@ -150,7 +155,7 @@ BuildRequires:      python3-markdown
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.647
 BuildRequires: seabios
-BuildRequires: systemd-devel >= 1:209
+%{?with_systemd:BuildRequires: systemd-devel >= 1:209}
 BuildRequires: texlive-dvips
 BuildRequires: texlive-latex-psnfss
 BuildRequires: texlive-xetex
@@ -184,7 +189,6 @@ BuildRequires:      xorg-lib-libXext-devel
 Requires(post,preun):  /sbin/chkconfig
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      ZopeInterface
 Requires:      bridge-utils
 Requires:      coreutils
 Requires:      diffutils
@@ -431,26 +435,34 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 %if %(echo %{cc_version} | cut -d. -f1) >= 10
 # -Wno-error=enum-conversion requires gcc 10
 %patch15 -p1
+%if %(echo %{cc_version} | cut -d. -f1) < 12
+# -Wno-error=dangling-pointer requires gcc 12
+%{__sed} -i -e 's/ -Wno-error=dangling-pointer//' tools/firmware/etherboot/Config
+%endif
 %endif
-%patch16 -p1
 %ifarch %{ix86} %{arm}
 %patch17 -p1
 %endif
+%patch18 -p1
+%patch19 -p1
+%patch20 -p1
 
 # stubdom sources
 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
 ln -s %{SOURCE17} %{SOURCE18} %{SOURCE19} stubdom
-ln -s %{SOURCE15} tools/firmware/etherboot/ipxe.tar.gz
-
+ln -s %{SOURCE20} tools/firmware/etherboot/ipxe.tar.gz
 
 %if %{with python2}
 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' \
 %else
-%{__sed} -i -e '1s,/usr/bin/env python$,%{__python3},' \
+%{__sed} -i -e '1s,/usr/bin/env python$,%{__python3},; 1s,/usr/bin/python2$,%{__python3},' \
 %endif
+       tools/misc/xencov_split \
+       tools/misc/xenpvnetboot \
        tools/pygrub/src/pygrub \
        tools/python/scripts/{convert-legacy-stream,verify-stream-v2} \
-       tools/xenmon/xenmon.py
+       tools/xenmon/xenmon.py \
+       tools/xentrace/xentrace_format
 
 # do not allow fetching anything via git
 echo GIT=/bin/false >> Config.mk
@@ -483,6 +495,7 @@ export PATH=$(pwd)/our-ld:$PATH
        ac_cv_lib_iconv_libiconv_open=no \
        --disable-debug \
        %{!?with_golang:--disable-golang} \
+       %{?with_pv_grub:--enable-pv-grub} \
        %{__enable_disable qemu_traditional qemu-traditional} \
        --with-system-seabios=/usr/share/seabios/bios.bin \
 %ifarch %{x8664}
@@ -490,8 +503,11 @@ export PATH=$(pwd)/our-ld:$PATH
 %else
        --with-system-qemu=/usr/bin/qemu-system-i386 \
 %endif
+%if %{with systemd}
        --with-systemd=%{systemdunitdir}
-
+%else
+       --disable-systemd
+%endif
 export EXTRA_CFLAGS_XEN_TOOLS="%{rpmcflags} -I/usr/include/ncurses"
 export EXTRA_CFLAGS_QEMU_TRADITIONAL="%{rpmcflags} -I/usr/include/ncurses"
 export EXTRA_CFLAGS_QEMU_XEN="%{rpmcflags} -I/usr/include/ncurses"
@@ -594,7 +610,7 @@ cp -p tools/pygrub/README _doc/README.pygrub
 # remove unneeded files
 %if %{with hypervisor}
 %{__mv} xen/xen-syms $RPM_BUILD_ROOT/boot/%{name}-syms-%{version}
-%{__rm} $RPM_BUILD_ROOT/boot/xen-4.14.gz
+%{__rm} $RPM_BUILD_ROOT/boot/xen-4.17.gz
 %{__rm} $RPM_BUILD_ROOT/boot/xen-4.gz
 %endif
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/xen
@@ -664,9 +680,9 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/xenstored
 %attr(754,root,root) /etc/rc.d/init.d/xendomains
 %attr(754,root,root) /etc/rc.d/init.d/xen-qemu-dom0-disk-backend
+%if %{with systemd}
 %{_prefix}/lib/modules-load.d/xen.conf
 %{systemdunitdir}/proc-xen.mount
-%{systemdunitdir}/var-lib-xenstored.mount
 %{systemdunitdir}/xen-init-dom0.service
 %{systemdunitdir}/xen-watchdog.service
 %{systemdunitdir}/xenconsoled.service
@@ -674,6 +690,7 @@ fi
 %{systemdunitdir}/xendriverdomain.service
 %{systemdunitdir}/xendomains.service
 %{systemdunitdir}/xen-qemu-dom0-disk-backend.service
+%endif
 %dir %{_sysconfdir}/xen
 %dir %{_sysconfdir}/xen/auto
 %dir %{_sysconfdir}/xen/examples
@@ -691,7 +708,6 @@ fi
 %attr(755,root,root) %{_bindir}/vchan-socket-proxy
 %attr(755,root,root) %{_bindir}/xen-cpuid
 %attr(755,root,root) %{_bindir}/xenalyze
-%attr(755,root,root) %{_bindir}/xencons
 %attr(755,root,root) %{_bindir}/xencov_split
 %attr(755,root,root) %{_bindir}/xentrace_format
 %if %{with xsm}
@@ -723,12 +739,14 @@ fi
 %if %{with qemu_traditional}
 %{_libexecdir}/%{name}/boot/ioemu-stubdom.gz
 %endif
+%if %{with pv_grub}
 %ifarch %{ix86} %{x8664}
 %{_libexecdir}/%{name}/boot/pv-grub-x86_32.gz
 %endif
 %ifarch %{x8664}
 %{_libexecdir}/%{name}/boot/pv-grub-x86_64.gz
 %endif
+%endif
 %{_libexecdir}/%{name}/boot/vtpm-stubdom.gz
 %{_libexecdir}/%{name}/boot/vtpmmgr-stubdom.gz
 %{_libexecdir}/%{name}/boot/xenstore-stubdom.gz
@@ -758,7 +776,6 @@ fi
 %{_mandir}/man7/xl-numa-placement.7*
 %{_mandir}/man8/xentrace.8*
 %{_sharedstatedir}/xen
-%{_sharedstatedir}/xenstored
 %dir /var/run/xenstored
 %{systemdtmpfilesdir}/xen.conf
 %{systemdtmpfilesdir}/xenstored.conf
@@ -790,11 +807,11 @@ fi
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libxenfsimage.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenfsimage.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxenfsimage.so.4.17
 %attr(755,root,root) %{_libdir}/libxencall.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libxencall.so.1
 %attr(755,root,root) %{_libdir}/libxenctrl.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxenctrl.so.4.17
 %attr(755,root,root) %{_libdir}/libxendevicemodel.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libxendevicemodel.so.1
 %attr(755,root,root) %{_libdir}/libxenevtchn.so.*.*
@@ -804,21 +821,21 @@ fi
 %attr(755,root,root) %{_libdir}/libxengnttab.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libxengnttab.so.1
 %attr(755,root,root) %{_libdir}/libxenguest.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxenguest.so.4.17
 %attr(755,root,root) %{_libdir}/libxenhypfs.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libxenhypfs.so.1
 %attr(755,root,root) %{_libdir}/libxenlight.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenlight.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxenlight.so.4.17
 %attr(755,root,root) %{_libdir}/libxenstat.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenstat.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxenstat.so.4.17
 %attr(755,root,root) %{_libdir}/libxentoolcore.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libxentoolcore.so.1
 %attr(755,root,root) %{_libdir}/libxentoollog.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libxentoollog.so.1
 %attr(755,root,root) %{_libdir}/libxenvchan.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxenvchan.so.4.17
 %attr(755,root,root) %{_libdir}/libxlutil.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxlutil.so.4.15
+%attr(755,root,root) %ghost %{_libdir}/libxlutil.so.4.17
 %dir %{_libdir}/xenfsimage
 %dir %{_libdir}/xenfsimage/ext2fs-lib
 %dir %{_libdir}/xenfsimage/fat
@@ -831,8 +848,8 @@ fi
 
 %files libs-guest
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libxenstore.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libxenstore.so.3.0
+%attr(755,root,root) %{_libdir}/libxenstore.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libxenstore.so.4
 
 %files devel
 %defattr(644,root,root,755)
@@ -852,7 +869,6 @@ fi
 %attr(755,root,root) %{_libdir}/libxentoollog.so
 %attr(755,root,root) %{_libdir}/libxenvchan.so
 %attr(755,root,root) %{_libdir}/libxlutil.so
-%{_includedir}/_libxl_list.h
 %{_includedir}/_libxl_types.h
 %{_includedir}/_libxl_types_json.h
 %{_includedir}/libxenvchan.h
This page took 0.074568 seconds and 4 git commands to generate.