]> git.pld-linux.org Git - packages/xen.git/blobdiff - xen.spec
Use the %%{systemdtmpfilesdir} macro
[packages/xen.git] / xen.spec
index 638ae2955d70fe81af46777c5189304c46d9af76..7cc0a647f55825fef6490abb2e5f18fbd464e7d9 100644 (file)
--- a/xen.spec
+++ b/xen.spec
@@ -4,6 +4,10 @@
 #    packages if so
 #  - pass bconds to qemu configure script (tricky, as the script is called from
 #    Xen Makefiles)
+#  - fix %doc - some files are installed in docdir both by make install and %d,
+#    other are installed once
+#  - now the build dependencies are insane (because of what qemu can use)
+#    we should make them optional or get rid of them all properly
 #
 #
 # Conditional build:
@@ -14,7 +18,7 @@
 %bcond_without ocaml           # build Ocaml libraries for Xen tools
 %bcond_without efi             # build the EFI hypervisor
 
-%ifnarch x86_64
+%ifnarch %{x8664}
 %undefine      with_efi
 %endif
 
@@ -26,7 +30,7 @@ Summary:      Xen - a virtual machine monitor
 Summary(pl.UTF-8):     Xen - monitor maszyny wirtualnej
 Name:          xen
 Version:       4.2.0
-Release:       0.1
+Release:       2
 License:       GPL v2, interface parts on BSD-like
 Group:         Applications/System
 Source0:       http://bits.xensource.com/oss-xen/release/%{version}/%{name}-%{version}.tar.gz
@@ -68,6 +72,7 @@ Source52:     xenstored.init
 Source53:      xen-watchdog.init
 Source54:      xendomains.init
 Source55:      xen.logrotate
+Source56:      xen.tmpfiles
 Patch0:                %{name}-python_scripts.patch
 Patch1:                %{name}-symbols.patch
 Patch2:                %{name}-curses.patch
@@ -81,6 +86,7 @@ Patch8:               xen-configure-xend.patch
 Patch9:                xen-initscript.patch
 Patch10:       xen-quemu-softloat-c99.patch
 Patch11:       xen-qemu.patch
+Patch12:       xen-scripts-locking.patch
 URL:           http://www.xen.org/products/xenhyp.html
 %{?with_opengl:BuildRequires:  OpenGL-devel}
 %{?with_sdl:BuildRequires:     SDL-devel >= 1.2.1}
@@ -90,7 +96,7 @@ BuildRequires:        bcc
 %endif
 %{?with_bluetooth:BuildRequires:       bluez-libs-devel}
 %{?with_brlapi:BuildRequires:  brlapi-devel}
-%{?with_efi:BuildRequires:     binutils >= 2.23.51.0.3-2}
+%{?with_efi:BuildRequires:     binutils >= 3:2.23.51.0.3-2}
 BuildRequires: bzip2-devel
 BuildRequires: ceph-devel
 BuildRequires: curl-devel
@@ -339,7 +345,7 @@ Ten pakiet zapewnia bashowe dopełnianie poleceń dla Xena (xl).
 
 %package efi
 Summary:       Xen hypervisor binary for EFI
-Summary(pl.UTF-8):     Hybervisor Xen dla EFI
+Summary(pl.UTF-8):     Hipernadzorca Xen dla EFI
 Group:         Applications/System
 Requires:      %{name}-libs-guest = %{version}-%{release}
 
@@ -365,6 +371,7 @@ Nadzorca Xen w postaci, która może być uruchomiona wprost z firmware
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
+%patch12 -p1
 
 # stubdom sources
 ln -s %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} stubdom
@@ -408,7 +415,7 @@ unset CXXFLAGS
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT/etc/{xen/examples,modules-load.d,logrotate.d} \
-       $RPM_BUILD_ROOT{/usr/lib/tmpfiles.d,%{systemdunitdir},/var/log/xen/console}
+       $RPM_BUILD_ROOT{%{systemdtmpfilesdir},%{systemdunitdir},/var/log/xen/console}
 
 %{__make} -j1 install-xen install-tools install-stubdom install-docs \
        %{!?with_ocaml:OCAML_TOOLS=n} \
@@ -428,9 +435,9 @@ install %{SOURCE34} $RPM_BUILD_ROOT%{systemdunitdir}/xenconsoled.service
 install %{SOURCE35} $RPM_BUILD_ROOT/etc/sysconfig/xenconsoled
 install %{SOURCE36} $RPM_BUILD_ROOT%{systemdunitdir}/xenstored.service
 install %{SOURCE37} $RPM_BUILD_ROOT/etc/sysconfig/xenstored
-install %{SOURCE38} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/xenstored.conf
+install %{SOURCE38} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xenstored.conf
 install %{SOURCE39} $RPM_BUILD_ROOT%{systemdunitdir}/xend.service
-install %{SOURCE40} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/xend.conf
+install %{SOURCE40} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xend.conf
 install %{SOURCE41} $RPM_BUILD_ROOT%{systemdunitdir}/xen-watchdog.service
 install %{SOURCE42} $RPM_BUILD_ROOT/etc/modules-load.d/xen-dom0.conf
 # sysvinit scripts
@@ -441,6 +448,7 @@ install %{SOURCE52} $RPM_BUILD_ROOT/etc/rc.d/init.d/xenstored
 install %{SOURCE53} $RPM_BUILD_ROOT/etc/rc.d/init.d/xen-watchdog
 install %{SOURCE54} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
 install %{SOURCE55} $RPM_BUILD_ROOT/etc/logrotate.d/xen
+install %{SOURCE56} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/xen.conf
 
 mv $RPM_BUILD_ROOT/etc/xen/{x{m,l}example*,examples}
 
@@ -620,6 +628,7 @@ fi
 %{_sharedstatedir}/xenstored
 %dir /var/run/xenstored
 %{systemdtmpfilesdir}/xenstored.conf
+%{systemdtmpfilesdir}/xen.conf
 %dir %attr(0700,root,root) /var/log/xen
 %dir %attr(0700,root,root) /var/log/xen/console
 %{_datadir}/qemu-xen
This page took 0.027566 seconds and 4 git commands to generate.