]> git.pld-linux.org Git - packages/xbmc.git/blobdiff - xbmc.spec
- +R: xorg-app-xdpyinfo, lsb-release
[packages/xbmc.git] / xbmc.spec
index c56e1a74cd93a563fde659cd3ce1f14def769378..4ae9cf6feb3e13b2a8b87e354d50ddc9050765aa 100644 (file)
--- a/xbmc.spec
+++ b/xbmc.spec
@@ -1,8 +1,9 @@
 #
 # TODO:
-# fix endless loop on ./configure
-# add missing BRs
-# make it build and add %files
+#  - fix build flags - some files are compiled with -O3 and without rpm*flags
+#  - fix linking order
+#  - fix install - add DESTDIR support
+#  - don't put binary in %{_datadir} and fix start scripts
 #
 %define     _subver b1
 Summary:       XBMC
@@ -64,6 +65,7 @@ BuildRequires:        openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: pulseaudio-devel
 BuildRequires: python-devel
+BuildRequires: rpm-pythonprov
 # used internally
 BuildRequires: sed >= 4.0
 BuildRequires: sqlite3-devel
@@ -75,6 +77,8 @@ BuildRequires:        xorg-lib-libXrandr-devel
 BuildRequires: xorg-lib-libXtst-devel
 BuildRequires: zip
 BuildRequires: zlib-devel
+Requires:      lsb-release
+Requires:      xorg-app-xdpyinfo
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -93,8 +97,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       prefix=$RPM_BUILD_ROOT/usr
+       prefix=$RPM_BUILD_ROOT%{_prefix}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -106,3 +109,6 @@ rm -rf $RPM_BUILD_ROOT
 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
 %attr(755,root,root) %{_bindir}/*
 %{_datadir}/%{name}
+%attr(755,root,root) %{_datadir}/%{name}/xbmc.bin
+%attr(755,root,root) %{_datadir}/%{name}/xbmc-xrandr
+%{_datadir}/xsessions/XBMC.desktop
This page took 0.069927 seconds and 5 git commands to generate.