]> git.pld-linux.org Git - packages/wvstreams.git/blobdiff - wvstreams.spec
- more includes on linux
[packages/wvstreams.git] / wvstreams.spec
index ad25c77f0cd212aabeb87b484fe8131d24328f7c..45d63e07050685e33ade880436159ee325761106 100644 (file)
@@ -1,23 +1,49 @@
 #
+# TODO:
+#   - review patches: vstreams-cflags.patch, wvstreams-mk.patch
+#   - check and/or package files:
+#    /etc/uniconf.conf
+#    /usr/bin/uni
+#    /usr/bin/wsd
+#    /usr/bin/wvtestrunner.pl
+#    /usr/lib/valgrind/wvstreams.supp
+#    /usr/sbin/uniconfd
+#    /usr/share/man/man8/uni.8.gz
+#    /usr/share/man/man8/uniconfd.8.gz
+#    /var/lib/uniconf/uniconfd.ini
+#
+#
 # Conditional build:
 %bcond_without doc     # don't build documentation
+%bcond_without slp     # build without openslp
 #
 Summary:       A network programming library written in C++
-Summary(pl):   Biblioteka programowania sieciowego napisana w C++
+Summary(pl.UTF-8):     Biblioteka programowania sieciowego napisana w C++
 Name:          wvstreams
-Version:       4.0.2
-Release:       1
+Version:       4.6.1
+Release:       2
 License:       LGPL
 Group:         Libraries
-Source0:       http://www.csclub.uwaterloo.ca/~ja2morri/%{name}-%{version}.tar.gz
-# Source0-md5: ecb4e74ebaa1f45206f5d88eb34c5623
-Patch0:                %{name}-rsapublickey.patch
-URL:           http://open.nit.ca/wvstreams/
+Source0:       http://wvstreams.googlecode.com/files/%{name}-%{version}.tar.gz
+# Source0-md5: 2760dac31a43d452a19a3147bfde571c
+Patch0:                %{name}-sort.patch
+Patch1:                %{name}-cflags.patch
+Patch2:                %{name}-mk.patch
+Patch3:                %{name}-openssl.patch
+Patch4:                %{name}-includes.patch
+URL:           http://alumnit.ca/wiki/index.php?page=WvStreams
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: boost-devel
+BuildRequires: dbus-devel >= 1.2.14
 %{?with_doc:BuildRequires:     doxygen}
 BuildRequires: libstdc++-devel
-BuildRequires: openssl-devel >= 0.9.7d
+%{?with_slp:BuildRequires:     openslp-devel}
+BuildRequires: openssl-devel >= 0.9.7i
+BuildRequires: pam-devel
+BuildRequires: pkgconfig
+BuildRequires: readline-devel
+BuildRequires: tcl-devel
 Obsoletes:     libwvstreams
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -25,13 +51,13 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 WvStreams aims to be an efficient, secure, and easy-to-use library for
 doing network applications development.
 
-%description -l pl
-WvStreams próbuje byæ wydajn±, bezpieczn± i ³atw± w u¿yciu bibliotek±
+%description -l pl.UTF-8
+WvStreams próbuje być wydajną, bezpieczną i łatwą w użyciu biblioteką
 do tworzenia aplikacji sieciowych.
 
 %package devel
 Summary:       Development files for WvStreams
-Summary(pl):   Pliki developerskie dla WvStreams
+Summary(pl.UTF-8):     Pliki developerskie dla WvStreams
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      libstdc++-devel
@@ -42,45 +68,43 @@ WvStreams aims to be an efficient, secure, and easy-to-use library for
 doing network applications development. This package contains the
 files needed for developing applications which use WvStreams.
 
-%description devel -l pl
-WvStreams próbuje byæ wydajn±, bezpieczn± i ³atw± w u¿yciu bibliotek±
-do tworzenia aplikacji sieciowych. Pakiet ten zawiera pliki niezbêdne
-do tworzenia aplikacji u¿ywaj±cych WvStreams.
+%description devel -l pl.UTF-8
+WvStreams próbuje być wydajną, bezpieczną i łatwą w użyciu biblioteką
+do tworzenia aplikacji sieciowych. Pakiet ten zawiera pliki niezbędne
+do tworzenia aplikacji używających WvStreams.
 
 %package static
 Summary:       Static wvstreams library
-Summary(pl):   Statyczna biblioteka wvstreams
+Summary(pl.UTF-8):     Statyczna biblioteka wvstreams
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static wvstreams library.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Statyczna wersja biblioteki wvstreams.
 
 %prep
 %setup -q
-#%patch0 -p1
-#ugly hack - fix it
-cp include/wvsslhacks.h crypto
-cp include/wvtelephony.h telephony
+%patch0 -p1
+#%patch1 -p1
+#%patch2 -p1
+%patch3 -p1
+%patch4 -p1
 
 %build
-# despite .fpic rules the same .o files are used for .a and .so - need -fPIC
-%{__aclocal}
-%{__autoconf}
-%{__autoheader}
-cp -f /usr/share/automake/config.sub xplc
 %configure \
+       --with%{!?with_slp:out}-openslp \
        --without-vorbis
 
 %{__make} -j1 \
+       VPATH=%{_libdir} \
        DEBUG=%{?debug:1}%{!?debug:0} \
        CXX="%{__cxx}" \
        CFLAGS="%{rpmcflags} -fPIC -DDEBUG=0 \$(OSDEFINE)"
 
-%if %{with doc}        
+%if %{with doc}
 %{__make} doxygen
 %endif
 
@@ -103,11 +127,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%if %{with doc}        
-%doc Docs/doxy-html/*
-%endif
+#%if %{with doc}
+#%doc Docs/doxy-html/*
+#%endif
 %attr(755,root,root) %{_libdir}/lib*.so
 %{_includedir}/wvstreams
+%{_pkgconfigdir}/*.pc
 
 %files static
 %defattr(644,root,root,755)
This page took 0.070249 seconds and 4 git commands to generate.