]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- updated to 1.1.20
[packages/wine.git] / wine.spec
index 84701d76456dcf71b9230ff155c87296ade446fc..e43c81993d42a98eb14d9e11b056dbba74f64ea8 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -1,12 +1,14 @@
 #
 # Conditional build:
 %bcond_without alsa            # don't build ALSA mm driver
-%bcond_without arts            # don't build aRts mm driver
 %bcond_without jack            # don't build JACK mm driver
 %bcond_without nas             # don't build NAS mm driver
 %bcond_without sane            # don't build TWAIN DLL with scanning support (through SANE)
 %bcond_without cups            # without CUPS printing support in winspool,wineps DLLs
 #
+# TODO:
+# - support for CAPI (ISDN support; --with-capi)
+#
 # NOTE: wine detects the following SONAMES for dlopen at build time:
 #   libcrypto,libssl (wininet.dll)
 #   libcups (winspool.dll.so,wineps.dll.so)
 # thus requires rebuild after change of any of the above.
 #
 # JACK requires ALSA
-%if !%{with alsa}
+%if %{without alsa}
 %undefine      with_jack
 %endif
 Summary:       Program that lets you launch Win applications
-Summary(es):   Ejecuta programas Windows en Linux
-Summary(pl):   Program pozwalaj±cy uruchamiaæ aplikacje Windows
-Summary(pt_BR):        Executa programas Windows no Linux
+Summary(es.UTF-8):     Ejecuta programas Windows en Linux
+Summary(pl.UTF-8):     Program pozwalający uruchamiać aplikacje Windows
+Summary(pt_BR.UTF-8):  Executa programas Windows no Linux
 Name:          wine
-Version:       0.9.30
-Release:       0.1
+Version:       1.1.20
+Release:       1
 Epoch:         1
 License:       LGPL
 Group:         Applications/Emulators
 Source0:       http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
-# Source0-md5: ac4e191d99386db1ed83723ac72e93ce
+# Source0-md5: 5eb87a5053fcb83fb4c9bcee68b113bc
+Source1:       %{name}-uninstaller.desktop
 Patch0:                %{name}-fontcache.patch
 Patch1:                %{name}-makedep.patch
-Patch2:                %{name}-alsa.patch
-Patch3:                %{name}-ncurses.patch
-#PatchX:               %{name}-dga.patch
+Patch2:                %{name}-ncurses.patch
+Patch4:                %{name}-disable-valgrind.patch
+Patch5:                %{name}-ca_certificates.patch
+Patch6:                %{name}-notarget.patch
+Patch7:                %{name}-manpaths.patch
+#PatchX:       %{name}-dga.patch
 URL:           http://www.winehq.org/
 BuildRequires: OpenGL-GLU-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
@@ -46,7 +52,6 @@ BuildRequires:        OpenGL-GLU-devel
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
-# BuildRequires:       chpax >= 0.20020901-2
 %{?with_cups:BuildRequires:    cups-devel}
 BuildRequires: docbook-dtd31-sgml
 BuildRequires: docbook-utils
@@ -55,26 +60,48 @@ BuildRequires:      fontconfig-devel
 BuildRequires: fontforge
 BuildRequires: freetype-devel >= 2.0.5
 BuildRequires: giflib-devel
+BuildRequires: gnutls-devel
+BuildRequires: hal-devel
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
+BuildRequires: lcms-devel
+BuildRequires: libgphoto2-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libtool
+BuildRequires: libxslt-devel
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: ncurses-devel
 # db2* failed previously - probably openjade or opensp bug
 BuildRequires: openjade >= 1:1.3.3-0.pre1
+BuildRequires: openldap-devel
 BuildRequires: opensp >= 1:1.5.1
 BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: pkgconfig
 %{?with_sane:BuildRequires:    sane-backends-devel}
-BuildRequires: valgrind
+BuildRequires: unixODBC-devel >= 2.2.12-2
+#BuildRequires:        valgrind
+BuildRequires: xorg-lib-libXcomposite-devel
+BuildRequires: xorg-lib-libXcursor-devel
 BuildRequires: xorg-lib-libXi-devel
+BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXmu-devel
+BuildRequires: xorg-lib-libXrandr-devel
 BuildRequires: xorg-lib-libXrender-devel
 BuildRequires: xorg-lib-libXxf86dga-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
-Requires:      binfmt-detector
+Requires:      libfreetype.so.6
+Suggests:      binfmt-detector
+Suggests:      ca-certificates
+Conflicts:     ca-certificates < 20080809-4
+# for winelauncher
+Suggests:      xorg-app-xmessage
+# for ntlm_auth
+Suggests:      samba-common >= 1:3.0.25
 # link to wine/ntdll.dll.so, without any SONAME
 Provides:      libntdll.dll.so
+Obsoletes:     wine-doc-pdf
+Obsoletes:     wine-drv-arts
 ExclusiveArch: %{ix86}
+ExcludeArch:   i386
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep           libGL.so.1 libGLU.so.1
@@ -94,59 +121,59 @@ Windows binary, and a library that implements Windows API calls using
 their Unix or X11 equivalents. The library may also be used for
 porting Win32 code into native Unix executables.
 
-%description -l es
+%description -l es.UTF-8
 Ejecuta programas Windows en Linux.
 
-%description -l pl
-Wine jest programem dziêki któremu mo¿na uruchamiaæ programy napisane
-dla Microsoft Windows pod systemami uniksowymi. Sk³ada siê on z
-loadera, który pozwala wczytywaæ i uruchamiaæ programy w formacie
-Microsoft Windows, oraz z biblioteki, która implementuje API Windows
-przy u¿yciu odpowiedników uniksowych oraz z X11. Biblioteka mo¿e byæ
-tak¿e wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
+%description -l pl.UTF-8
+Wine jest programem dzięki któremu można uruchamiać programy napisane
+dla Microsoft Windows pod systemami uniksowymi. Składa się on z
+loadera, który pozwala wczytywać i uruchamiać programy w formacie
+Microsoft Windows, oraz z biblioteki, która implementuje API Windows
+przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
+także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
 
-%description -l pt_BR
-O Wine é um programa que permite rodar programas MS-Windows no X11.
+%description -l pt_BR.UTF-8
+O Wine é um programa que permite rodar programas MS-Windows no X11.
 Ele consiste de um carregador de programa, que carrega e executa um
-binário MS-Windows, e de uma biblioteca de emulação que traduz as
+binário MS-Windows, e de uma biblioteca de emulação que traduz as
 chamadas da API para as equivalentes Unix/X11.
 
 %package devel
 Summary:       Wine - header files
-Summary(es):   Biblioteca de desarrollo de wine
-Summary(pl):   Wine - pliki nag³owkowe
-Summary(pt_BR):        Biblioteca de desenvolvimento do wine
+Summary(es.UTF-8):     Biblioteca de desarrollo de wine
+Summary(pl.UTF-8):     Wine - pliki nagłowkowe
+Summary(pt_BR.UTF-8):  Biblioteca de desenvolvimento do wine
 Group:         Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description devel
 Wine - header files.
 
-%description devel -l es
+%description devel -l es.UTF-8
 Biblioteca de desarrollo de wine.
 
-%description devel -l pl
-Wine - pliki nag³ówkowe.
+%description devel -l pl.UTF-8
+Wine - pliki nagłówkowe.
 
-%description devel -l pt_BR
-Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
+%description devel -l pt_BR.UTF-8
+Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
 WINE.
 
 %package programs
 Summary:       Wine - programs
-Summary(pl):   Wine - programy
+Summary(pl.UTF-8):     Wine - programy
 Group:         Applications
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description programs
 Wine - programs.
 
-%description programs -l pl
+%description programs -l pl.UTF-8
 Wine - programy.
 
 %package dll-d3d
 Summary:       Direct3D implementation DLLs for Wine
-Summary(pl):   Biblioteki DLL z implementacj± Direct3D dla Wine
+Summary(pl.UTF-8):     Biblioteki DLL z implementacją Direct3D dla Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      OpenGL
@@ -154,12 +181,12 @@ Requires: OpenGL
 %description dll-d3d
 Direct3D implementation DLLs for Wine (through OpenGL).
 
-%description dll-d3d -l pl
-Biblioteki DLL z implementacj± Direct3D dla Wine (poprzez OpenGL).
+%description dll-d3d -l pl.UTF-8
+Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
 
 %package dll-gl
 Summary:       OpenGL implementation DLLs for Wine
-Summary(pl):   Biblioteki DLL z implementacj± OpenGL dla Wine
+Summary(pl.UTF-8):     Biblioteki DLL z implementacją OpenGL dla Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      OpenGL
@@ -167,48 +194,36 @@ Requires: OpenGL
 %description dll-gl
 OpenGL implementation DLLs for Wine.
 
-%description dll-gl -l pl
-Biblioteki DLL z implementacj± OpenGL dla Wine.
+%description dll-gl -l pl.UTF-8
+Biblioteki DLL z implementacją OpenGL dla Wine.
 
 %package dll-twain
 Summary:       TWAIN implementation DLL for Wine
-Summary(pl):   Biblioteka DLL z implementacj± TWAIN dla Wine
+Summary(pl.UTF-8):     Biblioteka DLL z implementacją TWAIN dla Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description dll-twain
 TWAIN implementation DLL for Wine (through SANE).
 
-%description dll-twain -l pl
-Biblioteka DLL z implementacj± TWAIN dla Wine (poprzez SANE).
+%description dll-twain -l pl.UTF-8
+Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
 
 %package drv-alsa
 Summary:       ALSA driver for WINE mm.dll implementation
-Summary(pl):   Sterownik ALSA dla implementacji mm.dll w Wine
+Summary(pl.UTF-8):     Sterownik ALSA dla implementacji mm.dll w Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description drv-alsa
 ALSA driver for WINE mm.dll (multimedia system) implementation.
 
-%description drv-alsa -l pl
-Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
-
-%package drv-arts
-Summary:       aRts driver for WINE mm.dll implementation
-Summary(pl):   Sterownik aRts dla implementacji mm.dll w Wine
-Group:         Applications/Emulators
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-
-%description drv-arts
-aRts driver for WINE mm.dll (multimedia system) implementation.
-
-%description drv-arts -l pl
-Sterownik aRts dla implementacji mm.dll (systemu multimediów) w Wine.
+%description drv-alsa -l pl.UTF-8
+Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
 
 %package drv-jack
 Summary:       JACK driver for WINE mm.dll implementation
-Summary(pl):   Sterownik JACK-a dla implementacji mm.dll w Wine
+Summary(pl.UTF-8):     Sterownik JACK-a dla implementacji mm.dll w Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      jack-audio-connection-kit
@@ -218,28 +233,31 @@ Requires: jack-audio-connection-kit
 %description drv-jack
 JACK driver for WINE mm.dll (multimedia system) implementation.
 
-%description drv-jack -l pl
-Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
+%description drv-jack -l pl.UTF-8
+Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
 Wine.
 
 %package drv-nas
 Summary:       NAS driver for WINE mm.dll implementation
-Summary(pl):   Sterownik NAS dla implementacji mm.dll w Wine
+Summary(pl.UTF-8):     Sterownik NAS dla implementacji mm.dll w Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description drv-nas
 NAS driver for WINE mm.dll (multimedia system) implementation.
 
-%description drv-nas -l pl
-Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
+%description drv-nas -l pl.UTF-8
+Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
 
 # turn off compilation of some tools
 sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
@@ -249,15 +267,41 @@ sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
 %{__autoconf}
 %{__autoheader}
 %configure \
-       %{!?debug:--disable-debug} \
-       %{!?debug:--disable-trace} \
-       --enable-curses \
-       --enable-opengl \
+       --with%{!?with_alsa:out}-alsa \
+       --with-cms \
+       --with%{!?with_cups:out}-cups \
+       --with-cups \
+       --with-curses \
+       --with-esd \
+       --with-fontconfig \
+       --with-freetype \
+       --with-glu \
+       --with-gphoto \
+       --with-hal \
+       --with%{!?with_jack:out}-jack \
+       --with-jpeg \
+       --with-ldap \
+       --with%{!?with_nas:out}-nas \
+       --with-opengl \
+       --with-openssl \
+       --with-oss \
+       --with-png \
+       --with%{!?with_sane:out}-sane \
+       --with-xcomposite \
+       --with-xcursor \
+       --with-xinerama \
+       --with-xinput \
+       --with-xml \
+       --with-xrandr \
+       --with-xrender \
+       --with-xshape \
+       --with-xshm \
+       --with-xslt \
+       --with-xxf86vm \
        --with-x
 %{__make} depend
 %{__make}
 %{__make} -C programs
-#%{__make} -C programs/regapi
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -272,7 +316,6 @@ install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
 install tools/fnt2bdf                  $RPM_BUILD_ROOT%{_bindir}
 
 install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
-#mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
 
 install -d \
        $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
@@ -285,7 +328,7 @@ touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
 
-cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
+cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
 [mci]
 cdaudio=mcicda.drv
 sequencer=mciseq.drv
@@ -313,7 +356,7 @@ fi
 
 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
 
-programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
+programs="msiexec notepad regedit regsvr32 wineboot winecfg wineconsole winedbg winefile winemine winepath"
 
 BZZZ=`pwd`
 rm -f files.so;                touch files.so
@@ -321,7 +364,7 @@ rm -f files.programs;       touch files.programs
 cd $RPM_BUILD_ROOT%{_libdir}/wine
 for f in *.so; do
        case $f in
-               d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winearts.drv.so|winejack.drv.so|winenas.drv.so)
+               d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
                        ;;
                *)
                        echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
@@ -335,6 +378,10 @@ for p in $programs; do
        mv -f files.so. files.so
 done
 
+install -d $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
+install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
+install programs/winetest/winetest.svg $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -349,7 +396,7 @@ fi
 
 %files -f files.so
 %defattr(644,root,root,755)
-%doc README ChangeLog AUTHORS ANNOUNCE
+%doc README documentation/ChangeLog* AUTHORS ANNOUNCE
 %lang(de) %doc documentation/README.de
 %lang(es) %doc documentation/README.es
 %lang(fr) %doc documentation/README.fr
@@ -361,27 +408,30 @@ fi
 %attr(755,root,root) %{_bindir}/msiexec
 %attr(755,root,root) %{_bindir}/wine
 %attr(755,root,root) %{_bindir}/wineboot
-%attr(755,root,root) %{_bindir}/winebrowser
 %attr(755,root,root) %{_bindir}/winecfg
 %attr(755,root,root) %{_bindir}/winedbg
-%attr(755,root,root) %{_bindir}/wine-kthread
-%attr(755,root,root) %{_bindir}/winelauncher
+#%attr(755,root,root) %{_bindir}/wine-kthread
+#%attr(755,root,root) %{_bindir}/winelauncher
 %attr(755,root,root) %{_bindir}/wineprefixcreate
 %attr(755,root,root) %{_bindir}/wine-preloader
-%attr(755,root,root) %{_bindir}/wine-pthread
+#%attr(755,root,root) %{_bindir}/wine-pthread
 %attr(755,root,root) %{_bindir}/wineserver
-%attr(755,root,root) %{_bindir}/wineshelllink
 %attr(755,root,root) %{_libdir}/*.so*
 %dir %{_libdir}/wine
 %{_libdir}/wine/*.dll16
 %{_libdir}/wine/*.drv16
 %{_libdir}/wine/*.exe16
 %{_mandir}/man1/wine.1*
+%lang(de) %{_mandir}/de/man1/wine.1*
+%lang(fr) %{_mandir}/fr/man1/wine.1*
 %{_mandir}/man1/winedbg.1*
 %{_mandir}/man1/wineprefixcreate.1*
 %{_mandir}/man1/wineserver.1*
+%lang(fr) %{_mandir}/fr/man1/wineserver.1*
 %{_winedir}
 %{_desktopdir}/wine.desktop
+%{_desktopdir}/wine-uninstaller.desktop
+%{_pixmapsdir}/wine.svg
 
 %files programs -f files.programs
 %defattr(644,root,root,755)
@@ -396,12 +446,14 @@ fi
 %attr(755,root,root) %{_bindir}/wineg++
 %attr(755,root,root) %{_bindir}/winegcc
 %attr(755,root,root) %{_bindir}/winemaker
+%attr(755,root,root) %{_bindir}/winecpp
 #%attr(755,root,root) %{_bindir}/winewrap
 %attr(755,root,root) %{_bindir}/wmc
 %attr(755,root,root) %{_bindir}/wrc
 %{_libdir}/wine/lib*.def
 # no shared variants, so not separated
 %{_libdir}/wine/lib*.def.a
+%{_libdir}/wine/libadsiid.a
 %{_libdir}/wine/libdx*.a
 %{_libdir}/wine/libstrmiids.a
 %{_libdir}/wine/libuuid.a
@@ -410,6 +462,7 @@ fi
 %{_mandir}/man1/widl.1*
 %{_mandir}/man1/winedump.1*
 %{_mandir}/man1/winegcc.1*
+%{_mandir}/man1/wineg++.1*
 %{_mandir}/man1/winemaker.1*
 %{_mandir}/man1/winebuild.1*
 %{_mandir}/man1/wmc.1*
@@ -441,12 +494,6 @@ fi
 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
 %endif
 
-%if %{with arts}
-%files drv-arts
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/winearts.drv.so
-%endif
-
 %if %{with jack}
 %files drv-jack
 %defattr(644,root,root,755)
This page took 0.788184 seconds and 4 git commands to generate.