]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- removed redundant BR (RTF pld-devel)
[packages/wine.git] / wine.spec
index 84b5d8d1c3a28599a36d147e02bd343c2bebcfdd..b2c1c426702f704a4721a76b7b7c6e77000a1b4f 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -1,13 +1,21 @@
+#
+# Conditional build:
+# _without_arts                - without arts support
+# _without_cups                - without CUPS printing support
+# _without_sane                - without TWAIN scanning support (through SANE)
+#
+# maybe TODO: alsa,jack,nas BRs/checks (see dlls/winmm/wine*)
 Summary:       Program that lets you launch Win applications
 Summary(es):   Ejecuta programas Windows en Linux
 Summary(pl):   Program pozwalajĀ±cy uruchamiaƦ aplikacje Windows
 Summary(pt_BR):        Executa programas Windows no Linux
 Name:          wine
-Version:       20021219
-Release:       1
+Version:       20030508
+Release:       2
 License:       GPL
 Group:         Applications/Emulators
 Source0:       ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
+# Source0-md5: 15ae091974c28c38c71e29fe64eacad7
 Source1:       %{name}.init
 Source2:       %{name}.reg
 Source3:       %{name}.systemreg
@@ -15,6 +23,8 @@ Source4:      %{name}.userreg
 Patch0:                %{name}-fontcache.patch
 Patch1:                %{name}-destdir.patch
 Patch2:                %{name}-ncurses.patch
+Patch3:                %{name}-ac-ksh.patch
+Patch4:                %{name}-binutils.patch
 URL:           http://www.winehq.com/
 BuildRequires: OpenGL-devel
 BuildRequires: XFree86-devel
@@ -29,6 +39,10 @@ BuildRequires:       freetype-devel >= 2.0.5
 BuildRequires: libjpeg-devel
 BuildRequires: ncurses-devel
 BuildRequires: openjade
+BuildRequires: tetex-metafont
+BuildRequires: tetex-fonts-pazo
+BuildRequires: tetex-fonts-stmaryrd
+BuildRequires: tetex-fonts-type1-urw
 %{!?_without_sane:BuildRequires:       sane-backends-devel}
 Requires:      OpenGL
 Requires(post):        /sbin/ldconfig
@@ -39,8 +53,6 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _noautoreqdep           libGL.so.1 libGLU.so.1
 %define                no_install_post_strip   1
 
-%define                _prefix                 /usr/X11R6
-%define                _mandir                 %{_prefix}/man
 %define                _winedir                %{_datadir}/%{name}
 
 %description
@@ -96,16 +108,29 @@ Group:             Applications
 Requires:      %{name} = %{version}
 
 %description programs
-Wine - programs
+Wine - programs.
 
 %description programs -l pl
-Wine - programy
+Wine - programy.
+
+%package doc-pdf
+Summary:       Wine documentation in PDF
+Summary(pl):   Dokumentacja Wine w formacie PDF
+Group:         Documentation
+
+%description doc-pdf
+Wine documentation in PDF format.
+
+%description doc-pdf -l pl
+Dokumentacja Wine w formacie PDF.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p0
 
 # turn off compilation of some tools
 #sed -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in > .tmp
@@ -130,9 +155,15 @@ CFLAGS="%{rpmcflags} $CPPFLAGS"
 %{__make} -C programs/regapi
 
 cd documentation
-./db2html-winehq wine-user.sgml
-./db2html-winehq wine-devel.sgml
-./db2html-winehq winelib-user.sgml
+db2html wine-user.sgml
+db2html wine-devel.sgml
+db2html wine-faq.sgml
+db2html winelib-user.sgml
+
+db2pdf         wine-user.sgml
+db2pdf  wine-devel.sgml
+db2pdf  wine-faq.sgml
+db2pdf  winelib-user.sgml
 cd -
 
 %install
@@ -155,7 +186,7 @@ install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
        $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
        $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/wine
+install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wine
 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
@@ -232,13 +263,17 @@ fi
 %files -f files.so
 %defattr(644,root,root,755)
 %doc README DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
-%doc documentation/{wine-user,samples,status}
+%doc documentation/{wine-user,samples,status,wine-faq}
 %attr(755,root,root) %{_bindir}/wine
+%attr(755,root,root) %{_bindir}/wineboot
+%attr(755,root,root) %{_bindir}/winecfg
+%attr(755,root,root) %{_bindir}/wineclipsrv
 %attr(755,root,root) %{_bindir}/winedbg
+%attr(755,root,root) %{_bindir}/winelauncher
 %attr(755,root,root) %{_bindir}/wineserver
-%attr(755,root,root) %{_bindir}/wineclipsrv
 %attr(755,root,root) %{_bindir}/wineshelllink
 %attr(755,root,root) %{_libdir}/*.so*
+%dir %{_libdir}/wine
 %{_mandir}/man1/wine.*
 %{_mandir}/man5/wine.conf.*
 %config(noreplace) %{_sysconfdir}/wine.reg
@@ -253,19 +288,26 @@ fi
 %files devel
 %defattr(644,root,root,755)
 %doc documentation/{wine-devel,winelib-user,HOWTO-winelib}
+%attr(755,root,root) %{_bindir}/fnt2bdf
+%attr(755,root,root) %{_bindir}/function_grep.pl
+%attr(755,root,root) %{_bindir}/hlp2sgml
+%attr(755,root,root) %{_bindir}/widl
 %attr(755,root,root) %{_bindir}/winebuild
-%attr(755,root,root) %{_bindir}/winemaker
 %attr(755,root,root) %{_bindir}/winedump
-%attr(755,root,root) %{_bindir}/wrc
+%attr(755,root,root) %{_bindir}/wineg++
+%attr(755,root,root) %{_bindir}/winegcc
+%attr(755,root,root) %{_bindir}/winemaker
+%attr(755,root,root) %{_bindir}/winewrap
 %attr(755,root,root) %{_bindir}/wmc
-#%attr(755,root,root) %{_bindir}/widl
-%attr(755,root,root) %{_bindir}/hlp2sgml
-%attr(755,root,root) %{_bindir}/fnt2bdf
-%attr(755,root,root) %{_bindir}/function_grep.pl
+%attr(755,root,root) %{_bindir}/wrc
 %{_includedir}/wine
 %{_libdir}/*.a
 %{_mandir}/man1/winemaker.*
-#%{_mandir}/man1/winebuild.*
+%{_mandir}/man1/winebuild.*
 %{_mandir}/man1/wmc.*
 %{_mandir}/man1/wrc.*
 %{_aclocaldir}/*.m4
+
+%files doc-pdf
+%defattr(644,root,root,755)
+%doc documentation/*.pdf
This page took 0.034747 seconds and 4 git commands to generate.