]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- add patch: Bug 17296,STBR
[packages/wine.git] / wine.spec
index 20b1d0559eee8f21abd39f4bb0a7c451b918812b..a8c2516a4bad030d570d642552b097cfbcb426c7 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -6,9 +6,8 @@
 %bcond_without sane            # don't build TWAIN DLL with scanning support (through SANE)
 %bcond_without cups            # without CUPS printing support in winspool,wineps DLLs
 #
-# NOTE:        wineconsole is a bit broken: try wineconsole cmd to see what will happen
-#      As a workaroound use `wineconsole --backend=user cmd' (works fine)
-#      ref: http://bugs.winehq.org/show_bug.cgi?id=8069
+# TODO:
+# - support for CAPI (ISDN support; --with-capi)
 #
 # NOTE: wine detects the following SONAMES for dlopen at build time:
 #   libcrypto,libssl (wininet.dll)
@@ -30,19 +29,22 @@ Summary(es.UTF-8):  Ejecuta programas Windows en Linux
 Summary(pl.UTF-8):     Program pozwalający uruchamiać aplikacje Windows
 Summary(pt_BR.UTF-8):  Executa programas Windows no Linux
 Name:          wine
-Version:       0.9.61
+Version:       1.1.23
 Release:       2
 Epoch:         1
 License:       LGPL
 Group:         Applications/Emulators
-Source0:       http://dl.sourceforge.net/wine/%{name}-%{version}.tar.bz2
-# Source0-md5: d01518d529903dca013da592113bd995
+Source0:       http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
+# Source0-md5: 2a588487d4553a01db8326c7db710da2
 Source1:       %{name}-uninstaller.desktop
 Patch0:                %{name}-fontcache.patch
 Patch1:                %{name}-makedep.patch
 Patch2:                %{name}-ncurses.patch
-Patch3:                %{name}-bug9177_workaround.patch
 Patch4:                %{name}-disable-valgrind.patch
+Patch5:                %{name}-ca_certificates.patch
+Patch6:                %{name}-notarget.patch
+Patch7:                %{name}-manpaths.patch
+Patch8:                %{name}-secur32.patch
 #PatchX:       %{name}-dga.patch
 URL:           http://www.winehq.org/
 BuildRequires: OpenGL-GLU-devel
@@ -59,24 +61,38 @@ BuildRequires:      fontconfig-devel
 BuildRequires: fontforge
 BuildRequires: freetype-devel >= 2.0.5
 BuildRequires: giflib-devel
+BuildRequires: gnutls-devel
+BuildRequires: hal-devel
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
+BuildRequires: lcms-devel
+BuildRequires: libgphoto2-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libtool
+BuildRequires: libxslt-devel
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: ncurses-devel
 # db2* failed previously - probably openjade or opensp bug
 BuildRequires: openjade >= 1:1.3.3-0.pre1
-BuildRequires: openldap-devel >= 2.4.6
+BuildRequires: openldap-devel
 BuildRequires: opensp >= 1:1.5.1
 BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: pkgconfig
 %{?with_sane:BuildRequires:    sane-backends-devel}
+BuildRequires: unixODBC-devel >= 2.2.12-2
 #BuildRequires:        valgrind
+BuildRequires: xorg-lib-libXcomposite-devel
+BuildRequires: xorg-lib-libXcursor-devel
 BuildRequires: xorg-lib-libXi-devel
+BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXmu-devel
+BuildRequires: xorg-lib-libXrandr-devel
 BuildRequires: xorg-lib-libXrender-devel
 BuildRequires: xorg-lib-libXxf86dga-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
+Requires:      libfreetype.so.6
 Suggests:      binfmt-detector
+Suggests:      ca-certificates
+Conflicts:     ca-certificates < 20080809-4
 # for winelauncher
 Suggests:      xorg-app-xmessage
 # for ntlm_auth
@@ -239,8 +255,11 @@ Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 %patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
 
 # turn off compilation of some tools
 sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
@@ -250,10 +269,37 @@ sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
 %{__autoconf}
 %{__autoheader}
 %configure \
-       %{!?debug:--disable-debug} \
-       %{!?debug:--disable-trace} \
-       --enable-curses \
-       --enable-opengl \
+       --with%{!?with_alsa:out}-alsa \
+       --with-cms \
+       --with%{!?with_cups:out}-cups \
+       --with-cups \
+       --with-curses \
+       --with-esd \
+       --with-fontconfig \
+       --with-freetype \
+       --with-glu \
+       --with-gphoto \
+       --with-hal \
+       --with%{!?with_jack:out}-jack \
+       --with-jpeg \
+       --with-ldap \
+       --with%{!?with_nas:out}-nas \
+       --with-opengl \
+       --with-openssl \
+       --with-oss \
+       --with-png \
+       --with%{!?with_sane:out}-sane \
+       --with-xcomposite \
+       --with-xcursor \
+       --with-xinerama \
+       --with-xinput \
+       --with-xml \
+       --with-xrandr \
+       --with-xrender \
+       --with-xshape \
+       --with-xshm \
+       --with-xslt \
+       --with-xxf86vm \
        --with-x
 %{__make} depend
 %{__make}
@@ -312,7 +358,7 @@ fi
 
 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
 
-programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp"
+programs="msiexec notepad regedit regsvr32 wineboot winecfg wineconsole winedbg winefile winemine winepath"
 
 BZZZ=`pwd`
 rm -f files.so;                touch files.so
@@ -352,7 +398,7 @@ fi
 
 %files -f files.so
 %defattr(644,root,root,755)
-%doc README ChangeLog AUTHORS ANNOUNCE
+%doc README documentation/ChangeLog* AUTHORS ANNOUNCE
 %lang(de) %doc documentation/README.de
 %lang(es) %doc documentation/README.es
 %lang(fr) %doc documentation/README.fr
@@ -364,26 +410,26 @@ fi
 %attr(755,root,root) %{_bindir}/msiexec
 %attr(755,root,root) %{_bindir}/wine
 %attr(755,root,root) %{_bindir}/wineboot
-%attr(755,root,root) %{_bindir}/winebrowser
 %attr(755,root,root) %{_bindir}/winecfg
 %attr(755,root,root) %{_bindir}/winedbg
-%attr(755,root,root) %{_bindir}/wine-kthread
+#%attr(755,root,root) %{_bindir}/wine-kthread
 #%attr(755,root,root) %{_bindir}/winelauncher
 %attr(755,root,root) %{_bindir}/wineprefixcreate
 %attr(755,root,root) %{_bindir}/wine-preloader
-%attr(755,root,root) %{_bindir}/wine-pthread
+#%attr(755,root,root) %{_bindir}/wine-pthread
 %attr(755,root,root) %{_bindir}/wineserver
-%attr(755,root,root) %{_bindir}/wineshelllink
 %attr(755,root,root) %{_libdir}/*.so*
 %dir %{_libdir}/wine
 %{_libdir}/wine/*.dll16
 %{_libdir}/wine/*.drv16
 %{_libdir}/wine/*.exe16
-%{_libdir}/wine/*.mod16
 %{_mandir}/man1/wine.1*
+%lang(de) %{_mandir}/de/man1/wine.1*
+%lang(fr) %{_mandir}/fr/man1/wine.1*
 %{_mandir}/man1/winedbg.1*
 %{_mandir}/man1/wineprefixcreate.1*
 %{_mandir}/man1/wineserver.1*
+%lang(fr) %{_mandir}/fr/man1/wineserver.1*
 %{_winedir}
 %{_desktopdir}/wine.desktop
 %{_desktopdir}/wine-uninstaller.desktop
This page took 0.043108 seconds and 4 git commands to generate.