]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- updated to 1.1.0
[packages/wine.git] / wine.spec
index 0de017f886ae0f98139c2173387ddef09e5ea162..1a4da8179cbf93ddc09366a4e6dec632eb820743 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -1,15 +1,16 @@
 #
 # Conditional build:
 %bcond_without alsa            # don't build ALSA mm driver
-%bcond_without arts            # don't build aRts mm driver
 %bcond_without jack            # don't build JACK mm driver
 %bcond_without nas             # don't build NAS mm driver
 %bcond_without sane            # don't build TWAIN DLL with scanning support (through SANE)
 %bcond_without cups            # without CUPS printing support in winspool,wineps DLLs
-%bcond_without html_docs       # build html docs
-%bcond_without pdf_docs        # build pdf docs
 #
-# NOTE: wine detects following SONAMES for dlopen at build time:
+# NOTE:        wineconsole is a bit broken: try wineconsole cmd to see what will happen
+#      As a workaroound use `wineconsole --backend=user cmd' (works fine)
+#      ref: http://bugs.winehq.org/show_bug.cgi?id=8069
+#
+# NOTE: wine detects the following SONAMES for dlopen at build time:
 #   libcrypto,libssl (wininet.dll)
 #   libcups (winspool.dll.so,wineps.dll.so)
 #   libcurses/libncurses (wineconsole program)
 #   libfreetype (wineps.dll.so,gdi32.dll.so)
 #   libGL (x11drv.dll.so,ddraw.dll.so)
 #   libjack (winejack.drv.so - explicit dependency in subpackage)
-#   libX11, libXext, libXrender (x11drv.dll.so)
-# thus requires requild after change of any of above.
+#   libX11, libXext, libXi, libXrender (x11drv.dll.so)
+# thus requires rebuild after change of any of the above.
 #
 # JACK requires ALSA
 %if %{without alsa}
 %undefine      with_jack
 %endif
 Summary:       Program that lets you launch Win applications
-Summary(es):   Ejecuta programas Windows en Linux
-Summary(pl):   Program pozwalaj±cy uruchamiaæ aplikacje Windows
-Summary(pt_BR):        Executa programas Windows no Linux
+Summary(es.UTF-8):     Ejecuta programas Windows en Linux
+Summary(pl.UTF-8):     Program pozwalający uruchamiać aplikacje Windows
+Summary(pt_BR.UTF-8):  Executa programas Windows no Linux
 Name:          wine
-Version:       20031118
-Release:       2
-License:       GPL
+Version:       1.1.0
+Release:       1
+Epoch:         1
+License:       LGPL
 Group:         Applications/Emulators
-Source0:       http://dl.sf.net/wine/Wine-%{version}.tar.gz
-# Source0-md5: 5787e6b3205b54f2230b4c4c0d422c3c
-Source1:       %{name}.init
-Source2:       %{name}.reg
-Source3:       %{name}.systemreg
-Source4:       %{name}.userreg
+Source0:       http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
+# Source0-md5: b2374c4802bbef2f03633e153643b870
+Source1:       %{name}-uninstaller.desktop
 Patch0:                %{name}-fontcache.patch
-Patch1:                %{name}-destdir.patch
+Patch1:                %{name}-makedep.patch
 Patch2:                %{name}-ncurses.patch
-Patch3:                %{name}-ac-ksh.patch
-Patch4:                %{name}-binutils.patch
-Patch5:                %{name}-makedep.patch
-Patch6:                %{name}-dga.patch
-Patch7:                %{name}-winebuild.patch
+Patch3:                %{name}-bug9177_workaround.patch
+Patch4:                %{name}-disable-valgrind.patch
+#PatchX:       %{name}-dga.patch
 URL:           http://www.winehq.org/
-BuildRequires: OpenGL-devel
-BuildRequires: XFree86-devel
+BuildRequires: OpenGL-GLU-devel
 %{?with_alsa:BuildRequires:    alsa-lib-devel}
-%{?with_arts:BuildRequires:    arts-devel}
+%{?with_arts:BuildRequires:    artsc-devel}
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
-# BuildRequires:       chpax >= 0.20020901-2
 %{?with_cups:BuildRequires:    cups-devel}
 BuildRequires: docbook-dtd31-sgml
 BuildRequires: docbook-utils
 BuildRequires: flex
 BuildRequires: fontconfig-devel
+BuildRequires: fontforge
 BuildRequires: freetype-devel >= 2.0.5
+BuildRequires: giflib-devel
 %{?with_jack:BuildRequires:    jack-audio-connection-kit-devel}
 BuildRequires: libjpeg-devel
-BuildRequires: libungif-devel
+BuildRequires: libtool
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: ncurses-devel
-%if %{with html_docs} || %{with pdf_docs}
 # db2* failed previously - probably openjade or opensp bug
 BuildRequires: openjade >= 1:1.3.3-0.pre1
+BuildRequires: openldap-devel
 BuildRequires: opensp >= 1:1.5.1
-%endif
-BuildRequires: openssl-devel
-%if %{with pdf_docs}
-BuildRequires: tetex-metafont
-BuildRequires: tetex-fonts-pazo
-BuildRequires: tetex-fonts-stmaryrd
-BuildRequires: tetex-fonts-type1-urw
-%endif
+BuildRequires: openssl-devel >= 0.9.7d
 %{?with_sane:BuildRequires:    sane-backends-devel}
-BuildRequires: xrender-devel
-Requires(post):        /sbin/ldconfig
-Requires(post,preun):  /sbin/chkconfig
+#BuildRequires:        valgrind
+BuildRequires: xorg-lib-libXi-devel
+BuildRequires: xorg-lib-libXmu-devel
+BuildRequires: xorg-lib-libXrender-devel
+BuildRequires: xorg-lib-libXxf86dga-devel
+BuildRequires: xorg-lib-libXxf86vm-devel
+Suggests:      binfmt-detector
+# for winelauncher
+Suggests:      xorg-app-xmessage
+# for ntlm_auth
+Suggests:      samba-common >= 1:3.0.25
 # link to wine/ntdll.dll.so, without any SONAME
 Provides:      libntdll.dll.so
+Obsoletes:     wine-doc-pdf
+Obsoletes:     wine-drv-arts
 ExclusiveArch: %{ix86}
+ExcludeArch:   i386
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep           libGL.so.1 libGLU.so.1
@@ -93,7 +94,9 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _winedir                %{_datadir}/%{name}
 
-%define                getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk  '/SONAME/ { print $2 }')
+%define                getsoname()     %((objdump -p %{1} 2>/dev/null || echo SONAME ERROR) | awk '/SONAME/ { print $2; s=1 }; END { if(s==0) print "ERROR" }')
+
+%undefine      debuginfocflags
 
 %description
 Wine is a program which allows running Microsoft Windows programs
@@ -103,157 +106,133 @@ Windows binary, and a library that implements Windows API calls using
 their Unix or X11 equivalents. The library may also be used for
 porting Win32 code into native Unix executables.
 
-%description -l es
+%description -l es.UTF-8
 Ejecuta programas Windows en Linux.
 
-%description -l pl
-Wine jest programem dziêki któremu mo¿na uruchamiaæ programy napisane
-dla Microsoft Windows pod systemami unixowymi. Sk³ada siê on z
-loadera, który pozwala wczytywaæ i uruchamiaæ programy w formacie
-Microsoft Windows oraz z biblioteki, która implementuje API Windows
-przy u¿yciu odpowiedników Unixowych oraz z X11. Biblioteka mo¿e byæ
-tak¿e wykorzystana do przenoszenia aplikacji Win32 do Unixa.
+%description -l pl.UTF-8
+Wine jest programem dzięki któremu można uruchamiać programy napisane
+dla Microsoft Windows pod systemami uniksowymi. Składa się on z
+loadera, który pozwala wczytywać i uruchamiać programy w formacie
+Microsoft Windows, oraz z biblioteki, która implementuje API Windows
+przy użyciu odpowiedników uniksowych oraz z X11. Biblioteka może być
+także wykorzystana do przenoszenia aplikacji Win32 do Uniksa.
 
-%description -l pt_BR
-O Wine é um programa que permite rodar programas MS-Windows no X11.
+%description -l pt_BR.UTF-8
+O Wine é um programa que permite rodar programas MS-Windows no X11.
 Ele consiste de um carregador de programa, que carrega e executa um
-binário MS-Windows, e de uma biblioteca de emulação que traduz as
+binário MS-Windows, e de uma biblioteca de emulação que traduz as
 chamadas da API para as equivalentes Unix/X11.
 
 %package devel
 Summary:       Wine - header files
-Summary(es):   Biblioteca de desarrollo de wine
-Summary(pl):   Wine - pliki nag³owkowe
-Summary(pt_BR):        Biblioteca de desenvolvimento do wine
+Summary(es.UTF-8):     Biblioteca de desarrollo de wine
+Summary(pl.UTF-8):     Wine - pliki nagłowkowe
+Summary(pt_BR.UTF-8):  Biblioteca de desenvolvimento do wine
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description devel
 Wine - header files.
 
-%description devel -l es
+%description devel -l es.UTF-8
 Biblioteca de desarrollo de wine.
 
-%description devel -l pl
-Wine - pliki nag³ówkowe.
+%description devel -l pl.UTF-8
+Wine - pliki nagłówkowe.
 
-%description devel -l pt_BR
-Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
+%description devel -l pt_BR.UTF-8
+Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
 WINE.
 
 %package programs
 Summary:       Wine - programs
-Summary(pl):   Wine - programy
+Summary(pl.UTF-8):     Wine - programy
 Group:         Applications
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description programs
 Wine - programs.
 
-%description programs -l pl
+%description programs -l pl.UTF-8
 Wine - programy.
 
-%package doc-pdf
-Summary:       Wine documentation in PDF
-Summary(pl):   Dokumentacja Wine w formacie PDF
-Group:         Documentation
-
-%description doc-pdf
-Wine documentation in PDF format.
-
-%description doc-pdf -l pl
-Dokumentacja Wine w formacie PDF.
-
 %package dll-d3d
 Summary:       Direct3D implementation DLLs for Wine
-Summary(pl):   Biblioteki DLL z implementacj± Direct3D dla Wine
+Summary(pl.UTF-8):     Biblioteki DLL z implementacją Direct3D dla Wine
 Group:         Applications/Emulators
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      OpenGL
 
 %description dll-d3d
 Direct3D implementation DLLs for Wine (through OpenGL).
 
-%description dll-d3d -l pl
-Biblioteki DLL z implementacj± Direct3D dla Wine (poprzez OpenGL).
+%description dll-d3d -l pl.UTF-8
+Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
 
 %package dll-gl
 Summary:       OpenGL implementation DLLs for Wine
-Summary(pl):   Biblioteki DLL z implementacj± OpenGL dla Wine
+Summary(pl.UTF-8):     Biblioteki DLL z implementacją OpenGL dla Wine
 Group:         Applications/Emulators
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      OpenGL
 
 %description dll-gl
 OpenGL implementation DLLs for Wine.
 
-%description dll-gl -l pl
-Biblioteki DLL z implementacj± OpenGL dla Wine.
+%description dll-gl -l pl.UTF-8
+Biblioteki DLL z implementacją OpenGL dla Wine.
 
 %package dll-twain
 Summary:       TWAIN implementation DLL for Wine
-Summary(pl):   Biblioteka DLL z implementacj± TWAIN dla Wine
+Summary(pl.UTF-8):     Biblioteka DLL z implementacją TWAIN dla Wine
 Group:         Applications/Emulators
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description dll-twain
 TWAIN implementation DLL for Wine (through SANE).
 
-%description dll-twain -l pl
-Biblioteka DLL z implementacj± TWAIN dla Wine (poprzez SANE).
+%description dll-twain -l pl.UTF-8
+Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
 
 %package drv-alsa
 Summary:       ALSA driver for WINE mm.dll implementation
-Summary(pl):   Sterownik ALSA dla implementacji mm.dll w Wine
+Summary(pl.UTF-8):     Sterownik ALSA dla implementacji mm.dll w Wine
 Group:         Applications/Emulators
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description drv-alsa
 ALSA driver for WINE mm.dll (multimedia system) implementation.
 
-%description drv-alsa -l pl
-Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
-
-%package drv-arts
-Summary:       aRts driver for WINE mm.dll implementation
-Summary(pl):   Sterownik aRts dla implementacji mm.dll w Wine
-Group:         Applications/Emulators
-Requires:      %{name} = %{version}
-
-%description drv-arts
-aRts driver for WINE mm.dll (multimedia system) implementation.
-
-%description drv-arts -l pl
-Sterownik aRts dla implementacji mm.dll (systemu multimediów) w Wine.
+%description drv-alsa -l pl.UTF-8
+Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
 
 %package drv-jack
 Summary:       JACK driver for WINE mm.dll implementation
-Summary(pl):   Sterownik JACK dla implementacji mm.dll w Wine
+Summary(pl.UTF-8):     Sterownik JACK-a dla implementacji mm.dll w Wine
 Group:         Applications/Emulators
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      jack-audio-connection-kit
 # dlopened by SONAME detected at build time
-%if %{with jack}
-Requires:      %{getsoname /usr/lib/libjack.so}
-%endif
+%{?with_jack:Requires: %{getsoname /usr/%{_lib}/libjack.so}}
 
 %description drv-jack
 JACK driver for WINE mm.dll (multimedia system) implementation.
 
-%description drv-jack -l pl
-Sterownik JACK dla implementacji mm.dll (systemu multimediów) w Wine.
+%description drv-jack -l pl.UTF-8
+Sterownik JACK-a dla implementacji mm.dll (systemu multimediów) w
+Wine.
 
 %package drv-nas
 Summary:       NAS driver for WINE mm.dll implementation
-Summary(pl):   Sterownik NAS dla implementacji mm.dll w Wine
+Summary(pl.UTF-8):     Sterownik NAS dla implementacji mm.dll w Wine
 Group:         Applications/Emulators
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description drv-nas
 NAS driver for WINE mm.dll (multimedia system) implementation.
 
-%description drv-nas -l pl
-Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
+%description drv-nas -l pl.UTF-8
+Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
 
 %prep
 %setup -q
@@ -261,21 +240,15 @@ Sterownik NAS dla implementacji mm.dll (systemu multimedi
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p0
-%patch5 -p1
-%patch6 -p1
-%patch7 -p1
+%patch4 -p1
 
 # turn off compilation of some tools
-#sed -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in > .tmp
-sed -e "s|avitools||" programs/Makefile.in > .tmp
-mv -f .tmp programs/Makefile.in
+sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
+#sed -i -e "s|avitools||" programs/Makefile.in
 
 %build
-%{__aclocal}
 %{__autoconf}
-CPPFLAGS="-I/usr/include/ncurses -DALSA_PCM_OLD_HW_PARAMS_API"; export CPPFLAGS
-CFLAGS="%{rpmcflags} $CPPFLAGS"
+%{__autoheader}
 %configure \
        %{!?debug:--disable-debug} \
        %{!?debug:--disable-trace} \
@@ -285,23 +258,6 @@ CFLAGS="%{rpmcflags} $CPPFLAGS"
 %{__make} depend
 %{__make}
 %{__make} -C programs
-%{__make} -C programs/regapi
-
-cd documentation
-%if %{with html_docs}
-db2html wine-user.sgml
-db2html wine-devel.sgml
-db2html wine-faq.sgml
-db2html winelib-user.sgml
-%endif
-
-%if %{with pdf_docs}
-db2pdf         wine-user.sgml
-db2pdf  wine-devel.sgml
-db2pdf  wine-faq.sgml
-db2pdf  winelib-user.sgml
-%endif
-cd -
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -313,29 +269,22 @@ install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_aclocaldir}}
 %{__make} -C programs install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install programs/winhelp/hlp2sgml      $RPM_BUILD_ROOT%{_bindir}
 install tools/fnt2bdf                  $RPM_BUILD_ROOT%{_bindir}
 
 install aclocal.m4 $RPM_BUILD_ROOT%{_aclocaldir}/wine.m4
-#mv -f $RPM_BUILD_ROOT{/usr/X11R6/share/aclocal,%{_aclocaldir}}/wine.m4
 
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
-        $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
-        "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
+install -d \
+       $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
+       "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
        $RPM_BUILD_ROOT%{_winedir}/windows/{SendTo,ShellNew,system32,NetHood} \
        $RPM_BUILD_ROOT%{_winedir}/windows/{Profiles/Administrator,Recent} \
        $RPM_BUILD_ROOT%{_winedir}/{"Program Files/Common Files","My Documents"}
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/wine
-install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
-install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
-install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
-
 touch $RPM_BUILD_ROOT%{_winedir}/{autoexec.bat,config.sys,windows/win.ini}
 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{shell.dll,shell32.dll}
 touch $RPM_BUILD_ROOT%{_winedir}/windows/system/{winsock.dll,wsock32.dll}
 
-cat >$RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<EOF
+cat > $RPM_BUILD_ROOT%{_winedir}/windows/system.ini <<'EOF'
 [mci]
 cdaudio=mcicda.drv
 sequencer=mciseq.drv
@@ -357,13 +306,13 @@ if [ -n "$elfexelist" ]; then \
        strip -R .note -R .comment $elfexelist
 fi
 if [ -n "$elfsharedlist" ]; then
-       strip --strip-unneeded -R .note  -R .comment $elfsharedlist
+       strip --strip-unneeded -R .note -R .comment $elfsharedlist
 fi
 %endif
 
 # /sbin/chstk -e $RPM_BUILD_ROOT%{_bindir}/wine
 
-programs="notepad progman regedit regsvr32 uninstaller wineconsole winefile winemine winepath winhelp wcmd"
+programs="msiexec notepad progman regedit regsvr32 uninstaller wineboot winebrowser winecfg wineconsole winedbg winefile winemine winepath"
 
 BZZZ=`pwd`
 rm -f files.so;                touch files.so
@@ -371,10 +320,10 @@ rm -f files.programs;     touch files.programs
 cd $RPM_BUILD_ROOT%{_libdir}/wine
 for f in *.so; do
        case $f in
-         d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|twain_32.dll.so|winealsa.drv.so|winearts.drv.so|winejack.drv.so|winenas.drv.so)
-               ;;
-         *)
-               echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
+               d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
+                       ;;
+               *)
+                       echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
        esac
 done
 cd -
@@ -385,87 +334,97 @@ for p in $programs; do
        mv -f files.so. files.so
 done
 
+install -d $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
+install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
+install programs/winetest/winetest.svg $RPM_BUILD_ROOT%{_pixmapsdir}/wine.svg
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-/sbin/ldconfig
-/sbin/chkconfig --add wine
-if [ ! -f /var/lock/subsys/wine ]; then
-       echo "Run \"/etc/rc.d/init.d/wine start\" to start wine service." >&2
-fi
+%post  -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
 
-%preun
-if [ "$1" = "0" ]; then
-       if [ -f /var/lock/subsys/wine ]; then
-               /etc/rc.d/init.d/wine stop >&2
-       fi
+%triggerpostun -- wine < 1:0.9.12-1.9
+rm -f /var/lock/subsys/wine
+if [ -x /sbin/chkconfig ]; then
        /sbin/chkconfig --del wine
 fi
 
-%postun -p /sbin/ldconfig
-
 %files -f files.so
 %defattr(644,root,root,755)
-%doc README DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
-%doc documentation/samples
-%if %{with html_docs}
-%doc documentation/wine-{faq,user}
-%endif
+%doc README documentation/ChangeLog* AUTHORS ANNOUNCE
+%lang(de) %doc documentation/README.de
+%lang(es) %doc documentation/README.es
+%lang(fr) %doc documentation/README.fr
+%lang(it) %doc documentation/README.it
+%lang(ko) %doc documentation/README.ko
+%lang(nb) %doc documentation/README.no
+%lang(pt) %doc documentation/README.pt
+%lang(pt_BR) %doc documentation/README.pt_br
+%attr(755,root,root) %{_bindir}/msiexec
 %attr(755,root,root) %{_bindir}/wine
-%attr(755,root,root) %{_bindir}/wine-kthread
-%attr(755,root,root) %{_bindir}/wine-pthread
 %attr(755,root,root) %{_bindir}/wineboot
+%attr(755,root,root) %{_bindir}/winebrowser
 %attr(755,root,root) %{_bindir}/winecfg
-%attr(755,root,root) %{_bindir}/wineclipsrv
 %attr(755,root,root) %{_bindir}/winedbg
-%attr(755,root,root) %{_bindir}/winelauncher
+%attr(755,root,root) %{_bindir}/wine-kthread
+#%attr(755,root,root) %{_bindir}/winelauncher
+%attr(755,root,root) %{_bindir}/wineprefixcreate
+%attr(755,root,root) %{_bindir}/wine-preloader
+%attr(755,root,root) %{_bindir}/wine-pthread
 %attr(755,root,root) %{_bindir}/wineserver
 %attr(755,root,root) %{_bindir}/wineshelllink
 %attr(755,root,root) %{_libdir}/*.so*
 %dir %{_libdir}/wine
-%{_mandir}/man1/wine.*
-%{_mandir}/man5/wine.conf.*
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/wine.reg
-%config(missingok,noreplace) %verify(not size mtime md5) %{_sysconfdir}/wine.systemreg
-%config(missingok,noreplace) %verify(not size mtime md5) %{_sysconfdir}/wine.userreg
-%attr(754,root,root) %{_sysconfdir}/rc.d/init.d/wine
+%{_libdir}/wine/*.dll16
+%{_libdir}/wine/*.drv16
+%{_libdir}/wine/*.exe16
+%{_libdir}/wine/*.mod16
+%{_mandir}/man1/wine.1*
+%{_mandir}/man1/winedbg.1*
+%{_mandir}/man1/wineprefixcreate.1*
+%{_mandir}/man1/wineserver.1*
 %{_winedir}
+%{_desktopdir}/wine.desktop
+%{_desktopdir}/wine-uninstaller.desktop
+%{_pixmapsdir}/wine.svg
 
 %files programs -f files.programs
 %defattr(644,root,root,755)
 
 %files devel
 %defattr(644,root,root,755)
-%if %{with html_docs}
-%doc documentation/{wine-devel,winelib-user}
-%endif
 %attr(755,root,root) %{_bindir}/fnt2bdf
 %attr(755,root,root) %{_bindir}/function_grep.pl
-%attr(755,root,root) %{_bindir}/hlp2sgml
 %attr(755,root,root) %{_bindir}/widl
 %attr(755,root,root) %{_bindir}/winebuild
 %attr(755,root,root) %{_bindir}/winedump
 %attr(755,root,root) %{_bindir}/wineg++
 %attr(755,root,root) %{_bindir}/winegcc
 %attr(755,root,root) %{_bindir}/winemaker
-%attr(755,root,root) %{_bindir}/winewrap
+%attr(755,root,root) %{_bindir}/winecpp
+#%attr(755,root,root) %{_bindir}/winewrap
 %attr(755,root,root) %{_bindir}/wmc
 %attr(755,root,root) %{_bindir}/wrc
+%{_libdir}/wine/lib*.def
+# no shared variants, so not separated
+%{_libdir}/wine/lib*.def.a
+%{_libdir}/wine/libadsiid.a
+%{_libdir}/wine/libdx*.a
+%{_libdir}/wine/libstrmiids.a
+%{_libdir}/wine/libuuid.a
+%{_libdir}/wine/libwinecrt0.a
 %{_includedir}/wine
-%{_libdir}/*.a
-%{_mandir}/man1/winemaker.*
-%{_mandir}/man1/winebuild.*
-%{_mandir}/man1/wmc.*
-%{_mandir}/man1/wrc.*
+%{_mandir}/man1/widl.1*
+%{_mandir}/man1/winedump.1*
+%{_mandir}/man1/winegcc.1*
+%{_mandir}/man1/wineg++.1*
+%{_mandir}/man1/winemaker.1*
+%{_mandir}/man1/winebuild.1*
+%{_mandir}/man1/wmc.1*
+%{_mandir}/man1/wrc.1*
 %{_aclocaldir}/*.m4
 
-%if %{with pdf_docs}
-%files doc-pdf
-%defattr(644,root,root,755)
-%doc documentation/*.pdf
-%endif
-
 %files dll-d3d
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/wine/d3d8.dll.so
@@ -481,7 +440,8 @@ fi
 %if %{with sane}
 %files dll-twain
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/twain_32.dll.so
+%attr(755,root,root) %{_libdir}/wine/sane.ds.so
+%attr(755,root,root) %{_libdir}/wine/twain*.dll.so
 %endif
 
 %if %{with alsa}
@@ -490,12 +450,6 @@ fi
 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
 %endif
 
-%if %{with arts}
-%files drv-arts
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/winearts.drv.so
-%endif
-
 %if %{with jack}
 %files drv-jack
 %defattr(644,root,root,755)
This page took 0.066216 seconds and 4 git commands to generate.