]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- 20020710
[packages/wine.git] / wine.spec
index ec5f71d2f1bbb440eb2e5e93672b56ad4560d1a0..3a49f33b34e19fa2e1ce324f9dfc72888b4aef65 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -3,33 +3,42 @@ Summary(es):  Ejecuta programas Windows en Linux
 Summary(pl):   Program pozwalaj±cy uruchamiaæ aplikacje Windows
 Summary(pt_BR):        Executa programas Windows no Linux
 Name:          wine
-Version:       20011108
-Release:       2
-License:       distributable
+Version:       20020710
+Release:       1
+License:       GPL
 Group:         Applications/Emulators
-Group(de):     Applikationen/Emulators
-Group(pl):     Aplikacje/Emulatory
 Source0:       ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
-Source1:       wine.init
-Source2:       wine.reg
-Source3:       wine.systemreg
-Source4:       wine.userreg
+Source1:       %{name}.init
+Source2:       %{name}.reg
+Source3:       %{name}.systemreg
+Source4:       %{name}.userreg
 Patch0:                %{name}-fontcache.patch
 URL:           http://www.winehq.com/
-Exclusivearch: %{ix86}
-BuildRequires: XFree86-devel
-BuildRequires: flex
+ExclusiveArch: %{ix86}
+BuildRequires: arts-devel
 BuildRequires: bison
+BuildRequires: chpax
+BuildRequires: cups-devel
+BuildRequires: docbook-dtd31-sgml
+BuildRequires: docbook-utils
+BuildRequires: flex
+BuildRequires: freetype-devel >= 2.0.5
+BuildRequires: libjpeg-devel
 BuildRequires: ncurses-devel
 BuildRequires: OpenGL-devel
-BuildRequires:  freetype-devel >= 2.0.5
+BuildRequires: openjade
+BuildRequires: XFree86-devel
 Requires:      OpenGL
+Requires(post): ldconfig
+Requires(post,preun): chkconfig
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreqdep   libGL.so.1 libGLU.so.1
-%define                _prefix         /usr/X11R6
-%define                _mandir         %{_prefix}/man
-%define                _winedir        %{_datadir}/%{name}
+%define                _noautoreqdep           libGL.so.1 libGLU.so.1
+%define                no_install_post_strip   1
+
+%define                _prefix                 /usr/X11R6
+%define                _mandir                 %{_prefix}/man
+%define                _winedir                %{_datadir}/%{name}
 
 %description
 Wine is a program which allows running Microsoft Windows programs
@@ -62,41 +71,61 @@ Summary(es):        Biblioteca de desarrollo de wine
 Summary(pl):   Wine - pliki nag³owkowe
 Summary(pt_BR):        Biblioteca de desenvolvimento do wine
 Group:         Development/Libraries
-Group(de):     Entwicklung/Libraries
-Group(es):     Desarrollo/Bibliotecas
-Group(fr):     Development/Librairies
-Group(pl):     Programowanie/Biblioteki
-Group(pt_BR):  Desenvolvimento/Bibliotecas
-Group(ru):     òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
-Group(uk):     òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
 Requires:      %{name} = %{version}
+
 %description devel
 Wine - header files.
 
-%description -l es devel
+%description devel -l es
 Biblioteca de desarrollo de wine.
 
-%description -l pl devel
+%description devel -l pl
 Wine - pliki nag³ówkowe.
 
-%description -l pt_BR devel
+%description devel -l pt_BR
 Arquivos de inclusão e bibliotecas para desenvolver aplicações com o
 WINE.
 
+%package programs
+Summary:       Wine - programs
+Summary(pl):   Wine - programy
+Group:         Applications
+Requires:      %{name} = %{version}
+
+%description programs
+Wine - programs
+
+%description programs -l pl
+Wine - programy
+
 %prep
 %setup -q
 %patch -p1
 
+# turn off compilation of some tools
+sed -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in > .tmp
+mv -f .tmp programs/Makefile.in
+
 %build
-%configure2_13 \
-       --disable-debug \
-       --disable-trace \
+#aclocal
+#autoconf
+CPPFLAGS="-I/usr/include/ncurses"; export CPPFLAGS
+CFLAGS="%{rpmcflags} $CPPFLAGS"
+%configure \
+%{!?debug:     --disable-debug} \
+%{!?debug:     --disable-trace} \
        --enable-curses \
+       --enable-opengl \
        --with-x
 
 %{__make} depend
 %{__make}
+%{__make} -C programs
+
+(cd documentation
+./db2html-winehq wine-user.sgml
+./db2html-winehq wine-devel.sgml
+./db2html-winehq winelib-user.sgml)
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -115,8 +144,31 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man1
        localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
        sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
        mandir=$RPM_BUILD_ROOT%{_mandir} \
-       infodir=$RPM_BUILD_ROOT%{_infodir} 
-       
+       infodir=$RPM_BUILD_ROOT%{_infodir} \
+       dlldir=$RPM_BUILD_ROOT%{_libdir}/wine
+
+%{__make} -C programs install \
+       prefix=$RPM_BUILD_ROOT%{_prefix} \
+       exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
+        bindir=$RPM_BUILD_ROOT%{_bindir} \
+       sbindir=$RPM_BUILD_ROOT%{_sbindir} \
+       sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
+       datadir=$RPM_BUILD_ROOT%{_datadir} \
+       includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
+       libdir=$RPM_BUILD_ROOT%{_libdir} \
+       libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
+       localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
+       sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
+       mandir=$RPM_BUILD_ROOT%{_mandir} \
+       infodir=$RPM_BUILD_ROOT%{_infodir} \
+       dlldir=$RPM_BUILD_ROOT%{_libdir}/wine
+
+(cd $RPM_BUILD_ROOT%{_bindir}
+find -name '*.so' | sed 's|^.|%attr(755,root,root) %{_bindir}|; s|.so$||') > programs.list
+
+install programs/winhelp/hlp2sgml      $RPM_BUILD_ROOT%{_bindir}
+install tools/fnt2bdf                  $RPM_BUILD_ROOT%{_bindir}
+
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
@@ -144,20 +196,61 @@ vcr=mciviscd.drv
 MPEGVideo=mciqtz.drv
 EOF
 
-gzip -9nf README WARRANTY LICENSE DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
+%if %{?debug:0}%{!?debug:1}
+echo "Strip executable binaries and shared object files."
+filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
+elfexelist=`echo $filelist | xargs -r file | \
+       awk '/ELF.*executable/ {print $1}' | cut -d: -f1`
+elfsharedlist=`echo $filelist | xargs -r file | \
+       awk '/LF.*shared object/ {print $1}' | cut -d: -f1`; \
+if [ -n "$elfexelist" ]; then \
+       strip -R .note -R .comment $elfexelist
+fi
+if [ -n "$elfsharedlist" ]; then
+       strip --strip-unneeded -R .note  -R .comment $elfsharedlist
+fi
+%endif
 
-%post   -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+/sbin/chpax -p $RPM_BUILD_ROOT%{_bindir}/wine
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+/sbin/ldconfig
+/sbin/chkconfig --add wine
+if [ ! -f /var/lock/subsys/wine ]; then
+       echo "Run \"/etc/rc.d/init.d/wine start\" to start wine service." >&2
+fi
+
+%preun
+if [ "$1" = "0" ]; then
+       if [ -f /var/lock/subsys/wine ]; then
+               /etc/rc.d/init.d/wine stop >&2
+       fi
+       /sbin/chkconfig --del wine
+fi
+
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
-%doc {README,WARRANTY,LICENSE,DEVELOPERS-HINTS,ChangeLog,BUGS,AUTHORS,ANNOUNCE}.gz
-%doc documentation
-%attr(755,root,root) %{_bindir}/*
+%doc README DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
+%doc documentation/wine-user
+%attr(755,root,root) %{_bindir}/wine
+%attr(755,root,root) %{_bindir}/winebuild
+%attr(755,root,root) %{_bindir}/winemaker
+%attr(755,root,root) %{_bindir}/wineserver
+%attr(755,root,root) %{_bindir}/wineclipsrv
+%attr(755,root,root) %{_bindir}/winelauncher
+%attr(755,root,root) %{_bindir}/wineshelllink
+%attr(755,root,root) %{_bindir}/winedump
+%attr(755,root,root) %{_bindir}/wrc
+%attr(755,root,root) %{_bindir}/wmc
+%attr(755,root,root) %{_bindir}/fnt2bdf
+%attr(755,root,root) %{_bindir}/function_grep.pl
 %attr(755,root,root) %{_libdir}/*.so*
+%{_libdir}/wine
 %{_mandir}/man[15]/*
 %config(noreplace) %{_sysconfdir}/wine.reg
 %config(missingok) %{_sysconfdir}/wine.systemreg
@@ -165,7 +258,13 @@ rm -rf $RPM_BUILD_ROOT
 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/wine
 %{_winedir}
 
+%files programs -f programs.list
+%defattr(644,root,root,755)
+%attr (755,root,root) %{_bindir}/hlp2sgml
+#%{_bindir}/*.so
+
 %files devel
 %defattr(644,root,root,755)
+%doc documentation/{wine-devel,winelib-user,HOWTO-winelib}
 %{_includedir}/wine
 %{_libdir}/*.a
This page took 0.035892 seconds and 4 git commands to generate.