]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- 20020710
[packages/wine.git] / wine.spec
index 0b06778c96413b704f2906dc15834938d4eb1fc4..3a49f33b34e19fa2e1ce324f9dfc72888b4aef65 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -3,9 +3,9 @@ Summary(es):    Ejecuta programas Windows en Linux
 Summary(pl):   Program pozwalajĀ±cy uruchamiaƦ aplikacje Windows
 Summary(pt_BR):        Executa programas Windows no Linux
 Name:          wine
-Version:       20020122
-Release:       6
-License:       distributable
+Version:       20020710
+Release:       1
+License:       GPL
 Group:         Applications/Emulators
 Source0:       ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-%{version}.tar.gz
 Source1:       %{name}.init
@@ -14,15 +14,23 @@ Source3:    %{name}.systemreg
 Source4:       %{name}.userreg
 Patch0:                %{name}-fontcache.patch
 URL:           http://www.winehq.com/
-Exclusivearch: %{ix86}
-BuildRequires: XFree86-devel
-BuildRequires: flex
+ExclusiveArch: %{ix86}
+BuildRequires: arts-devel
 BuildRequires: bison
+BuildRequires: chpax
+BuildRequires: cups-devel
+BuildRequires: docbook-dtd31-sgml
+BuildRequires: docbook-utils
+BuildRequires: flex
+BuildRequires: freetype-devel >= 2.0.5
+BuildRequires: libjpeg-devel
 BuildRequires: ncurses-devel
 BuildRequires: OpenGL-devel
-BuildRequires: freetype-devel >= 2.0.5
-BuildRequires: chpax
+BuildRequires: openjade
+BuildRequires: XFree86-devel
 Requires:      OpenGL
+Requires(post): ldconfig
+Requires(post,preun): chkconfig
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep           libGL.so.1 libGLU.so.1
@@ -95,11 +103,15 @@ Wine - programy
 %patch -p1
 
 # turn off compilation of some tools
-sed -e "s|winetest||;s|avitools||" programs/Makefile.in > .tmp
+sed -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in > .tmp
 mv -f .tmp programs/Makefile.in
 
 %build
-%configure2_13 \
+#aclocal
+#autoconf
+CPPFLAGS="-I/usr/include/ncurses"; export CPPFLAGS
+CFLAGS="%{rpmcflags} $CPPFLAGS"
+%configure \
 %{!?debug:     --disable-debug} \
 %{!?debug:     --disable-trace} \
        --enable-curses \
@@ -132,15 +144,31 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man1
        localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
        sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
        mandir=$RPM_BUILD_ROOT%{_mandir} \
-       infodir=$RPM_BUILD_ROOT%{_infodir}
+       infodir=$RPM_BUILD_ROOT%{_infodir} \
+       dlldir=$RPM_BUILD_ROOT%{_libdir}/wine
 
 %{__make} -C programs install \
        prefix=$RPM_BUILD_ROOT%{_prefix} \
-        bindir=$RPM_BUILD_ROOT%{_bindir}
+       exec-prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
+        bindir=$RPM_BUILD_ROOT%{_bindir} \
+       sbindir=$RPM_BUILD_ROOT%{_sbindir} \
+       sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
+       datadir=$RPM_BUILD_ROOT%{_datadir} \
+       includedir=$RPM_BUILD_ROOT%{_includedir}/wine \
+       libdir=$RPM_BUILD_ROOT%{_libdir} \
+       libexecdir=$RPM_BUILD_ROOT%{_libexecdir} \
+       localstatedir=$RPM_BUILD_ROOT%{_localstatedir} \
+       sharedstatedir=$RPM_BUILD_ROOT%{_sharedstatedir} \
+       mandir=$RPM_BUILD_ROOT%{_mandir} \
+       infodir=$RPM_BUILD_ROOT%{_infodir} \
+       dlldir=$RPM_BUILD_ROOT%{_libdir}/wine
 
 (cd $RPM_BUILD_ROOT%{_bindir}
 find -name '*.so' | sed 's|^.|%attr(755,root,root) %{_bindir}|; s|.so$||') > programs.list
 
+install programs/winhelp/hlp2sgml      $RPM_BUILD_ROOT%{_bindir}
+install tools/fnt2bdf                  $RPM_BUILD_ROOT%{_bindir}
+
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d \
         $RPM_BUILD_ROOT%{_winedir}/windows/{system,Desktop,Favorites,Fonts} \
         "$RPM_BUILD_ROOT%{_winedir}/windows/Start Menu/Programs/Startup" \
@@ -168,8 +196,6 @@ vcr=mciviscd.drv
 MPEGVideo=mciqtz.drv
 EOF
 
-gzip -9nf README WARRANTY LICENSE DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
-
 %if %{?debug:0}%{!?debug:1}
 echo "Strip executable binaries and shared object files."
 filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*"`
@@ -209,7 +235,7 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
+%doc README DEVELOPERS-HINTS ChangeLog BUGS AUTHORS ANNOUNCE
 %doc documentation/wine-user
 %attr(755,root,root) %{_bindir}/wine
 %attr(755,root,root) %{_bindir}/winebuild
@@ -224,6 +250,7 @@ fi
 %attr(755,root,root) %{_bindir}/fnt2bdf
 %attr(755,root,root) %{_bindir}/function_grep.pl
 %attr(755,root,root) %{_libdir}/*.so*
+%{_libdir}/wine
 %{_mandir}/man[15]/*
 %config(noreplace) %{_sysconfdir}/wine.reg
 %config(missingok) %{_sysconfdir}/wine.systemreg
@@ -234,7 +261,7 @@ fi
 %files programs -f programs.list
 %defattr(644,root,root,755)
 %attr (755,root,root) %{_bindir}/hlp2sgml
-%{_bindir}/*.so
+#%{_bindir}/*.so
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.033512 seconds and 4 git commands to generate.