]> git.pld-linux.org Git - packages/wine.git/blobdiff - wine.spec
- add wineg++.1* to files (contains only .so winegcc.1)
[packages/wine.git] / wine.spec
index 8ff07e69f7f15540a5832f956f4985f8f9d70a44..24f51a23bea865ec9c4757e64f9020812a5c3e72 100644 (file)
--- a/wine.spec
+++ b/wine.spec
@@ -1,12 +1,15 @@
 #
 # Conditional build:
 %bcond_without alsa            # don't build ALSA mm driver
-%bcond_without arts            # don't build aRts mm driver
 %bcond_without jack            # don't build JACK mm driver
 %bcond_without nas             # don't build NAS mm driver
 %bcond_without sane            # don't build TWAIN DLL with scanning support (through SANE)
 %bcond_without cups            # without CUPS printing support in winspool,wineps DLLs
 #
+# NOTE:        wineconsole is a bit broken: try wineconsole cmd to see what will happen
+#      As a workaroound use `wineconsole --backend=user cmd' (works fine)
+#      ref: http://bugs.winehq.org/show_bug.cgi?id=8069
+#
 # NOTE: wine detects the following SONAMES for dlopen at build time:
 #   libcrypto,libssl (wininet.dll)
 #   libcups (winspool.dll.so,wineps.dll.so)
 # thus requires rebuild after change of any of the above.
 #
 # JACK requires ALSA
-%if !%{with alsa}
+%if %{without alsa}
 %undefine      with_jack
 %endif
 Summary:       Program that lets you launch Win applications
-Summary(es.UTF-8):   Ejecuta programas Windows en Linux
-Summary(pl.UTF-8):   Program pozwalający uruchamiać aplikacje Windows
-Summary(pt_BR.UTF-8):   Executa programas Windows no Linux
+Summary(es.UTF-8):     Ejecuta programas Windows en Linux
+Summary(pl.UTF-8):     Program pozwalający uruchamiać aplikacje Windows
+Summary(pt_BR.UTF-8):  Executa programas Windows no Linux
 Name:          wine
-Version:       0.9.30
-Release:       0.1
+Version:       0.9.54
+Release:       1
 Epoch:         1
 License:       LGPL
 Group:         Applications/Emulators
 Source0:       http://ibiblio.org/pub/linux/system/emulators/wine/%{name}-%{version}.tar.bz2
-# Source0-md5: ac4e191d99386db1ed83723ac72e93ce
+# Source0-md5: 8d9d5c8ed53f1f97cc997c2612bc3993
 Patch0:                %{name}-fontcache.patch
 Patch1:                %{name}-makedep.patch
-Patch2:                %{name}-alsa.patch
-Patch3:                %{name}-ncurses.patch
+Patch2:                %{name}-ncurses.patch
+Patch3:                %{name}-bug9177_workaround.patch
+Patch4:                %{name}-disable-valgrind.patch
 #PatchX:               %{name}-dga.patch
 URL:           http://www.winehq.org/
 BuildRequires: OpenGL-GLU-devel
@@ -46,7 +50,6 @@ BuildRequires:        OpenGL-GLU-devel
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
-# BuildRequires:       chpax >= 0.20020901-2
 %{?with_cups:BuildRequires:    cups-devel}
 BuildRequires: docbook-dtd31-sgml
 BuildRequires: docbook-utils
@@ -62,19 +65,25 @@ BuildRequires:      libtool
 BuildRequires: ncurses-devel
 # db2* failed previously - probably openjade or opensp bug
 BuildRequires: openjade >= 1:1.3.3-0.pre1
+BuildRequires: openldap-devel >= 2.4.6
 BuildRequires: opensp >= 1:1.5.1
 BuildRequires: openssl-devel >= 0.9.7d
 %{?with_sane:BuildRequires:    sane-backends-devel}
-BuildRequires: valgrind
+#BuildRequires:        valgrind
 BuildRequires: xorg-lib-libXi-devel
 BuildRequires: xorg-lib-libXmu-devel
 BuildRequires: xorg-lib-libXrender-devel
 BuildRequires: xorg-lib-libXxf86dga-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
-Requires:      binfmt-detector
+Suggests:      binfmt-detector
+# For winelauncher
+Suggests:      xorg-app-xmessage
 # link to wine/ntdll.dll.so, without any SONAME
 Provides:      libntdll.dll.so
+Obsoletes:     wine-doc-pdf
+Obsoletes:     wine-drv-arts
 ExclusiveArch: %{ix86}
+ExcludeArch:   i386
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep           libGL.so.1 libGLU.so.1
@@ -113,9 +122,9 @@ chamadas da API para as equivalentes Unix/X11.
 
 %package devel
 Summary:       Wine - header files
-Summary(es.UTF-8):   Biblioteca de desarrollo de wine
-Summary(pl.UTF-8):   Wine - pliki nagłowkowe
-Summary(pt_BR.UTF-8):   Biblioteca de desenvolvimento do wine
+Summary(es.UTF-8):     Biblioteca de desarrollo de wine
+Summary(pl.UTF-8):     Wine - pliki nagłowkowe
+Summary(pt_BR.UTF-8):  Biblioteca de desenvolvimento do wine
 Group:         Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
@@ -134,7 +143,7 @@ WINE.
 
 %package programs
 Summary:       Wine - programs
-Summary(pl.UTF-8):   Wine - programy
+Summary(pl.UTF-8):     Wine - programy
 Group:         Applications
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
@@ -146,7 +155,7 @@ Wine - programy.
 
 %package dll-d3d
 Summary:       Direct3D implementation DLLs for Wine
-Summary(pl.UTF-8):   Biblioteki DLL z implementacją Direct3D dla Wine
+Summary(pl.UTF-8):     Biblioteki DLL z implementacją Direct3D dla Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      OpenGL
@@ -159,7 +168,7 @@ Biblioteki DLL z implementacją Direct3D dla Wine (poprzez OpenGL).
 
 %package dll-gl
 Summary:       OpenGL implementation DLLs for Wine
-Summary(pl.UTF-8):   Biblioteki DLL z implementacją OpenGL dla Wine
+Summary(pl.UTF-8):     Biblioteki DLL z implementacją OpenGL dla Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      OpenGL
@@ -172,7 +181,7 @@ Biblioteki DLL z implementacją OpenGL dla Wine.
 
 %package dll-twain
 Summary:       TWAIN implementation DLL for Wine
-Summary(pl.UTF-8):   Biblioteka DLL z implementacją TWAIN dla Wine
+Summary(pl.UTF-8):     Biblioteka DLL z implementacją TWAIN dla Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
@@ -184,7 +193,7 @@ Biblioteka DLL z implementacją TWAIN dla Wine (poprzez SANE).
 
 %package drv-alsa
 Summary:       ALSA driver for WINE mm.dll implementation
-Summary(pl.UTF-8):   Sterownik ALSA dla implementacji mm.dll w Wine
+Summary(pl.UTF-8):     Sterownik ALSA dla implementacji mm.dll w Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
@@ -194,21 +203,9 @@ ALSA driver for WINE mm.dll (multimedia system) implementation.
 %description drv-alsa -l pl.UTF-8
 Sterownik ALSA dla implementacji mm.dll (systemu multimediów) w Wine.
 
-%package drv-arts
-Summary:       aRts driver for WINE mm.dll implementation
-Summary(pl.UTF-8):   Sterownik aRts dla implementacji mm.dll w Wine
-Group:         Applications/Emulators
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-
-%description drv-arts
-aRts driver for WINE mm.dll (multimedia system) implementation.
-
-%description drv-arts -l pl.UTF-8
-Sterownik aRts dla implementacji mm.dll (systemu multimediów) w Wine.
-
 %package drv-jack
 Summary:       JACK driver for WINE mm.dll implementation
-Summary(pl.UTF-8):   Sterownik JACK-a dla implementacji mm.dll w Wine
+Summary(pl.UTF-8):     Sterownik JACK-a dla implementacji mm.dll w Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      jack-audio-connection-kit
@@ -224,7 +221,7 @@ Wine.
 
 %package drv-nas
 Summary:       NAS driver for WINE mm.dll implementation
-Summary(pl.UTF-8):   Sterownik NAS dla implementacji mm.dll w Wine
+Summary(pl.UTF-8):     Sterownik NAS dla implementacji mm.dll w Wine
 Group:         Applications/Emulators
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 
@@ -240,6 +237,7 @@ Sterownik NAS dla implementacji mm.dll (systemu multimediów) w Wine.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 # turn off compilation of some tools
 sed -i -e "s|winetest \\\|\\\|;s|avitools||" programs/Makefile.in
@@ -321,7 +319,7 @@ rm -f files.programs;       touch files.programs
 cd $RPM_BUILD_ROOT%{_libdir}/wine
 for f in *.so; do
        case $f in
-               d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winearts.drv.so|winejack.drv.so|winenas.drv.so)
+               d3d8.dll.so|d3d9.dll.so|d3dx8.dll.so|glu32.dll.so|opengl32.dll.so|sane.ds.so|twain.dll.so|twain_32.dll.so|winealsa.drv.so|winejack.drv.so|winenas.drv.so)
                        ;;
                *)
                        echo "%attr(755,root,root) %{_libdir}/wine/$f" >>$BZZZ/files.so
@@ -396,6 +394,7 @@ fi
 %attr(755,root,root) %{_bindir}/wineg++
 %attr(755,root,root) %{_bindir}/winegcc
 %attr(755,root,root) %{_bindir}/winemaker
+%attr(755,root,root) %{_bindir}/winecpp
 #%attr(755,root,root) %{_bindir}/winewrap
 %attr(755,root,root) %{_bindir}/wmc
 %attr(755,root,root) %{_bindir}/wrc
@@ -410,6 +409,7 @@ fi
 %{_mandir}/man1/widl.1*
 %{_mandir}/man1/winedump.1*
 %{_mandir}/man1/winegcc.1*
+%{_mandir}/man1/wineg++.1*
 %{_mandir}/man1/winemaker.1*
 %{_mandir}/man1/winebuild.1*
 %{_mandir}/man1/wmc.1*
@@ -441,12 +441,6 @@ fi
 %attr(755,root,root) %{_libdir}/wine/winealsa.drv.so
 %endif
 
-%if %{with arts}
-%files drv-arts
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/wine/winearts.drv.so
-%endif
-
 %if %{with jack}
 %files drv-jack
 %defattr(644,root,root,755)
This page took 0.039295 seconds and 4 git commands to generate.