]> git.pld-linux.org Git - packages/wget.git/blobdiff - wget.spec
- obsoleted, applied upstream
[packages/wget.git] / wget.spec
index 4978bb4ee3f73edc770d0453601a846e52c32658..e907d79c4aceecb5a0a61f539e9e87b0bd101e0d 100644 (file)
--- a/wget.spec
+++ b/wget.spec
@@ -1,34 +1,45 @@
+# TODO
+# - add --delete-remote patches:
+#  - http://wget-bugs.ferrara.linux.it/issue9
+#  - or http://osdir.com/ml/web.wget.patches/2005-09/msg00006.html
+# - add http://article.gmane.org/gmane.comp.web.wget.patches/2333
+#
+# Conditional build:
+%bcond_with    gnutls  # use GnuTLS (wget default) instead of OpenSSL
+#
 Summary:       A utility for retrieving files using the HTTP or FTP protocols
-Summary(es.UTF-8):   Cliente en línea de comando para bajar archivos WWW/FTP con recursión opcional
-Summary(fr.UTF-8):   Un utilitaire pour recuperer des fichiers en utilisant les protocoles HTTP ou FTP
-Summary(pl.UTF-8):   Wsadowy klient HTTP/FTP
-Summary(pt_BR.UTF-8):   Cliente na linha de comando para baixar arquivos WWW/FTP com recursão opcional
-Summary(ru.UTF-8):   Утилита для получения файлов по протоколам HTTP и FTP
-Summary(uk.UTF-8):   Утиліта для отримання файлів по протоколам HTTP та FTP
-Summary(zh_CN.UTF-8):   [通讯]功能强大的下载程序,支持断点续传
+Summary(es.UTF-8):     Cliente en línea de comando para bajar archivos WWW/FTP con recursión opcional
+Summary(fr.UTF-8):     Un utilitaire pour recuperer des fichiers en utilisant les protocoles HTTP ou FTP
+Summary(pl.UTF-8):     Wsadowy klient HTTP/FTP
+Summary(pt_BR.UTF-8):  Cliente na linha de comando para baixar arquivos WWW/FTP com recursão opcional
+Summary(ru.UTF-8):     Утилита для получения файлов по протоколам HTTP и FTP
+Summary(uk.UTF-8):     Утиліта для отримання файлів по протоколам HTTP та FTP
+Summary(zh_CN.UTF-8):  [通讯]功能强大的下载程序,支持断点续传
 Name:          wget
-Version:       1.10.2
-Release:       4
-License:       GPL
+Version:       1.13.4
+Release:       2
+License:       GPL v3+ with OpenSSL exception
 Group:         Networking/Utilities
-Source0:       ftp://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.gz
-# Source0-md5: 795fefbb7099f93e2d346b026785c4b8
+Source0:       http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.xz
+# Source0-md5: 7f518b3a71e9efd330e9a0c3714f8463
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: d8b2b56ec7461606c22edbafaf8a418f
 Patch0:                %{name}-info.patch
-Patch1:                %{name}-ac.patch
-Patch2:                %{name}-pl.patch
-Patch3:                %{name}-wgetrc_path.patch
-Patch4:                %{name}-home_etc.patch
-Patch5:                %{name}-noabort.patch
-URL:           http://wget.sunsite.dk/
-BuildRequires: autoconf >= 2.59
-BuildRequires: automake
-BuildRequires: gettext-devel
-BuildRequires: libtool
-BuildRequires: openssl-devel >= 0.9.8b
-BuildRequires: texinfo
+Patch1:                %{name}-wgetrc_path.patch
+Patch2:                %{name}-home_etc.patch
+Patch3:                %{name}-ssl-certs.patch
+Patch4:                %{name}-pl.po-update.patch
+URL:           http://www.gnu.org/software/wget/
+BuildRequires: autoconf >= 2.61
+BuildRequires: automake >= 1:1.9
+BuildRequires: gettext-devel >= 0.17
+%{?with_gnutls:BuildRequires:  gnutls-devel}
+BuildRequires: libidn-devel
+%{!?with_gnutls:BuildRequires: openssl-devel >= 0.9.7m}
 BuildRequires: perl-devel
+BuildRequires: tar >= 1:1.22
+BuildRequires: texinfo
+BuildRequires: xz
 Provides:      webclient
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -111,22 +122,29 @@ Proxy серверів, настроюваність.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
-rm -f doc/wget.info doc/sample.wgetrc.munged_for_texi_inclusion
+%{__rm} doc/wget.info doc/sample.wgetrc.munged_for_texi_inclusion po/stamp-po
 
-mv -f po/{no,nb}.po
+# temp hack for 1.13.4
+test -e build-aux/bzr-version-gen || cat <<EOF > build-aux/bzr-version-gen
+#!/bin/sh
+echo -n %{version}
+EOF
+chmod +x build-aux/bzr-version-gen
 
 %build
-%{__libtoolize}
 %{__gettextize}
 %{__aclocal} -I m4
 %{__autoheader}
 %{__autoconf}
+%{__automake}
 %configure \
-       --with-ssl
+       --with-ssl%{!?with_gnutls:=openssl}
 %{__make}
 tail -n 6 util/README >rmold.README
 
+# 1.13.4 tarball was buggy and produced empty version.
+grep %{version} src/version.c
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
@@ -135,29 +153,31 @@ install -d $RPM_BUILD_ROOT%{_sysconfdir}
        DESTDIR=$RPM_BUILD_ROOT \
        GETTEXT_PACKAGE=wget
 
-install util/rmold.pl          $RPM_BUILD_ROOT%{_bindir}/rmold
-install doc/sample.wgetrc      $RPM_BUILD_ROOT%{_sysconfdir}/wgetrc
+install -p util/rmold.pl $RPM_BUILD_ROOT%{_bindir}/rmold
+cp -a doc/sample.wgetrc        $RPM_BUILD_ROOT%{_sysconfdir}/wgetrc
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
-rm -f $RPM_BUILD_ROOT%{_mandir}/README*
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/README*
+rm -f $RPM_BUILD_ROOT%{_infodir}/dir
 
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%post  -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun
-[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
+%postun        -p /sbin/postshell
+-/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS TODO README MAILING-LIST rmold.README
+%doc AUTHORS ChangeLog NEWS README MAILING-LIST rmold.README
 %verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/%{name}rc
-%attr(755,root,root) %{_bindir}/*
-%{_mandir}/man1/*
-%lang(hu) %{_mandir}/hu/man1/*
-%lang(pl) %{_mandir}/pl/man1/*
-%{_infodir}/*.info*
+%attr(755,root,root) %{_bindir}/rmold
+%attr(755,root,root) %{_bindir}/wget
+%{_mandir}/man1/wget.1*
+%{_mandir}/hu/man1/wget.1*
+%{_mandir}/pl/man1/wget.1*
+%{_infodir}/wget.info*
This page took 1.410687 seconds and 4 git commands to generate.