]> git.pld-linux.org Git - packages/wget.git/blobdiff - wget.spec
disable y2038 (fixes metalink support on i686)
[packages/wget.git] / wget.spec
index a80802b4647cd21961f82a41c4e9133802e00a7f..ad38ac794b6461e93fa51da3f2e258f07f9cbdd6 100644 (file)
--- a/wget.spec
+++ b/wget.spec
@@ -5,7 +5,8 @@
 # - add http://article.gmane.org/gmane.comp.web.wget.patches/2333
 #
 # Conditional build:
-%bcond_without tests
+%bcond_without tests   # check target
+%bcond_without metalink # build without metalink support
 %bcond_with    gnutls  # use GnuTLS (wget default) instead of OpenSSL
 
 Summary:       A utility for retrieving files using the HTTP or FTP protocols
@@ -17,12 +18,12 @@ Summary(ru.UTF-8):  Утилита для получения файлов по п
 Summary(uk.UTF-8):     Утиліта для отримання файлів по протоколам HTTP та FTP
 Summary(zh_CN.UTF-8):  [通讯]功能强大的下载程序,支持断点续传
 Name:          wget
-Version:       1.17.1
+Version:       1.21.2
 Release:       1
 License:       GPL v3+ with OpenSSL exception
 Group:         Networking/Utilities
-Source0:       http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.xz
-# Source0-md5: b0d58ef4963690e71effba24c105ed52
+Source0:       http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.lz
+# Source0-md5: 2703828579552a5a6749fadfb1bf305d
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: d8b2b56ec7461606c22edbafaf8a418f
 Patch0:                %{name}-info.patch
@@ -31,19 +32,22 @@ Patch2:             %{name}-home_etc.patch
 Patch3:                %{name}-ssl-certs.patch
 Patch4:                user.xdg.origin.url.patch
 URL:           http://www.gnu.org/software/wget/
-BuildRequires: attr-devel
-BuildRequires: autoconf >= 2.61
+BuildRequires: autoconf >= 2.64
+BuildRequires: autoconf-archive
 BuildRequires: automake >= 1:1.9
-BuildRequires: gettext-tools >= 0.17
-%{?with_gnutls:BuildRequires:  gnutls-devel}
-BuildRequires: gpgme-devel >= 0.4.2
-BuildRequires: libidn-devel
-BuildRequires: libmetalink-devel
-BuildRequires: libpsl-devel
+BuildRequires: gettext-tools >= 0.19.8
+# >= 3.6.3 for TLSv1.3
+%{?with_gnutls:BuildRequires:  gnutls-devel >= 3.0.16}
+%{?with_metalink:BuildRequires:        gpgme-devel >= 0.4.2}
+BuildRequires: libidn2-devel
+%{?with_metalink:BuildRequires:        libmetalink-devel}
+BuildRequires: libpsl-devel >= 0.16.0
 BuildRequires: libuuid-devel
-%{!?with_gnutls:BuildRequires: openssl-devel >= 0.9.7m}
-BuildRequires: pcre-devel
+# >= 1.1.0 for TLSv1.3
+%{!?with_gnutls:BuildRequires: openssl-devel >= 1.0.1}
+BuildRequires: pcre2-8-devel
 BuildRequires: perl-devel
+BuildRequires: pkgconfig
 BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo
 BuildRequires: xz
@@ -55,6 +59,9 @@ BuildRequires:        perl-IO-Socket-SSL
 BuildRequires: python3-modules >= 1:3.0
 %endif
 Provides:      webclient
+%{?with_gnutls:Requires:       gnutls-libs >= 3.0.16}
+%{!?with_gnutls:Requires:      openssl >= 1.0.1}
+Requires:      libpsl >= 0.16.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqfiles         %{_bindir}/rmold
@@ -146,6 +153,8 @@ echo -n %{version}
 EOF
 chmod +x build-aux/bzr-version-gen
 
+%{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' util/rmold.pl
+
 %build
 %{__gettextize}
 %{__aclocal} -I m4
@@ -153,7 +162,6 @@ chmod +x build-aux/bzr-version-gen
 %{__autoconf}
 %{__automake}
 %configure \
-       --disable-debug \
        --enable-digest \
        --enable-ipv6 \
        --enable-iri \
@@ -162,8 +170,10 @@ chmod +x build-aux/bzr-version-gen
        --enable-ntlm \
        --enable-opie \
        --enable-pcre \
+       --disable-silent-rules \
+       --disable-year2038 \
        --with-libpsl \
-       --with-metalink \
+       %{__with_without metalink} \
        --with-ssl%{!?with_gnutls:=openssl} \
        --with-zlib \
        %{nil}
@@ -190,7 +200,8 @@ bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README*
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
 
-%find_lang %{name}
+# "wget" and "wget-gnulib" domains
+%find_lang %{name} --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -204,7 +215,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README MAILING-LIST rmold.README
-%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/%{name}rc
+%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/wgetrc
 %attr(755,root,root) %{_bindir}/rmold
 %attr(755,root,root) %{_bindir}/wget
 %{_mandir}/man1/wget.1*
This page took 0.032581 seconds and 4 git commands to generate.