]> git.pld-linux.org Git - packages/wget.git/blobdiff - wget.spec
disable y2038 (fixes metalink support on i686)
[packages/wget.git] / wget.spec
index 68c43654fb7361abed1a7125087a4a83ea9d2773..ad38ac794b6461e93fa51da3f2e258f07f9cbdd6 100644 (file)
--- a/wget.spec
+++ b/wget.spec
@@ -3,6 +3,12 @@
 #  - http://wget-bugs.ferrara.linux.it/issue9
 #  - or http://osdir.com/ml/web.wget.patches/2005-09/msg00006.html
 # - add http://article.gmane.org/gmane.comp.web.wget.patches/2333
+#
+# Conditional build:
+%bcond_without tests   # check target
+%bcond_without metalink # build without metalink support
+%bcond_with    gnutls  # use GnuTLS (wget default) instead of OpenSSL
+
 Summary:       A utility for retrieving files using the HTTP or FTP protocols
 Summary(es.UTF-8):     Cliente en línea de comando para bajar archivos WWW/FTP con recursión opcional
 Summary(fr.UTF-8):     Un utilitaire pour recuperer des fichiers en utilisant les protocoles HTTP ou FTP
@@ -12,27 +18,50 @@ Summary(ru.UTF-8):  Утилита для получения файлов по п
 Summary(uk.UTF-8):     Утиліта для отримання файлів по протоколам HTTP та FTP
 Summary(zh_CN.UTF-8):  [通讯]功能强大的下载程序,支持断点续传
 Name:          wget
-Version:       1.13
+Version:       1.21.2
 Release:       1
 License:       GPL v3+ with OpenSSL exception
 Group:         Networking/Utilities
-Source0:       http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.xz
-# Source0-md5: 48c5384123156e7b7501d2f5b5c7189a
+Source0:       http://ftp.gnu.org/gnu/wget/%{name}-%{version}.tar.lz
+# Source0-md5: 2703828579552a5a6749fadfb1bf305d
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: d8b2b56ec7461606c22edbafaf8a418f
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-wgetrc_path.patch
 Patch2:                %{name}-home_etc.patch
 Patch3:                %{name}-ssl-certs.patch
+Patch4:                user.xdg.origin.url.patch
 URL:           http://www.gnu.org/software/wget/
-BuildRequires: autoconf >= 2.61
+BuildRequires: autoconf >= 2.64
+BuildRequires: autoconf-archive
 BuildRequires: automake >= 1:1.9
-BuildRequires: gettext-devel >= 0.17
-BuildRequires: libtool
-BuildRequires: openssl-devel >= 0.9.7m
+BuildRequires: gettext-tools >= 0.19.8
+# >= 3.6.3 for TLSv1.3
+%{?with_gnutls:BuildRequires:  gnutls-devel >= 3.0.16}
+%{?with_metalink:BuildRequires:        gpgme-devel >= 0.4.2}
+BuildRequires: libidn2-devel
+%{?with_metalink:BuildRequires:        libmetalink-devel}
+BuildRequires: libpsl-devel >= 0.16.0
+BuildRequires: libuuid-devel
+# >= 1.1.0 for TLSv1.3
+%{!?with_gnutls:BuildRequires: openssl-devel >= 1.0.1}
+BuildRequires: pcre2-8-devel
 BuildRequires: perl-devel
+BuildRequires: pkgconfig
+BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo
+BuildRequires: xz
+BuildRequires: zlib-devel
+%if %{with tests}
+BuildRequires: perl-HTTP-Daemon
+BuildRequires: perl-HTTP-Message
+BuildRequires: perl-IO-Socket-SSL
+BuildRequires: python3-modules >= 1:3.0
+%endif
 Provides:      webclient
+%{?with_gnutls:Requires:       gnutls-libs >= 3.0.16}
+%{!?with_gnutls:Requires:      openssl >= 1.0.1}
+Requires:      libpsl >= 0.16.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqfiles         %{_bindir}/rmold
@@ -113,19 +142,49 @@ Proxy серверів, настроюваність.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%{__rm} doc/wget.info doc/sample.wgetrc.munged_for_texi_inclusion
+%patch4 -p1
+
+%{__rm} doc/wget.info doc/sample.wgetrc.munged_for_texi_inclusion po/stamp-po
+
+# temp hack for 1.13.4
+test -e build-aux/bzr-version-gen || cat <<EOF > build-aux/bzr-version-gen
+#!/bin/sh
+echo -n %{version}
+EOF
+chmod +x build-aux/bzr-version-gen
+
+%{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' util/rmold.pl
 
 %build
-%{__libtoolize}
 %{__gettextize}
 %{__aclocal} -I m4
 %{__autoheader}
 %{__autoconf}
+%{__automake}
 %configure \
-       --with-ssl
+       --enable-digest \
+       --enable-ipv6 \
+       --enable-iri \
+       --enable-largefile \
+       --enable-nls \
+       --enable-ntlm \
+       --enable-opie \
+       --enable-pcre \
+       --disable-silent-rules \
+       --disable-year2038 \
+       --with-libpsl \
+       %{__with_without metalink} \
+       --with-ssl%{!?with_gnutls:=openssl} \
+       --with-zlib \
+       %{nil}
 %{__make}
 tail -n 6 util/README >rmold.README
 
+# 1.13.4 tarball was buggy and produced empty version.
+grep %{version} src/version.c
+
+%{?with_tests:%{__make} check}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
@@ -138,10 +197,11 @@ install -p util/rmold.pl $RPM_BUILD_ROOT%{_bindir}/rmold
 cp -a doc/sample.wgetrc        $RPM_BUILD_ROOT%{_sysconfdir}/wgetrc
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
-rm -f $RPM_BUILD_ROOT%{_mandir}/README*
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/README*
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
 
-%find_lang %{name}
+# "wget" and "wget-gnulib" domains
+%find_lang %{name} --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -155,7 +215,7 @@ rm -rf $RPM_BUILD_ROOT
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README MAILING-LIST rmold.README
-%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/%{name}rc
+%verify(not md5 mtime size) %config(noreplace) %{_sysconfdir}/wgetrc
 %attr(755,root,root) %{_bindir}/rmold
 %attr(755,root,root) %{_bindir}/wget
 %{_mandir}/man1/wget.1*
This page took 0.063925 seconds and 4 git commands to generate.